Jump to content
Ultimaker Community of 3D Printing Experts

Cura 13.03 error: 'Attempt to retrieve context when no valid context'


pablobell

Recommended Posts

Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

When Cura starts, a popup window shows this message 'Attempt to retrieve context when no valid context', and then the 3D view is completely white.

This does not prevent the slicer from working perfectly. The 3D view is mostly cosmetic, and you can load an object, prepare and print it using the File menu.

According to Daid, this issue happens in some ATI Radeon cards, and is already reported at https://github.com/daid/Cura/issues/393.

 

  • Link to post
    Share on other sites
    • 2 months later...
    Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

    Has anyone solved this problem? I installed Autdesk DWG Trueview yesterday, which brought along a DirectX 11 install with it, and Cura is now broken.

    I tried changing the buffer size in the line Daid suggested in OpenglGUI.py, but nothing changed.

    Also tried cleanly uninstalling and then reinstalling latest graphics drivers. No difference.

     

  • Link to post
    Share on other sites
    Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

    That last one is telling me that you are missing OpenGL shaders support. Which is really odd. I think the install of Autodesk DWG messed something up in your video card drivers. I recommend installing the drivers from you video card supplier.

    (OpenGL shader support is really standard, even my 5 year old cheap vista laptop has it)

    Note, my laptop has DX11, and I think a lot more users have DX11. But if we can get closer to the cause then this would be great

     

  • Link to post
    Share on other sites
    Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

    Yeah, I have a decent laptop which was running Cura fine until a few days ago when this started. I tried reinstalling my graphics drivers to no effect. I guess it would be more correct to say that TrueView updated DirectX, but I'm not exactly sure what the version it used was. Using the most recent DirectX installer from Microsoft says that my DirectX install is up to date.

     

  • Link to post
    Share on other sites
    Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

    So, I just scoured heaven and earth to purge my system of old video drivers and install various new drivers - official releases, beta versions, and homebrew hacked ones. Nothing changed the error message Cura is giving me.

    I don't know where else to look. Is there possibly an Opengl related registry flag that might have been set incorrectly and then not reset upon uninstall of Trueview?

     

  • Link to post
    Share on other sites
    Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

    So, I just scoured heaven and earth to purge my system of old video drivers and install various new drivers - official releases, beta versions, and homebrew hacked ones. Nothing changed the error message Cura is giving me.

    I don't know where else to look. Is there possibly an Opengl related registry flag that might have been set incorrectly and then not reset upon uninstall of Trueview?

     

    Hi Nick

    Could you do a system restore back to before it started?

     

  • Link to post
    Share on other sites
    Posted · Cura 13.03 error: 'Attempt to retrieve context when no valid context'

    Hi Nick

    Could you do a system restore back to before it started?

     

    Unfortunately, no. Due to the video driver swapping all of my system restore points where overwritten by garbage. Actually, even attempting it just almost wrecked my computer as it left me with some hybrid driver install that wouldn't render windows properly.

    Maybe it's time to pack my things and start prepping for the fresh reinstall of Windows entirely...

    Update - bit the bullet, reinstalled windows. Happily using Cura with proper previews again...

     

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...