Jump to content
Ultimaker Community of 3D Printing Experts
XYZDesignPro

Cura 2.5 Final Manual Setting of Z location

Recommended Posts

In 2.5 you can set the X and Y locations manually by entering the distance in the box in the upper left corner and pressing either Enter or Tab, moving to the next field. However when entering the Z value, and pressing Enter or Tab the field always reverts back to the previous value. The only way to change the Z value is to drag the Z arrow. Not very accurate. 2.4 does not behave this way.

Am I missing something?

Share this post


Link to post
Share on other sites

Am I missing something?

Perhaps you have enabled the setting "Automatically drop models to the build plate" (Preferences -> General)?

That setting is enabled by default and simply assures placement the model at the 0 "Z" location. There are times when I need to set the model at -0.2mm "Z". That has the effect of burying the model 0.2mm into the build plate, to assure good build plate adhesion. The fact that I cannot do this in 2.5, but had no problems with it in 2.4 and earlier versions of Cura tells me this is a bug. Unless someone can jump in here and tell me what I'm missing.

Can you try it for yourself and see if you can type in a specific Z location? The X and Y locations work as they did in 2.4 and earlier, but I'm unable to enter a specific Z location and have Cura accept it.

Thanks.

Share this post


Link to post
Share on other sites

Can you try it for yourself and see if you can type in a specific Z location?  The X and Y locations work as they did in 2.4 and earlier, but I'm unable to enter a specific Z location and have Cura accept it.

Hi, I just tried that using version 2.5 and initially it didn't seem to want to accept a value typed in the Z field but then I clicked around some other stuff and afterwards I could enter whatever I wanted in the Z field so perhaps there's some weird focus problem there?

Edited by Guest

Share this post


Link to post
Share on other sites

Can you try it for yourself and see if you can type in a specific Z location?  The X and Y locations work as they did in 2.4 and earlier, but I'm unable to enter a specific Z location and have Cura accept it.

Hi, I just tried that using version 2.5 and initially it didn't seem to want to accept a value typed in the Z field but then I clicked around some other stuff and afterwards I could enter whatever I wanted in the Z field so perhaps there's some weird focus problem there?

Were you using 2.5 BETA or 2.5 Final? In any case, it would appear that Tinkergnome is at least partially correct. If you disable "Automatically drop models to the build plate" the correct functionality is restored. Of course the user now has to set the "Z" to 0 manually, but it does solve the problem.

Thanks.

Share this post


Link to post
Share on other sites

I was about to post a topic on this issue too, so I'm joining the conversation. I am using Cura 2.5 final as well, on OS X 10.11.6.

When dropping a model on the build plate with "Automatically drop models to the build plate" disabled my model loads halfway below Z=0. Changing the value to 0 manually indeed doesn't work and the Z-value is reverted to the previous negative value, while dragging the model upwards does. After dragging the model up I can change or drag the value to anything I want. Turning the automatic drop option back on reverts the issue, now I can't change the Z-value to anything else than 0.

Share this post


Link to post
Share on other sites

I was about to post a topic on this issue too, so I'm joining the conversation. I am using Cura 2.5 final as well, on OS X 10.11.6.

When dropping a model on the build plate with "Automatically drop models to the build plate" disabled my model loads halfway below Z=0. Changing the value to 0 manually indeed doesn't work and the Z-value is reverted to the previous negative value, while dragging the model upwards does. After dragging the model up I can

change or drag the value to anything I want. Turning the automatic drop option back on reverts the issue, now I can't change the Z-value to anything else than 0.

Yes, that is the same problem / symptoms. It's not a deal breaker, but it does appear to be a bug in 2.5 Final that I've not experienced in earlier versions. I'm now just leaving "Automatically drop models to the build plate" setting un-checked, and setting the Z to 0 manually. Not a big deal.

Perhaps it will be addressed in 2.6 . . . :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!