Jump to content
Ultimaker Community of 3D Printing Experts

Cura 2.5.0 Massive Memory Usage


Recommended Posts

Posted · Cura 2.5.0 Massive Memory Usage

I just checked with an unloaded file and my 2.5 only registers at 372.2 MB. That seems in line with other programs running.

It really jumps when I load models, but I have a tendency to use hyper large models (vertex count).

  • Link to post
    Share on other sites
    Posted (edited) · Cura 2.5.0 Massive Memory Usage

    Do you have a printer added? If so, is it connected?

    Do you have a model loaded? Were you currently in Layer View, or printing?

    For the record: I have a couple of printers added in my Cura 2.5, none of which are currently connected, and without any models loaded it uses ~360 Mb (depending on which printer is active due to the build plate mesh) and 0% CPU use in the Solid view.

    PS: (could not resist)

    gqtpBYZ.gif

    You call that massive?

    We've seen memory leaks where Cura takes up many, many gigabytes of memory.

    We do take this seriously though, so any additional information you can add is useful. Does the memory use (slowly) creep up?

    Edited by Guest
  • Link to post
    Share on other sites
    Posted (edited) · Cura 2.5.0 Massive Memory Usage

    I just did a test. When I start Cura, it registers about 375MB in task manager.

    I loaded a file (STL 357,723KB listed in explorer).

    Cura then registered at 2,643.9 MB in solid view/2,677.2MB Layers in task manager.

    Then, clearing the build plate Cura 2,661.3 MB in task manager.

    Loading another file (STL 263,510KB listed in explorer)

    Cura then registered at 3,728.1 MB in solid view/4,107.6MB Layers in task manager.

    Then, clearing the build plate Cura 3,989.2 MB in task manager.

    I reloaded the first file (STL 357,723KB listed in explorer).

    Cura then registered at 5,053.6 MB in solid view/5,053.7MB Layers in task manager.

    ande reLoading the second file (STL 263,510KB listed in explorer)

    Cura then registered at 5,705.1 MB in solid view/5,881.2MB Layers in task manager.

    But, relaunching Cura it went to 374.9MB.

    So, it does seem to grow while in use, but seems to release it when closed out.

    Edited by Guest
  • Link to post
    Share on other sites
    Posted (edited) · Cura 2.5.0 Massive Memory Usage

     

    Mine is 684 MB... 12% CPU consumption. That's heavy but still seems normal

     

    I wonder why I would be running almost half your usage. Did you have anything loaded? Extra Plugins?

     

    I have a model loaded with layer view active, and LAN printer connection. That may be the reason...

    but I don't find it abnormal, today we have dual core / 16 GB memory rigs, so no pb...

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Cura 2.5.0 Massive Memory Usage

    Mine is 684 MB... 12% CPU consumption. That's heavy but still seems normal

    I wonder why I would be running almost half your usage. Did you have anything loaded? Extra Plugins?

    I have a model loaded with layer view active, and LAN printer connection. That may be the reason...

    but I don't find it abnormal, today we have dual core / 16 GB memory rigs, so no pb...

    I did not either until I ran the tests above to see how it worked. It definitely built up from job to job (Files loaded). Although it 'reset' to a nominal level when cleared, when the models were loaded, it kept growing although I was using the same files.

    I did find that odd. It may also be why I get different times sometimes on the same file. It can be as much as one or more hours on a complicated print.

  • Link to post
    Share on other sites
    Posted · Cura 2.5.0 Massive Memory Usage

    PS: (could not resist)

    gqtpBYZ.gif

    [[bEEP]] What is Kill Bill Vol 2?

    :p:P:P

  • Link to post
    Share on other sites
    Posted (edited) · Cura 2.5.0 Massive Memory Usage

    Was working on a few models this morning, work on one close down open cura again work on the other.  Left one open for 20mins and it had gone up to the below.

    Cura open, with part sliced and is in layer view model.  UM3 is on network but no files have been sent to the machine.

    Its happened a few times, where windows shuts down cura on its own as it said you have run out of memory.

    Even our CAD software with a large assembly open doesn't consume this type of memory and Simplify 3D is running simultaneously at only 4.1MB with the same part in layer view.

    5a33387ee05f3_CuraMemoryUsage2.thumb.JPG.afd7da40ceacd35a4794fa36431aee09.JPG

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Cura 2.5.0 Massive Memory Usage

    We've had one more report of a memory leak when a UM3 is connected to Cura:

    https://github.com/Ultimaker/Cura/issues/1632#issuecomment-294369252

    (In that case: 22 Gb in "a couple of hours", hence my remark about the ~780 Mb memory use)

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...