Jump to content
Ultimaker Community of 3D Printing Experts

Damaged electronics of print head cooling fan?


Recommended Posts

Posted · Damaged electronics of print head cooling fan?

Specs: Ultimaker Original with PCB 1.5.4.

I think I've short circuited the fan output of the fan at the print head. The fan does not behave as expected. E.g. a 24vdc fan turns on at full speed (M106 S255) but not at halve speedd (M106 S128). Where as this 24vdc works with a 12vdc power supply. So the part of the circuit it is about is from Arduino pin 7 (pin 8 at PCB connector, going to R20 of 1Kohm to Q4 (BD679 Transistor) to PWM terminal to where the fan can be connected.

I have the following set up to test it: Arduino Mega + PCB connected through USB cable to computer with a COM terminal to send GCODEs. I have a multimeter and oscilloscope at my disposal. When I connect the Arduino and open the COM I get some output of saying that temperature and what not gives errors (make sense as nothing is connected to the PCB). It says M999 to restart, so I send that code and it replies with OK. When I then send the GCODE to turn on the fan "M106 S[1-255]" like "M106 S128" for example I can measure a 5v PWM signal coming from Arduino pin 7 with a correct duty cycle. So the port is working. The voltage after R20 (1Kohm resistor), or at Base of Q4 is 1.28v.

Question 1:

From what I can see is that the fan is powered with the same voltage as the power supply (16-20Vdc). But the fan is 12v. So at full speed (M106 S255) the 12vdc fan need to take care of the 20vdc continuously? Is this correct? Or am I mistaken?

Question 2:

From what I know understand is that 5v is drops to 1.28 volt after 1KOhm resistance. Meaning that (5v-1.28v=)3.72v dropped on 1KOhm. Meaning that the Base of Q4 provides ((1000Ohm/3.72v)*1.28v=)344Ohm resistance. Seeing the datasheet of Q4 (BD679) I do not understand where this restistance of 344Ohm coming from. Is the voltage drop of 5v to 1.28v from PWM port 7 of Arduino to Base of Q4 Transistor normal?

Thank you.

  • Link to post
    Share on other sites
    Posted · Damaged electronics of print head cooling fan?

    In short:

    - Yes the UMO has this crazy thing: the 12V fan is powered at 19V and it works... Not all fans will survive this, but at least the one Ultimaker provides works ;)

    - Your transistor is most probably dead, just replace it -- on an 1.5.x board it is really easy.

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...