Jump to content
foehnsturm

Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Recommended Posts

Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I installed it and am working on step 6 calibration.

How to check if Mark 2 board works?

 

Well do you know much about electricity? Do you have an ohm meter? If not do you have a friend that understands how to test wires and simple circuits and owns an ohm meter?

What happens when you go into the menu on your UM2 and look at the temperature of the second head? What temp does it read? What happens when you try to set it to a higher temperature?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I installed it and am working on step 6 calibration.

How to check if Mark 2 board works?

What exact problem do you have at the moment? Is it still this one:

The issue is 'nozzle 2' doesn't shows up in 'dual extrusion' mode.

In this case, I would assume that something went wrong with the firmware update. As gr5 pointed out, there is no such thing as printhead auto-discovery.

Are you sure that you picked up the right version of the firmware? Anything happened during the firmware upload process?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I am looking for a sample/template factory file for Simplify3D for Mark 2. I remember that there was one around, but can't find it.

Anyone still knows where this was mentioned / published?

And once we have it, should we add it to the Mark 2 Git repository?

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

There is something:

http://ultimaker.com/en/community/48788-ultimaker-mark2-the-smart-dual-extrusion-upgrade?page=12&sort=#reply-181802

https://www.dropbox.com/sh/nbc006f6ym2d6b9/AAD8J_Mv_j4y6Hq3KEtJRvcea?dl=0

(page 12, first entry, by @MarcoUbtz)

@SanderVG,

there's something wrong with the permalink. I think they are not supposed to be amazonaws urls ;-)

Edited by gr5

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Just replace everything from "elb" to ".com" with "ultimaker.com" and the link will work. I'll edit it now for you.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

The S3D dual profile of MarcoUbtz I linked above worked pretty quickly, thanks, Marco! :-)

But somehow S3D feels so much less intelligent in dual printing than Cura, once you got used to the new Cura 2. Not so happy with how it behaves.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

My first result with 4.0 on dual extrusion is, bad. maybe some "tuning" to do.

The thing i don't like about Cura, is the overall feeling of the program, with its settings menu's, it is slow and there is no logic in the interface, as with S3D it is very nice, and easy to find settings and change things. But probaly at this moment it is the best dual extrusion solution?

Will have to make some more prints with S3D 4.0 before final judgement.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

My first result with 4.0 on dual extrusion is, bad. maybe some "tuning" to do.

Yes, that's also my experience every time I work with S3D. While Cura is perfectly tuned to work with the Ultimaker you need to find a bunch of settings in S3D yourself. Of course it's the same with dual, you need to tune yourself, what Cura already has.

And it seems to be less clever in dual printing than Cura. For example the preheating of nozzles while the other ones prints. I was quite "surprised" to see that the new toolhead sat there after tool change and took 20 seconds to heat up.... in the first moment I wondered why it would not print.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

@SanderVG,

there's something wrong with the permalink. I think they are not supposed to be amazonaws urls ;-)

Thanks, we just moved to new servers to make the site faster. Did you notice any difference? These incorrect links are/were only suppose to last very briefly as a short aftermath from the move. I'll check when it is expected to work as normal. Our apologies for the inconvenience.
  • Like 2

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

@SanderVG,

there's something wrong with the permalink. I think they are not supposed to be amazonaws urls ;-)

Thanks, we just moved to new servers to make the site faster. Did you notice any difference? These incorrect links are/were only suppose to last very briefly as a short aftermath from the move. I'll check when it is expected to work as normal. Our apologies for the inconvenience.

Ah, that's the reason for the downtimes the last days.

I'd say the site is still not "fast". If it's faster than before I can't tell really, the feeling is still - "uh, I have to reload, that will take a while".

Just did a test, it's still some 4-5 seconds for a reload. For my taste and expectation that's 3-4 seconds too much :-)

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I'd like to minimize filament oozing when a head is not used, through modifying toolchange retract parameters.

When I tweak those values in the printer menu while printing, it doesn't seem to change anything.

Is it actually handled somewhere else (cura) ?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

If the Mark2 works with G10/G11 it should take the values from the printer settings. Otherwise retraction recognition (the feature is called somehow different) in Marlin would have to be enabled to be able to change it on the printer. If none of those is true, Cura handles the retraction settings.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I'd like to minimize filament oozing when a head is not used, through modifying toolchange retract parameters.

When I tweak those values in the printer menu while printing, it doesn't seem to change anything.

Is it actually handled somewhere else (cura) ?

The length of the tool change retraction can be tuned during a print, but the effect on oozing highly depends on the used material (and is not that big...). Usually it is more important to find the optimal temperature and retract speed.

Which material do you use? What are the values for toolchange retract?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I'm experimenting with PETG as a support for PLA.

Basically, there is a lot of oozing with the PETG print head.

For the toolretract of tool 2, I tried "Length: 8mm; Speed: 40mm/s" but I don't feel it changes anything.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I recommend you don't go over 4.5mm. If you retract too much air can get in the nozzle and then very quickly eat up and meanwhile there is filament at the bottom of the nozzle and so that heated air creates pressure and pushes some filament out and then more air can get in...

Later when you start extruding there is an air pocket in there. It's fine at first and then it might stop extruding for a while.

I could be wrong about all this but definitely it doesn't make sense to me to retract more than the standard 4.5mm unless your bowden is loose.

Better to lower the temperature much more when not printing? Or maybe use a wipe shield?

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I could be wrong about all this but definitely it doesn't make sense to me to retract more than the standard 4.5mm unless your bowden is loose.

George, that's true for normal retractions. But Melka asked for the toolchange retract of the inactive nozzle (in Cura it's called "Nozzle Switch Retraction") - that's a different thing...

The default for the Mark2 is 16 mm at 20 mm/s (the same as the "end-of-print" retraction - more or less).

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I could be wrong about all this but definitely it doesn't make sense to me to retract more than the standard 4.5mm unless your bowden is loose.

George, that's true for normal retractions. But Melka asked for the toolchange retract of the inactive nozzle (in Cura it's called "Nozzle Switch Retraction") - that's a different thing...

The default for the Mark2 is 16 mm at 20 mm/s (the same as the "end-of-print" retraction - more or less).

Looks like this setting is hidden in Cura for the Mark2 profile.

Do you know how we could activate it ?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Looks like this setting is hidden in Cura for the Mark2 profile.

That's intended, just use the according setting on the printer. An additional retract from the slicer would interfere with the firmware value and probably end up in a big mess...

BTW: what is the reason for the reduced length (8 mm), did you had issues with the default retraction (16 mm)?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Do you guys know what is this witchcraft Cura 2.6.2 is doing ?

weird1.thumb.PNG.7572a1923bd1d2734e27ad86a9982725.PNG

wird2.thumb.PNG.03511af9de0834e435f346fe17ee7275.PNG

Of course, it crashes the printhead...

Are we supposed to set the X/Y layer start position ?

Project here: https://1drv.ms/u/s!AgmRtaUlyi-AkatGjQ7MSffV3vFKuQ

Had the same issue last week. You need to set Travel > X/Y Layer start to something 100/45. For both extruders.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

BTW: what is the reason for the reduced length (8 mm), did you had issues with the default retraction (16 mm)?

It was a problem on my end, I set it back to 16mm.

My tests using PETG as a support for PLA are a bit underwhelming.

I do obtain crazy good surface on the PLA when peeling off, but often struggle with PLA adhesion on PETG.

The adhesion is a bit too weak, it's sad because for some parts it works really well.

The second issue is about the oozing, I can't make it stop, if I lower the temp on extruder 2 (PETG) to 220, I get troubles extruding properly, especially when printing small support structures. I did not see the effect of bigger or faster toolretracts.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

After some time working with the Mark 2, i must say it works really well!!! Toolhead changes work reliable, calibration is steady. Once everything is measured in, ;-)

I use the second head mainly for 2 color prints, or supporting material. I use PVA (delicate parts) and Polysupport, which i like very much, because of the ease of use!

At this moment 1 thing is not working ok, when i use wipe wall in cura (2.6-2.7 beta), the nozzle is already inside the print area (inside the the wipewall) when the printing are is reached after a toolhead change. No wipe is done on the wall.

When i use a prime pillar, the head goes over the center of the bed where my print is, before going to the prime pillar.

And it would be really nice, to be able to set the speeds of X , Y and Z axe for the toolhead change movements. They are now very noisy with my printer, which is in my linving room, if i could tune these values, it would be nice. Maybe i would sacrify some speed versus less noise.

Happy printing!!!!

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Actually if you want to experiment you can already change the tool change code by reading them in from a SD card (details earlier described here somewhere).

But it would be very nice, also for other developments (ZGE) to be able to set the code without the need to load it from SD at every printer poweron. But I believe according to @tinkergnome this is not so easy (what was it? memory availability?)

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

And about the printhead moving to the center of the bed before moving to the prime tower. did anyone find a solution for this? It's indeed annoying...

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Actually if you want to experiment you can already change the tool change code by reading them in from a SD card (details earlier described here somewhere).

Can you point me in the right direction? can't find it?

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!