Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade


Recommended Posts

Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
21 minutes ago, tinkergnome said:

 

I added two things to the "After print is finished"-script, retract the filament a bit (additional 11 mm as "end-of-print-retraction")
and home all axis.

I think Octoprint does this not automatically  - in opposite to the firmware if you print from sdcard.

Yes I just finished the test print and the head just stopped on top of the print. I then added the same end-script I have in Cura (from the mark2 config) but it still just stops:

 

G90
M104 S0 T0
M104 S0 T1
M140 S0
T0
M107

 

This should work in Octoprint, right? But it still just stops.

I don't quite get why an end script is needed anyway isn't this part of the gcode

 

EDIT: Well this doesn't work at all even when I try to send it over the terminal. 

If I want to home everything at the end I can send this and it works, it actually seems to be enough to just send this because it does automatically retract a little and turns the heating off, so all that's missing in the end is the homeing procedure for the head and the bed:

G28 X Y
G28 Z

However it would be nice to be able to perform an extruder change at the end as well, just to make sure everything is nicely reset and ready for the next print.

Can Octoprint not read any of the above? I think especially the part for putting the second print head into the parking position should be part of the end-script.

Edited by Glomby
  • Link to post
    Share on other sites
    • Replies 971
    • Created
    • Last Reply

    Top Posters In This Topic

    Top Posters In This Topic

    Popular Posts

    @zerspaner_gerd & @MarcoUbtz Thank you gentlemen, everything is working perfectly now   https://www.youmagine.com/designs/flexible-coupler-using-colorfabb-ngen-flex  

    Hi guys, After years of following the evolution of the mark2 project, I finally got my hands on relatively cheap second-hand Ultimaker 2 (non plus that wasn't in the best shape to be honest) and di

    Already found?? Here are my noted links:   https://forum.simplify3d.com/viewtopic.php?f=8&t=1959    

    Posted Images

    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    4 minutes ago, Glomby said:

    I don't quite get why an end script is needed anyway isn't this part of the gcode

     

    Some steps are done by the firmware, if the print was started from the sdcard. These are usually not in the gcode.

    If you add it generally, the home command (e.g.) would work, if you print via USB, but would be executed twice if you start the same gcode from sdcard.

     

    I use this for "After print job completes" and "After print job is cancelled":

     

    ;disable all heaters
    M104 S0 T0
    M104 S0 T1
    M140 S0
    G90 ;use absolute coordinates
    G92 E11.0
    G1 E0 F1500  ;end-of-print-retract
    T0
    G1 X23 Y200 F10800 ; move printhead away
    G28
    ; disable motors
    M84
    ; disable fan
    M106 S0

     

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    Got my Mark 2 Upgrade (with expansion board) up and running and I'm loving this thing!

    Had some issues in Cura in the beginning but those cleared up after I found the updated printer def file in another tread on here,  is that updated in Github yet?

     

    Couple questions:

    What are the pros and cons of running Marlin vs Ultimaker 2 gcode flavor.  I have really gotten used to using the on board printer material temp setting with the Ultimaker 2 is there a reason that the definition files for the Mark 2 uses Marlin instead?

     

    I noticed with single material prints that the second head still comes to temp, primes and sits at 175 for the entire print for no reason.  Am I missing a setting or should I be slicing with the stock Ultimaker 2+ machine in Cura for single material prints?

     

    Thanks!

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    • resource files for Cura 3.2 (and upwards) are in a new folder on Github: https://github.com/foehnsturm/Mark2/tree/master/cura-3.2-resources
    • For GCode-Flavor "Ultimaker 2" Cura does not generate the "temperature magic" - because this is quite important for dual color prints i recommend the "Marlin" flavor
    • for single extrusion prints just use the stock Ultimaker 2+ machine in Cura as before (and remove the second printhead from the dock to free up the build area if necessary)

    Glad that you like it - Have fun!

    • Like 2
    Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    On 2/6/2018 at 12:37 AM, yyh1002 said:

    Thanks for the update! The new definition totally worked with quality options in CURA 3.2b. Creating and updating profiles finally works properly. 

    I've been creating multiple machines to have dedicated setting for head 1 print, head 2 print, PVA support and PVA interface only print. 

    And I find UltiGcode flavor works more handy than Marlin. 

    The start code for Marlin would heat up and prime both nozzle in all conditions. But in UltiGcode mode, only the necessary nozzle will be heated up.

    Great! thanks for the support, as this is critical to use the mk2 to the level of an UM3.

     

     

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    2 hours ago, tinkergnome said:
    • resource files for Cura 3.2 (and upwards) are in a new folder on Github: https://github.com/foehnsturm/Mark2/tree/master/cura-3.2-resources
    • For GCode-Flavor "Ultimaker 2" Cura does not generate the "temperature magic" - because this is quite important for dual color prints i recommend the "Marlin" flavor
    • for single extrusion prints just use the stock Ultimaker 2+ machine in Cura as before (and remove the second printhead from the dock to free up the build area if necessary)

    Glad that you like it - Have fun!

    Is it possible to adjust standby temp in firmware?  I’ve had some succesfull dual color and pva prints with UltiGcode which seems to have 100 degree standby temp. What temp magic would marlin do other than the default 175 standby temp? 

    Nozzle 2 only print would need dedicated start code for Marlin flavor. I wonder whether the extruder 1/2 start code settings could do the intelligent start code generation for the two nozzles. 

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    After the printer is configured as mark2, will it be possible for it to print using Gcode generated for the ultimaker 2+?

     

    The reason I ask is because what if I sometimes don't want to use the second hot end at all? I don't want it to prep itself if its not going to be used. Furthermore, one at a time print sequence mode is disabled for mark 2.

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    Sure, in Cura you select the um2+, remove the dock, hang the 2nd head outside the printer, and you machine is a UM2+

    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    Tinkergnome

    I copied the cura 3.2 files -  I take it I install as per the instructions on the Mark2 installation manual then it should be up and running for cura 3.2

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    16 hours ago, bob-hepple said:

    Tinkergnome

    I copied the cura 3.2 files -  I take it I install as per the instructions on the Mark2 installation manual then it should be up and running for cura 3.2

    Just install the files as described and you'll be up and running - 3.2 version running well here :) 

    • Thanks 1
    Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    On 2/22/2018 at 1:59 AM, yyh1002 said:

    I’ve had some succesfull dual color and pva prints with UltiGcode which seems to have 100 degree standby temp. What temp magic would marlin do

     

    The standby temperature for UltiGCode is a (fixed) calculated value - it depends on the printing temperature and the time of inactivity:

    • after  30 seconds -> printing temp - 5%
    • after  90 seconds -> printing temp * 0.8 (rounded down)
    • after 5 minutes    -> printing temp * 0.5 (rounded down)
    • after 12 minutes  ->  80°C

    I don't think that this is documented somewhere, it's just not the intended use.

     

    On 2/22/2018 at 1:59 AM, yyh1002 said:

    Nozzle 2 only print would need dedicated start code for Marlin flavor. I wonder whether the extruder 1/2 start code settings could do the intelligent start code generation for the two nozzles. 

     

    Interesting idea. It's worth a try.

     

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    On ‎22‎/‎02‎/‎2018 at 12:59 AM, yyh1002 said:

    Nozzle 2 only print would need dedicated start code for Marlin flavor. 

    If I understand you right; you can do a print using the extra head, by mounting the second head prior to running the generated gcode file using the standard UM2 (single head) settings under marlin.

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    I just completed my Mark 2 Build.   I am using the UM2 original print head as the 2nd extruder.

     

    What I'm noticing is that the UM2 original print head takes quite a while longer to heat up than the UM2+ print head.   However, I'm also noticing that the firmware seems to try and prime the 2nd extruder BEFORE it's at the correct temperature -- it seems to attempt this after the 1st extruder is at temp.   As such, ithe 2nd extruder is having a harder time priming correctly at the start of a print.

     

    Is there some way to remedy this....for the firmware to wait until the 2nd extruder reaches the proper temp rather than relying on the 1st extruder temp?

     

    Thoughts?


    *B

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    The UM2 heater is 25W, the UM2+ is 35W, so it takes some 50% longer to heat up.

     

    Here in the printer definition:

    https://github.com/foehnsturm/Mark2/blob/master/cura-resources/definitions/Mark2_for_Ultimaker2.def.json

     

    In „machine-start-code“ you could add a head temperature command at the beginning to preheat E2. 

     

    https://fablabdigiscope.wordpress.com/list-of-raw-g-code-commands-for-ultimakers/

     

    Quote
    
    RepRap M Codes
    
    M0 - Unconditional stop - Wait for user to press a button on the LCD (Only if ULTRA_LCD is enabled)
    M1 - Same as M0
    M104 - Set extruder target temp
    M105 - Read current temp
    M106 - Fan on
    M107 - Fan off
    M109 - Wait for extruder current temp to reach target temp.
    M114 - Display current position

     

    Use M104 and M109.

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    7 hours ago, conny_g said:

    The UM2 heater is 25W, the UM2+ is 35W, so it takes some 50% longer to heat up.

     

    Here in the printer definition:

    https://github.com/foehnsturm/Mark2/blob/master/cura-resources/definitions/Mark2_for_Ultimaker2.def.json

     

    In „machine-start-code“ you could add a head temperature command at the beginning to preheat E2. 

     

    https://fablabdigiscope.wordpress.com/list-of-raw-g-code-commands-for-ultimakers/

     

     

    Use M104 and M109.

     

     

    Seems like this should be something addressed in the actual Tinkernome firmware, rather than in an auxiliary script?   It seems legit that extruder 1 and 2 may have different timings to come to temperature -- even with different materials.  Shouldn't the printer always wait for the proper temp to be reached (as opposed to a manual script to be used for each print)?

     

    If there isn't consensus on this request for firmware change, can you be more specific about where and how to use M104 and M109?   I'm not a Gcoder.

     

    Thanks again,

     

    *B

     

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    For me, that sounds like they would have swapped the T0 and T1 sensor!

  • Link to post
    Share on other sites
    Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    Nevermind, i kicked something very old :)

     

    Edited by korneel
  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    hi! I install the mark2  but what printer I have to configure in cura, help me please!

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    Hi Luciano,

     

    After downloading the Cura definition files from the Mark2 github, copying them into the proper location and restarting Cura you should find  the Mark2 via the add printer menu in the "Other" section.

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    On 2/26/2018 at 4:17 PM, bradley said:

     

    Shouldn't the printer always wait for the proper temp to be reached (as opposed to a manual script to be used for each print)?

     

    If there isn't consensus on this request for firmware change, can you be more specific about where and how to use M104 and M109?   I'm not a Gcoder.

     

    Thanks again,

     

    *B

     

     

    Anyone able to help me?

     

    *B

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    Well learn some gcode - it's very very simple.  Very simple.  Extremely simple.  In my opinion.  It just executes the gcodes in order top to bottom.  You should read about the difference between M104, M109 here (also M140, M190):

     

    http://reprap.org/wiki/G-code

     

    If you set the temperature in a gcode and don't wait it will continue executing the next gcode (which might start printing for example or might turn the heat on elsewhere or play with fans etc) before the temperature is achieved.  The other method doesn't continue execution to the next gcode until the temperature is achieved.

     

    So typically you turn on the bed at first but don't want the nozzle to come on because it steals some power from the bed and the bed takes longer.  Then when the bed is say 10C below goal you can turn the nozzle on.  So one way to do this is:

     

    bed goal to 50C and wait for it to happen before continuing to...

    bed goal now to 60C but don't wait

    nozzle to 210 and wait for it before moving on...

    bed to 60C and wait  (just in case bed is only at for example 55C when nozzle gets to 210C)

     

     

    That's just one of a few good ways to do it.   Do the above 4 commands make sense?

    The other concern is you don't want filament sitting in the nozzle at full printing temp as the material deteriorates faster when at printing temps.  So you want to somewhat minimize the time the nozzle is at full temp yet not printing.

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

    @bradley the firmware should always wait for the target temperature of the particular extruder. You don't need to change the start script or the gcode.

    The question is: what is the target temperature? It should be displayed in the upper line, if you scroll to the temperature on the display at the printer (just to be sure).

     

    My suspicion: take sure that you use the correct definition files for Cura. There was a change in Cura 3.2, by default it initializes the target temperature of the inactive nozzle with the standby temperature now. There are new definition files for 3.2 (and upwards) in the folder "cura-3.2-resources" - take sure that you use these for Cura 3.2.

     

    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    1 hour ago, tinkergnome said:

    y suspicion: take sure that you use the correct definition files for Cura. There was a change in Cura 3.2, by default it initializes the target temperature of the inactive nozzle with the standby temperature now. There are new definition files for 3.2 (and upwards) in the folder "cura-3.2-resources" - take sure that you use these for Cura 3.2.

     

     

    Thanks for your response.   I am using the most up to date definition files from github.  

     

    I typically print at 210 degrees.  What I am seeing is the first extruder coming right up to 210 upon startup followed by the second extruder heating up much more slowly.  When the second extruder reaches approximately 200 degrees, the printer retrieves it and primes it -- it hasn't normalized at 210 yet.     Then, after priming, it remains at 175 (standby temp?).

     

    When I was using the default 200 degree print temp, the second extruder was only getting to 180-190 before priming.  Thus my concern.

     

    I haven't finished the calibration steps yet, so I'm still printing only with one extruder, but the dual extruder priming sequence is happening anyway.

     

    I know I can probably resolve this issue by upgrading the heater cartridge on second extruder.  But other than the wait time for heating up, it should wait for proper temp, regardless.

     

    Thoughts?

     

    *B

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    26 minutes ago, bradley said:

     

    Thanks for your response.   I am using the most up to date definition files from github.  

     

    I typically print at 210 degrees.  What I am seeing is the first extruder coming right up to 210 upon startup followed by the second extruder heating up much more slowly.  When the second extruder reaches approximately 200 degrees, the printer retrieves it and primes it -- it hasn't normalized at 210 yet.     Then, after priming, it remains at 175 (standby temp?).

     

    When I was using the default 200 degree print temp, the second extruder was only getting to 180-190 before priming.  Thus my concern.

     

    I haven't finished the calibration steps yet, so I'm still printing only with one extruder, but the dual extruder priming sequence is happening anyway.

     

    I know I can probably resolve this issue by upgrading the heater cartridge on second extruder.  But other than the wait time for heating up, it should wait for proper temp, regardless.

     

    Thoughts?

     

    *B

    Did you check the initial printing temperature setting? If not, unhide and take a look at it. 

    I remember cura have 10 degree lower initial printe temp as default.

  • Link to post
    Share on other sites
    Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade
    8 minutes ago, yyh1002 said:

    Did you check the initial printing temperature setting? If not, unhide and take a look at it. 

    I remember cura have 10 degree lower initial printe temp as default.

     

     

    That's how I'm setting it in cura

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 5 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...