Jump to content
foehnsturm

Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Recommended Posts

Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I'm almost sure this is the one, single issue we've seen several times now. As soon as something hits the frame it won't work thereafter.

Check two things:

Make sure you got the latest version of the Cura definition files? There was an error with the initial start / prime positions in the first github version.

Second, in the firmware check Dual extrusion - > wiping position and set the y value to something like 40 mm.

We should try to find a solution for the latter one and for the occasional layer start xy "bug" in Cura. What do you think @Tinkergnome?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I had sort of the same issue, it was with the first github versions. And with a to big difference between the 2 nozzles in the Z axe.

After upgrading all the files with the current distrubuted in Github, and the UM2+ extruder upgrade as second head, all these problems are gone.

What i see in the pictures is an enormous difference bteween the 2 heads in X and Y, maybe dial in an offset that is closer to the reality. I can't check the values right now. Maybe someone can chime in?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Simplify3D settings?

I have the M2 printer working with Cura, but to be honest, it is not my favorite software ! The only advantage i see is the "magic temperature"

S3D is what i used all the time, and now i want to adapt this to the M2.

Is there someone who is already using this with them M2?

Would be great to get tips and info.

Otherwise, it will be trial and error.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I'm almost sure this is the one, single issue we've seen several times now.  As soon as something hits the frame it won't work thereafter.

Second, in the firmware check Dual extrusion - > wiping position and set the y value to something like 40 mm.

 

Have to agree with what foehnsturm has said - there have been a couple of us who have had this problem at the start - once a suitable value has been entered into the Y offset it works superbly :)

For help, my offsets are: X 18.20 Y -24.95 - Maybe good starter input positions?

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

have not used S3D for dual for a long time, but as a starter I would try;

use the Mark2 firmware as much as possible, so XY offset, Z offset etc, leave it to the firmware. Same for the pick and place of the head, leave it to the firmware.

So I think all you need to do is setup two processes in S3D, on for T0 and one for T1, with correct temperature etc fort the head. (and T2 I guess for the bed)

Set all dual stuff from S3D to zero > like the xyz offset and nozzle change retraction

Take the start& end g-codes from the Mark2 json file, split them to the appropriate S3D processes per nozzle.

I'll probably give it a try myself, but that may take a while...

please share the processes when you succeed....

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I had sort of the same issue, it was with the first github versions. And with a to big difference between the 2 nozzles in the Z axe.

 

Similar to mine after I held the 2nd head out off the way until it was needed to measure distances.

Have entered my calibration readings in a previous post which should be a good start :)

Fk0g7mOm.jpg

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

 

I had sort of the same issue, it was with the first github versions. And with a to big difference between the 2 nozzles in the Z axe.

 

Similar to mine after I held the 2nd head out off the way until it was needed to measure distances.

Have entered my calibration readings in a previous post which should be a good start :)

Fk0g7mOm.jpg

 

Maybe you can try to change to the second head and then set the extruder offset.

About S3D, I've tried with it but I had some problems with infill and top layers so I stopped the prints, nice result but it take some time to heat up, and the tool change retraction is not always clean.

I post here my wip fff profile for the mark2

https://www.dropbox.com/s/5ll53ssyriua7xa/Mark2_1.0.0.fff?dl=0

Edited by Guest
error

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

@tinkergnome: I got the extra head from someone who purchased an extruder upgrade kit to upgrade to UM2+. Replaced the fan shroud and everything else is stock UM2+. Feeder mounted at the back using the fixed extruder mount. I'm considering printing the adjustable version instead.

@foehnsturm: Unless the current github files are still not updated. I've just cloned/download the repo yesterday.

Rattling/Crashing Noise Solved

I solved the rattling/crashing noise and aligned the prints by copying @navigator's extruder offset settings (X 18.20 Y -24.95). See pic attached. Thanks @navigator!

Btw, are these settings something that can be permanently stored to the machine? I noticed that it gets reset the moment the machine is turned off.

5a333b0a3fdb0_2017-05-2211_01_12.thumb.jpg.1cb6b628e75a27794b23f29bee827149.jpg

 


 

 

New Issue: Head moving to front left corner

I noticed the same thing that @MarcoUbtz reported. The printhead goes to the front left after the 2nd pass/layer causing the 1st hotend to crash against the front panel. This causes the printhead to get out of alignment. Will try @MarcoUbtz' solution to solve for this extra printhead travel.

5a5df1468783f_UltimakerCuraMark2.thumb.jpg.273dca3b50fab94f6d64f8683d5d566f.jpg

 

5a333b0a3fdb0_2017-05-2211_01_12.thumb.jpg.1cb6b628e75a27794b23f29bee827149.jpg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Will try @MarcoUbtz' solution to solve for this extra printhead travel.

 

To fix these movements you need to set layer start at X{100} Y{50} in travel menu, after doing this you will see the only one which is ok.

The solution is not mine but it is of foehnsturm

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Thanks, @MarcoUbtz! I did notice after backtracking the tread that it was @foehnsturm who suggested the layer start settings.

Btw, if you don't mind... Can you tell me how to activate the Mart2Tweaks plugin? I can't find it in the list in Cura and in the Mark2 github repo. I also don't see the "settings" icon as you're showing in this Cura screenshot below:

Cattura_LI.thumb.jpg.3ed9cfadc2b8e0ee9e8ed482c09bd927.jpg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

@navigator: Yup, I noticed that the "Store" button actually saves the settings even after the machine is turned off

Issues Solved

Setting the Layer Start X and Y values solved the "front left corner travel" issue. Was able to successfully print the dual color traffic cone below (printed at 60% scale):

I think that the calibration page on the documentation should be updated to first set the Extruder Offset X and Y *before* printing the calibration ruler/grid. This ensures that others in the future will not encounter the issues the early modders experienced. Also important to note as well is setting the Start Layer X and Y in Cura.

5a333b0c1ac01_2017-05-2216_32_35.thumb.jpg.c521bf53c4f4d5066a8cb8086e6b27f2.jpg

While I still have to dial in my offsets and fix some ooze issues with the hotends, I can say that I've successfully implemented the Mark2 mod. I can't thank enough everyone involved on this project. :)I can now join the ranks of the the first few successful Mark2 modders.

  1. @RudydG
  2. @qwerty8224
  3. @MarcoUbtz
  4. @navigator
  5. chiz

(others feel free to add yourself to the list)

@TheFox: Are you done with your Mark2 mod?

One last thing: I've noticed that my 1st hotend would crash to the parked 2nd hotend when it's wiping and I can't solve it even if I set the wiping coordinates farther from the front and more to the left. The 1st hotend will always move to front center slightly crashing to the parked hotend. Is this something that's firmware-specific behavior?

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

One last thing: I've noticed that my 1st hotend would crash to the parked 2nd hotend when it's wiping and I can't solve it even if I set the wiping coordinates farther from the front and more to the left. The 1st hotend will always move to front center slightly crashing to the parked hotend. Is this something that's firmware-specific behavior?

I think I know what you mean, and if I'm correct you may have your head docking position pushing on the 2nd head too much.

Just try backing off a bit on the Y docking position (save and test swapping heads etc) and see if that helps out.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

It's not during docking but during priming. This is after the 2nd hotend has extruded some material, then it gets docked. Then before the 1st extruder extrudes some material, it will move to the front center hitting the parked hotend. See pic below.image4493.thumb.png.92c927cfd01eb9e9ffcd238cec0dfd7f.png

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

I have a look at the gcode start sequence. The first priming is controlled there.

@Tinkergnome, If you find the time could you make a short write up, on how Mark2 specific settings are derived from other settings and in what way. Like priming pos derived from wiping pos, default is .. Or toolchange speed/accel is derived from ...

I know you answered the most questions already more than once, but it would save you a lot of time if we add some kind of cheat sheet to the documentation.

  • Like 2

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Here's how to adjust the start sequence;

If you want to have an easy readable view on it, look into the machine setting in Cura;

1-machinesettings.thumb.png.d3b6d82fdb32d0a8e4f0a31321c7be0c.png2-machinesetprime.thumb.png.006b5676b60bcd9b136ce4622e57fc84.png

The red marked area is probably where you want to make a change, set the X positions a bit lower.

But you better do it directly in the json file, there are (not sure, maybe solved already) issues with settings not stored when changed from machine settings,

To do it directly in the .json file, it looks like this, same code;3-json.thumb.png.d68bcaf32245b96871eff01ce371719a.png

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

@foehnsturm/@ultiarjan: So I edited the json file directly and adjusted X to 115. It did provide some clearance between the fans. However, with the 1st hotend out of the way, now it's the X rod that's squeezing the parked hotend and causes belt jitter/rattle. Weird thing though is that no matter what value I set to Y, it will not move the X rod farther from the parked head. I tried both small and extreme values such as Y=20, Y=0, Y=30 and Y=50 but it will not stop the X rod from hitting/squeezing the parked hotend.

5a333b21a592b_2017-05-2301_06_43.thumb.jpg.93ab7e45f11acbad745a72a507246081.jpg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

...

I tried both small and extreme values such as Y=20, Y=0, Y=30 and Y=50 but it will not stop the X rod from hitting/squeezing the parked hotend.

Have you tried to change the wipe position too?

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

Weird thing though is that no matter what value I set to Y, it will not move the X rod farther from the parked head. I tried both small and extreme values such as Y=20, Y=0, Y=30 and Y=50 but it will not stop the X rod from hitting/squeezing the parked hotend.

Thats what I thought you meant in your original post - I also had that, and reducing the pressure on the head in the Y direction whilst in the docking position cured it for me.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

@TheFox: Are you done with your Mark2 mod?

 

not yet, just got my extension board from @foehnsturm :-)

i hope i can install it today. will post results :D

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

The red marked area is probably where you want to make a change, set the X positions a bit lower.

 

@ultiarjan - IMHO this move should be X105 Y27

This is also the default for the Prime/Wipe position.

The default for the extruder offset should be X=18, Y=-25 (as a starting point for calibration). It seems that the "tinker" firmware does not set this automatically - I'll check it.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

At this moment my S3D configuration profile is 95% finished.

Just need to modify some single extruder settings.

Only thing i will not be able to program is the intelligent temp control, in my settings they cool to low, making the wait between toolchanges longer...

When they are done they will probably end up on Github ;-)

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

At this moment my S3D configuration profile is 95% finished.

Just need to modify some single extruder settings.

Only thing i will not be able to program is the intelligent temp control, in my settings they cool to low, making the wait between toolchanges longer...

When they are done they will probably end up on Github ;-)

 

I'm working on a profile for the mark2 too.

I noticed the time to heat from 160/80 degrees, I was thinking about insert in toolchange script tab something like this:

T[new_tool]

{IF NEWTOOL=1} M104 S175 T0 ; cool old tool

{IF NEWTOOL=1} M109 S[extruder1_temperature] T1 ; stabilize new tool

{IF NEWTOOL=0} M104 S175 T1 ; cool old tool

{IF NEWTOOL=0} M109 S[extruder0_temperature] T0 ; stabilize new tool

This script shouldn't interfere with the settings in the printer, but during a non-double print it heats and keeps at 175 degrees the first/second head

Share this post


Link to post
Share on other sites
Posted · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

You don't have to think about non-double prints basically, just use your normal Ultimaker2 profile for that.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Mark2 - The Smart Dual-Extrusion Upgrade

 

At this moment my S3D configuration profile is 95% finished.

Just need to modify some single extruder settings.

Only thing i will not be able to program is the intelligent temp control, in my settings they cool to low, making the wait between toolchanges longer...

When they are done they will probably end up on Github ;-)

 

I'm working on a profile for the mark2 too.

I noticed the time to heat from 160/80 degrees, I was thinking about insert in toolchange script tab something like this:

T[new_tool]

{IF NEWTOOL=1} M104 S175 T0 ; cool old tool

{IF NEWTOOL=1} M109 S[extruder1_temperature] T1 ; stabilize new tool

{IF NEWTOOL=0} M104 S175 T1 ; cool old tool

{IF NEWTOOL=0} M109 S[extruder0_temperature] T0 ; stabilize new tool

This script shouldn't interfere with the settings in the printer, but during a non-double print it heats and keeps at 175 degrees the first/second head

 

I tried this, but it gives a very strange behaviour, although the temps do as they supposed (M104 and M109), but i get strange Z behaviour. When using both extruders in the skirt, the Z does not go back to correct height after a toolchange.

When i disable this everything works again as expected.  But "less intelligent" temperature settings.

In the normal S3D dual extruder setting, the temp stays at 185 for some time (a minute or so), and after that it cools down. So at the next toolchange the waiting time is longer.

But I am willing to accept that, in favor of the better controls in S3D. (this is my personal opinion, many people prefere Cura)

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!