Jump to content
SandervG

Cura 2.6 | Beta

Recommended Posts

Posted · Cura 2.6 | Beta

Hey there, Custom FDM Dual Extrusion have a problem, with the Extruder specific setting (start/end Code). They won't used in the gcode. Only the Machine settings start/end gcode will be used.

second thing, what are the variables for extruder 1 and 2 first layer temp and first layer bed temp?

 

Can someone confirm this?

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.6 | Beta

With the Cura 2.6 Beta I can now select the nozzle size for my Ultimaker II extended with Olsson block...

but how can I add the fact that I have a 1.0mm nozzle that I use most of the time for large, mechanical parts?

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Hey there, Custom FDM Dual Extrusion have a problem, with the Extruder specific setting (start/end Code). They won't used in the gcode. Only the Machine settings start/end gcode will be used.

 

Could you try adding a new Custom FDM Printer, just to rule out any issues with upgrading an instance from the previous version? No need to throw out the whole configuration (yet), just add a new printer.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

how can I add the fact that I have a 1.0mm nozzle that I use most of the time for large, mechanical parts?

 

You would have to add a "variant" definition file. Create a copy of resources/variants/ultimaker2_extended_0.8.inst.cfg and replace 0.8 by 1.0.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

 

Hey there, Custom FDM Dual Extrusion have a problem, with the Extruder specific setting (start/end Code). They won't used in the gcode. Only the Machine settings start/end gcode will be used.

 

Could you try adding a new Custom FDM Printer, just to rule out any issues with upgrading an instance from the previous version? No need to throw out the whole configuration (yet), just add a new printer.

 

I try'd on two different Mac's with blank install.Try'd with adding a second machine, but won't work. It includes only the Machine specific gcode but not the extruder specific.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Hi Cura Team,

I have just completed a print (cuddling owls from Thingiverse) and it turned out fantastic !!!!!

My first attempt was somehow interrupted and I ended up with a half-finished print, where the layers were clearly visible.

I stumbled more or less by accident over the function "uneven skin", which supposedly "wobbles" the outermost layer.

THE RESULT IS SIMPLY FANTASTI)C !!!!!!

No visible layer structure and a very attracting skin view !!!

Guys, TRY IT OUT !!

Thanks for this great improvement !!

Peter

  • Like 2

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I stumbled more or less by accident over the function "uneven skin", which supposedly "wobbles" the outermost layer.

THE RESULT IS SIMPLY FANTASTI)C !!!!!!

I cannot find it.

Do you mean "Fuzzy Skin"?

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

how can I add the fact that I have a 1.0mm nozzle that I use most of the time for large, mechanical parts?

You would have to add a "variant" definition file. Create a copy of resources/variants/ultimaker2_extended_0.8.inst.cfg and replace 0.8 by 1.0.

I don't seem to have a "resources" directory in "C:\Users\\AppData\Roaming\cura\2.6".

There is a "variants" directory but it contains the 3 defined printers

Custom+FDM+printer_variant.inst.cfg

Ultimaker+2+Extended_variant.inst.cfg

Ultimaker+2+Extended+1.0mm_variant.inst.cfg

No files for the individual nozzle sizes a printer can have.

The last file contains

[general]
version = 2
name = Ultimaker 2 Extended 1.0mm_variant
definition = ultimaker2_extended
[metadata]
type = variant
[values]
machine_nozzle_size = 1
machine_gcode_flavor = RepRap (Marlin/Sprinter)

but only "Automatic", "0.25", "0.4", "0.6" and "0.8" can be selected in Cura 2.6 Beta.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Where is located the button to send gcode to Octoprint? And how to configure Cura with Octoprint API information, port, etc?

Go into your printer settings - you will need to give Octoprint the ip address of your octoprint server and the port you have it running on. You will also need to go into octoprint settings and get the API Key (best with copy) and paste it into the printer setup. This has to be defined separately for each printer ecause it most probably will be different for each printer.

Once you do that, octoprint appears as a third option with "save to file" and "save to SD card" (when you have an octoprint enabled printer selected). When you click on "Print with Octoprint" it uses Octoprint's web interface to send the file to the octoprint server's staging area.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

OK, so I have an odd bug. Since I have installed Cura 2.6, everything seems to work perfectly, but I have only printed PLA at around 200C. So today I load up PETG. I use the default PETG material profile, and I set the print temps to 240. The settings are "Default 240 Printing 240 Printing Temperature Initial Layer 240 Initial 235 Final 225". So then I print something, everything heats to 240, and it seems to be printing well. Boom, at the end of the initial layer the temp drops to 200. Hmmm. I abort the print, and check all my settings, check I have no post processing set, slice it again. Same thing. This time I check the gcode. Sure enough

G0 X-90.032 Y28.478
G1 F1800 X-90.255 Y28.538 E120.67034
M104 S200
G0 F3600 X-90.392 Y28.514
G0 X-85.533 Y28.281
G0 X-83.998 Y28.1
G0 X-81.445 Y27.562
G0 X-78.956 Y26.773
G0 X-76.552 Y25.738
G0 X-74.257 Y24.47
G0 X-72.785 Y23.498
G0 X-70.679 Y21.83
G0 X-68.652 Y19.881
G0 X-66.827 Y17.739
G0 X-65.215 Y15.427
G0 X-64.267 Y13.82
G0 X-63.043 Y11.277
G0 X-62.039 Y8.59
G0 X-61.289 Y5.816
G0 X-60.794 Y2.983
G0 X-59.923 Y-5.374
G0 X-57.075 Y-3.708
;TIME_ELAPSED:127.274815
;LAYER:1
M140 S70
M106 S204
G0 F5400 X-57.075 Y-3.708 Z0.5
;TYPE:WALL-INNER

I have no idea why that M104 would be there. I really do not see any temperatures other than in the temperature setting area. I only have one extruder defined. Also it sort of looks like the temperature was reset right after the last use of the extruder on the first layer - which implies that the extruder was being cooled down from a warmer first layer to a 200 degree printing temperature but that just was not the way the settings were set. This is the germane part of the settings block at the end of the gcode:

;SETTING_3 _type = skirt\\nbrim_width = 6\\ncool_fan_speed = 80.0\\ncool_fan_spe
;SETTING_3 ed_max = 100.0\\ncool_lift_head = True\\ndefault_material_print_tempe
;SETTING_3 rature = 240\\ninfill_angles = [ 0,45,15,60,30,75]\\ninfill_pattern =
;SETTING_3  zigzag\\ninfill_sparse_density = 40\\nlayer_height = 0.2\\nmaterial_
;SETTING_3 flow = 92\\nmaterial_initial_print_temperature = 235\\nmaterial_print
;SETTING_3 _temperature = =default_material_print_temperature\\nmin_infill_area 
;SETTING_3 = 2\\nprint_sequence = one_at_a_time\\nretraction_hop_enabled = True\
;SETTING_3 \nretraction_hop_only_when_collides = True\\nskirt_line_count = 3\\ns
;SETTING_3 upport_infill_rate = 21\\nsupport_z_distance = 0.5\\ntop_bottom_patte
;SETTING_3 rn = concentric\\ntop_bottom_pattern_0 = concentric\\nwall_thickness 
;SETTING_3 = 1.2\\n\\n"}

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I don't seem to have a "resources" directory in "C:\Users\\AppData\Roaming\cura\2.6".

I meant in the Program Files folder.

I made a new file in C:\Users\\AppData\Roaming\cura\2.6\variants named ultimaker2_1.0.inst.cfg with this content:

[general]
name = 1.0 mm
version = 2
definition = ultimaker2
[metadata]
author = Ultimaker
type = variant
setting_version = 1
[values]
machine_nozzle_size = 1.0
machine_nozzle_tip_outer_diameter = 1.35

And now I have a 1.0 mm in the dropdown for the UM2 with Olsson block.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I don't seem to have a "resources" directory in "C:\Users\\AppData\Roaming\cura\2.6".

I meant in the Program Files folder.

Thanks.

What do you do when the next Cura update comes?

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I have not downloaded the Beta version, but I was wondering if the new version will fix a minor annoyance when saving project files.

Instead of just keeping the File Extension, it keeps adding .curaproject.3mf to itself. As in:

My_project.curaproject.3mf would be listed in the name window but it saves as:

My_project.curaproject.3mf.curaproject.3mf

And will keep adding the extension unless you wipe it out or replace a file by double clicking on it.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I have not downloaded the Beta version, but I was wondering if the new version will fix a minor annoyance when saving project files.

Instead of just keeping the File Extension, it keeps adding .curaproject.3mf to itself. As in:

My_project.curaproject.3mf would be listed in the name window but it saves as:

My_project.curaproject.3mf.curaproject.3mf

And will keep adding the extension unless you wipe it out or replace a file by double clicking on it.

Not yet, but I'm working on it. Think we can ship this with 2.6 final.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.6 | Beta

I don't seem to have a "resources" directory in "C:\Users\\AppData\Roaming\cura\2.6".

I meant in the Program Files folder.

What do you do when the next Cura update comes?

If you read the comment, you will see I copied and renamed the file from the Program Files cura folder into the roaming profile folder. So the new file will survive an upgrade to a new version of Cura.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I have not downloaded the Beta version, but I was wondering if the new version will fix a minor annoyance when saving project files.

Instead of just keeping the File Extension, it keeps adding .curaproject.3mf to itself. As in:

My_project.curaproject.3mf would be listed in the name window but it saves as:

My_project.curaproject.3mf.curaproject.3mf

And will keep adding the extension unless you wipe it out or replace a file by double clicking on it.

Not yet, but I'm working on it. Think we can ship this with 2.6 final.

Cool beenie weenies :) I know it is minor compared to some of the things you guys are working on. I truly appreciate it.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Can you please add the option to allow the user to select and remove certain support structures? Often times when printing with supports, there are areas I want/need supports and other areas where I would like to not have supports. Having the ability to remove them on the fly would be very helpful. Thanks!

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I like the new format, I just do not know what to change and why? The other issue, like our other versions, I can only use them on 1 of my 3 computers because of the video card. The computers come with built-in video cards and the vendor does not say much about them, so you do not know Cura will not work until you purchase it and installed the software.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Hey, I'm experiencing a strange bug. After I successfully finish one print I edit the settings and try to print again, this leads to the print head crashing into the bed.

I'm using a delta printer.

The only non standard thing I use is a post processing script to probe the bed before the nozzle heat up code but I don't see how it could cause these kinds of issues. AutoBedLevelingBeforeHeatUp.py

An error on my side is always possible, I might just be to blind to see it.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Can you please add the option to allow the user to select and remove certain support structures?  Often times when printing with supports, there are areas I want/need supports and other areas where I would like to not have supports.  Having the ability to remove them on the fly would be very helpful.  Thanks!

You can do this with anti overhang meshes.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.6 | Beta

Can you please add the option to allow the user to select and remove certain support structures?  Often times when printing with supports, there are areas I want/need supports and other areas where I would like to not have supports.  Having the ability to remove them on the fly would be very helpful.  Thanks!

I have never heard of this beast. Where  can I get some references that are specific to your point? Off to google now, but posting just in case.

You can do this with anti overhang meshes.

Well, that was weird, I had a question about the anti-overhangs and it just posted the quotes.....may have been me, but here I go again:

I have not heard of anti-overhangs before. I am off to Google to find this, but could you elaborate or point to a reference more specific towards your comment?

Thanks!

Edit: I did find the reference through a search, but for some reason it confuses the heck out of me. A visual guide would be appreciated if such exists or could be made.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Any updates on the 'surface' in surface mode? It still refuses to slice something.

And is there a reason for not asking to overwrite a file on a sd card? Saving to file does ask permission.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

I have just downloaded and installed the new 2.6.0 Beta and was wondering if it just me. or does the print area seen to shrink every time there is a software upgrade?

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

Hallo

i've downloaded and installed the new cura, i'm still analysing , but i can't " drag & drop" my files out of a file into cura. There's nothing happening. In cura 2.5 no problem at all.

Share this post


Link to post
Share on other sites
Posted · Cura 2.6 | Beta

upgraded from 2.4 to 2.6 beta. i used to select an object then zoom using double finger slide down on the trackpad, this used to zoom into the object. now it zooms into the centre of the screen, which isn't as useful. i actually can't find how to move the view to put the object in the centre :(

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!