Jump to content
Ultimaker Community of 3D Printing Experts

Why is Cura generating partial top layers?


Recommended Posts

Posted · Why is Cura generating partial top layers?

Hi, I'm having this weird issue where Cura keeps generating a partial top layer:

eXJChnU.png

It's almost like I accidentally tilted the model ever so slightly, but the bottom layer is perfectly flush with the bed. Also, moving it around makes the partial top layer generate in all sorts of inconsistent shapes and sizes, even on opposing ends of a surface!

All dimensions are exactly defined and exported from SW, so I'm kindda puzzled at why it does this?

  • Link to post
    Share on other sites
    Posted · Why is Cura generating partial top layers?

    Check the X-Ray view for any RED areas, they would indicate issues with the model that can confuse Cura when slicing it.

    I've seen this happen when the layer is not perfectly flat and parallel to the build plate. Even a difference of .1mm in height can cause the slicer to print that 'bump'. Any way you could post the STL, or original model for examination?

  • Link to post
    Share on other sites
    Posted · Why is Cura generating partial top layers?

    Check the X-Ray view for any RED areas, they would indicate issues with the model that can confuse Cura when slicing it.

    I've seen this happen when the layer is not perfectly flat and parallel to the build plate. Even a difference of .1mm in height can cause the slicer to print that 'bump'.  Any way you could post the STL, or original model for examination?

    The model itself is perfectly proportioned, pretty sure of that barring any outragous STL conversion errors on SW's side. Here are all the views:

    jpYYzGO.png

    (notice the funky pattern on the top layer now)

    And as far as I can tell the bottom of the model is perfectly aligned to the bed:

    65tDmrF.png

    If you want to take a look; feel free to check out the STL/SW models:

    DriveMotorHousing.zip

    So far it hasn't been messing with any actual functionality, but I foresee some potential problems later on in my project on moving parts if it keeps adding pronounced ridges...

    Thanks!

  • Link to post
    Share on other sites
    Posted (edited) · Why is Cura generating partial top layers?

    I took a look. Here is an image of three different slices using the Lines, Concentric and Zig-Zag. I could not reproduce the image you provided. But, it is laying flat. You can check that by taking your layers to the bottom and see if it is indeed sliced on the bottom. It was in my view. I did try different rez sizes (Draft, Normal, Fast) and it did not change and moved it around the plate. I do not think it is an issue. It just looks like the way the graphics are being drawn or something. What version of Cura are you using?

    Lines_3DifferentOnes.jpg

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Why is Cura generating partial top layers?

    First off, you model is AWESOME. Yeah, everything is flat, straight, level, etc. very nice!

    Ok, here's some clues (Cura 2.5)

    I was getting the same behavior as you with .1 Layer Height and .15 Initial Layer Height. This causes the top layers to not be perfect layer increments: .15, .25, .35, .45 ...

    So you can see that when it gets to the first inner top later at 10mm, its going to be either 9.95 or 10.05mm. Looks like Cura has a rounding issue and depending on where on the build plate it sits, it may do some areas in 9.95 and others in 10.05

    So I'm guessing your Initial Layer Height is probably something like .25

    So to mitigate this, set you Initial Layer Height and Layer Height values so they will land exactly on the top layers of your part: ie: 10mm and 30mm.

    I would recommend .2mm for both Initial Layer Height and Layer Height. It might make bed adhesion a little more difficult, but your top layers will be flat.

  • Link to post
    Share on other sites
    Posted · Why is Cura generating partial top layers?

    I took a look. Here is an image of three different slices using the Lines, Concentric and Zig-Zag. I could not reproduce the image you provided. But, it is laying flat. You can check that by taking your layers to the bottom and see if it is indeed sliced on the bottom. It was in my view. I did try different rez sizes (Draft, Normal, Fast) and it did not change and moved it around the plate. I do not think it is an issue. It just looks like the way the graphics are being drawn or something. What version of Cura are you using?

     

    Thanks for checking Kman, but it's not just graphical; I only noticed Cura was doing it when the actual prints showed half made top layers:

    Qpuu0QK.jpg

    Bottom layer looks pretty flat in the slicer:

    wdC5j2a.png

    Using latest Cura 2.5

  • Link to post
    Share on other sites
    Posted · Why is Cura generating partial top layers?

    First off, you model is AWESOME. Yeah, everything is flat, straight, level, etc. very

    ...

    It might make bed adhesion a little more difficult, but your top layers will be flat.

     

    Thanks man! On both accounts, as that was actually the issue it seems. Had my initial layers set to 0.3 mm.

    Set it to 0.25 and fixed my surfaces!

    Is this a known issue then? Pretty annoying something like this when you really have no clue where to look for the cause.

  • Link to post
    Share on other sites
    Posted · Why is Cura generating partial top layers?

    Yeah, that print is something I have not seen before. Usually when I have encountered something like that, it was purely graphical.

    But, showing the print is good to see. Thanks for that :)

    And, yep, that is the way the print should look in sliced view when it is on the plate nicely.

    But, wonder why your version of cura and mine would differ? I am on the same version.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...