Jump to content
Ultimaker Community of 3D Printing Experts
ultimati

M190 S55 in my gcode file

Recommended Posts

Hi,

in Cura 2.5.0, in the printer configuration, in "initial gcode" we see this:

G21 ;metric values

G90 ;absolute positioning

M82 ;set extruder to absolute mode

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

...

But in my generated gcode file i can see this:

;FLAVOR:RepRap

;TIME:43839

;Filament used: 41.4211m

;Layer height: 0.2

;Generated with Cura_SteamEngine 2.5.0

M190 S55

M104 S198

M109 S198

G21 ;metric values

G90 ;absolute positioning

M82 ;set extruder to absolute mode

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

...

With the code "M190 S55", the printer "Wait for bed temperature to reach target temp".

In the previus version of Cura, i generated files with this start:

M140 S60.000000

M109 T0 S198.000000

T0

M190 S60.000000

;Sliced at: Wed 08-03-2017 21:38:28

;Basic settings: Layer height: 0.2 Walls: 1.6 Fill: 30

;Print time: #P_TIME#

;Filament used: #F_AMNT#m #F_WGHT#g

;Filament cost: #F_COST#

;M190 S60 ;Uncomment to add your own bed temperature line

;M109 S198 ;Uncomment to add your own temperature line

G21 ;metric values

G90 ;absolute positioning

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

With code "M140 S60.000000", the printer heats the extruder at the same time as the bed (Bed Temperature (Fast)).

Can I change de real initial code and put M140 instead of M190?

Thank you.

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!