Jump to content
Ultimaker Community of 3D Printing Experts

Printer skipping right through the filament priming


Recommended Posts

Posted (edited) · Printer skipping right through the filament priming

(Printer and SW specs at the bottom)

I'm on the verge of tears for this problem: for some unknown reason, my printer simply skips the material priming at the beginning of the print. Instead of parking the head at the priming position and doing it, it first moves to the position, and then starts printing right away from there. Nothing chaged at all in slicer or printer configurations, I didn't touch anything in the start g-code or printer type or whatever.

I had this problem a few weeks ago an I don't have a clue on what I did that fixed it, but now it's back.  Extruder stepper works just fine in every other situation. Tried older gcodes from when the priming occured and it skips it too. Did multiple factory resets and firmware updates, and also changed the slicer version, nothing solved it either. When it worked again, it came back just as it started, out of nowhere.

The last time it happened, after like the fifth factory reset and firmware update, the priming simply started working again, even though I was using exactly the same setup from when the problem started. Every different firmware and slicer I tried after it came back worked too. I'm at a total loss.

Firmware: Tinker 17.02.1

Slicer: Cura 15.04

Printer: Ultimaker 2

I know the firmware is not from Ultimaker and the slicer is an older version, but like I said, when it works, it works with every firmware and slicer I throw at it, and when it doesn't, it doesn't work with any of them too.

Edited by Guest
  • Link to post
    Share on other sites
    Posted · Printer skipping right through the filament priming

    Could it be your pulleys are loose and you need to tighten the set screws? If so you would see the motor turning in X and Y but the head not always moving.

    Anyway to debug this I would send gcodes manually one at a time. I would start by learning what they all mean and then install pronterface. Connect to your printer through a USB cable:

    Get pronterface here. It's free:

    http://koti.kapsi.fi/~kliment/printrun/

    Once the connection is working well home the head and then move it with G commands and move the extruder. Experiment. Do the same commands that are in your gcode files. It could be that you aren't setting the extruder back to 0:

    G92 E0

    The extruder will ignore very long moves (not sure what is very long? More than 3 meters maybe?) so if you finished one print and then start the next one and the first extrusion is the prime it might be like "extruder is at 5 meters and now you want me to go back to 3mm position? Sorry: no.".

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...