Jump to content
Ultimaker Community of 3D Printing Experts
Ollo

Probleme PID auto tune

Recommended Posts

Bonjour à tous,

Sur ma UM2 j'ai eu quelques soucis ( et oui encore, lol), j'ai eu plusieurs fois Heather error et donc obligé d'éteindre et rallumer la bête.

En début de semaine, impossible de faire chauffer la buse, j'ai démonté et comme la tête chauffait bien mais la valeur mesurée ne montait pas , je me dit que la sonde est morte et commande une sonde pour UM2 100K, à réception je monte (apres avoir casse la sonde dans le bloc olson évidemment) , (j'ai vérifié que la sonde fonctionnait), mais c'est la cartouche qui ne marchait plus , grrrrr.

Nouvelle commande pour une cartouche 35W, reçue cet après midi.

Premières mise en chauffe, la température monte très vite et dépasse la consigne (consigne à 100°C, ca monte jusqu'a 110-115 pour redescendre tranquillement à 100°C), je me dis alors que peut être que je n'avais pas à l'époque une cartouche 35W mais une 25W peut être.

J'essaie l'auto tune du PID par le menu de tinker (actuellement j'ai P10.00 I2.50 D100.00) mais là erreur, température too high ...

Qu'avez vous comme paramètre PID vous ?

Est ce que ça peut venir d'autre chose ?

J'ai testé après une heure de maintient à 150 par le menu Heather nozzle, c'est stable, consigne à150 et mesure à 150.

Share this post


Link to post
Share on other sites

Les valeurs de PID me semblent être bonnes....

Vérifie bien que le bloc de chauffe et la sonde sont bien en place et à fond dans le logement.

Ne serre pas la vis de maintien comme un dingue.

Lance une impression...

Edited by Guest

Share this post


Link to post
Share on other sites

salut

Avant de débuter un PID Auto Tune tu choisis un température exemple 180° que tu vas chercher à atteindre normalement dans le menu "heating nozzle", une fois cette température stable tu envois l'Auto Tune avec la même valeur de température.

Share this post


Link to post
Share on other sites

Bravo rigs,

Avec cette méthode, j'ai maintenant une montée en température qui ne dépasse la consigne que de 3-4 °C et non 15°C.

Mes nouveaux paramétres sont P10.30 I0.95 D27.98, c'est sacrément différent.

A voir maintenant si ça change quelque chose sur mes prints, je me demande la tolérance de précision de mesure d'une sonde à une autre.

Share this post


Link to post
Share on other sites

A voir maintenant si ça change quelque chose sur mes prints, je me demande la tolérance de précision de mesure d'une sonde à une autre.

 

Je bosse avec 4 ultimaker 2 + et je n'ai pas une seule valeur PID identiques...

Sinon pour observer une modification de la largeur d'extrusion du fondu il faut descendre à la limite de la sous-extrusion avec du PLA par exemple afin d'observer la zone d'influence.

5a333c888ddf1_tempsinfluence.thumb.jpg.f4f52df3129ff3bbca28263ed18fd516.jpg

 

Et c'est à ce moment là que je m'aperçois que mes valeurs de PID étaient revenues aux valeurs d'usine : comment est-ce possible ?

 

Factory reset ou mise à jour du firmware depuis ton dernier réglage PID voir Roswell....

5a333c888ddf1_tempsinfluence.thumb.jpg.f4f52df3129ff3bbca28263ed18fd516.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Je bosse avec 4 ultimaker 2 + et je n'ai pas une seule valeur PID identiques...

 

Oui le PID je comprends car ça va dépendre de la chaine électronique complète, mais je me demandais pour la valeur de consigne mesurée par la sonde.

En clair si on prend un thermomètre electronique, que l'on fait chauffer les 4 UM2 a 200°C est ce que la valeur mesurée directement sur chacune des buses est identique car elle dépend de la précision de mesure de la sonde des buses.

Si une sonde est calibrée avec 10°c de moins par rapport à la réalité, la consigne de chauffe affichée à 200°c et mesurée par la sonde à 200°c sera en réalité à 190°c non ?

Share this post


Link to post
Share on other sites

Cela reste du matériel grand public.

A température ambiante, je n'ai pas la même mesure sur mes différentes imprimantes, voir pas la même entre le lit et la buse...

Le PID est responsable de la stabilisation de la température, en temps que tel il ne joue pas sur la précision de la lecture.

Share this post


Link to post
Share on other sites

Si une sonde est calibrée avec 10°c de moins par rapport à la réalité, la consigne de chauffe affichée à 200°c et mesurée par la sonde à 200°c sera en réalité à 190°c non ?

 

Dans une logique oui mais tu n'interviens jamais sur ce calibrage ( fabrication usine et interprétation firmware des valeurs envoyées ) sauf dans un mauvais positionnement de cette sonde en son logement.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy