Jump to content
Ultimaker Community of 3D Printing Experts
kaypohl

Problem with overhang in Cura

Recommended Posts

Hello all,

my name is Kay and i am new here. I just printed some simple models with cura as slicer. But now i have a problem with a self designed model.

The model is made with Sketchup. In every STL viewer it looks great with no problems.

adapter.thumb.PNG.cd0d2a4069ab5453d1e996b0c69ed97e.PNG

In Cura with supports and layers view it looks like this.

cura_supports.thumb.PNG.ba2dc52259a59729958c62c96ced139b.PNG

The problem is the inner side. There is now a plate, which doesn't exists in the STL file.

Any hint what i am doing wrong?

Kind Regards

Kay

adapter.thumb.PNG.cd0d2a4069ab5453d1e996b0c69ed97e.PNG

cura_supports.thumb.PNG.ba2dc52259a59729958c62c96ced139b.PNG

Share this post


Link to post
Share on other sites

Well there are a few things you can try. Basically 2 ways to success. The first way is to fix it in sketchup. In sketchup you have the default walls (which is good) which are gray on one side and white on the other. You can click on any wall and reverse the faces (gray in, white out, or vice versa). Make sure all walls have white facing out. More fixes here:

https://i.materialise.com/blog/3d-printing-with-sketchup/

The other way to fix things (or maybe you have to do this even if your model is perfect) is in cura. There are settings in the section "mesh fixes". If your model is perfect cura can fill in parts of your model like the photo above unless you turn all of these off. Click the gear and locate these (second or third to last category in cura and make them all visible). It's probably the "union overlapping volumes" on that is the problem and needs to be unchecked. Although if you fix things to make all visible faces of your part "white" then you might not need to mess with this in cura.

Share this post


Link to post
Share on other sites

Well there are a few things you can try.  Basically 2 ways to success.  The first way is to fix it in sketchup.  In sketchup you have the default walls (which is good) which are gray on one side and white on the other.  You can click on any wall and reverse the faces (gray in, white out, or vice versa).  Make sure all walls have white facing out.  More fixes here:

https://i.materialise.com/blog/3d-printing-with-sketchup/

The other way to fix things (or maybe you have to do this even if your model is perfect) is in cura.  There are settings in the section "mesh fixes".  If your model is perfect cura can fill in parts of your model like the photo above unless you turn all of these off.  Click the gear and locate these (second or third to last category in cura and make them all visible).  It's probably the "union overlapping volumes" on that is the problem and needs to be unchecked.  Although if you fix things to make all visible faces of your part "white" then you might not need to mess with this in cura.

Hi gr5,

thanks for your help. I have tried to follow all the steps you supposed. Here is the result:

Sketchup changed faces:

adapter_faces.thumb.PNG.1fe027ed4ac8c3ac32e050c582836d88.PNG

Cura with no meshmix settings:

adapter_cura_without.thumb.PNG.0c3e90b79aee96e74cc1821112e78d95.PNG

Cura wit meshmix settings:

adapter_cura_with.thumb.PNG.568a52f2bd5d6eb3cca62d79ce1c48b3.PNG

Share this post


Link to post
Share on other sites

Yikes no. You want zero visible gray faces. Only white faces visible from inside outside, all around.

Well my suggestion was likely not the issue then. View the part in xray view in cura. It will show red if you have extra walls or holes in it -- that's my next theory.

Sketchup is just very problematic. Did you follow my link? It talks about tools you can use in sketchup to make sure your part is a 3d object and doesn't have things like internal walls.

Sketchup is designed to make nice looking things but not real things. CAD programs are meant to create real things. For example in sketchup you can just place an infinitely thin wall somewhere. There's no way to print that. I'm thinking you have more cylinders inside this object than you thought and it's confusing cura.

Share this post


Link to post
Share on other sites

Yikes no.  You want zero visible gray faces.  Only white faces visible from inside outside, all around.

Well my suggestion was likely not the issue then.  View the part in xray view in cura.  It will show red if you have extra walls or holes in it -- that's my next theory.

Sketchup is just very problematic.  Did you follow my link?  It talks about tools you can use in sketchup to make sure your part is a 3d object and doesn't have things like internal walls.

Sketchup is designed to make nice looking things but not real things.  CAD programs are meant to create real things.   For example in sketchup you can just place an infinitely thin wall somewhere.  There's no way to print that.  I'm thinking you have more cylinders inside this object than you thought and it's confusing cura.

Yes i followed your link. I think i found the problem, but i don't know how to fix it in Sketchup.

xray.PNG.2a7df117a4a1ae8f3a381bb025a7e7de.PNG

The problem is red shown :-(

Kay

Share this post


Link to post
Share on other sites

What you called the "inner side" was something impossible in the 3d world. I call it an "inner wall". The guide I linked to explains it better. It's hard to explain with words - easier to explain with pictures. But I'm glad you figured it out.

Share this post


Link to post
Share on other sites

Hello.

I have the same problem.

I'm drawing a model in Sketchup. I'm converting this model into an STL file.

I open the STL file in CURA, and CURA fills the entire inner space with overhangs.

I read this forum and delete the entire inner wall, but CURA still fills the whole model with overhangs.

The program removes the protrusions only if the model is installed vertically.

 

Sorry for my English.

thanks to everyone.

 

cura_1.jpg

cura_2.jpg

cura_3.jpg

overhang.curaproject.curaproject.3mf

Share this post


Link to post
Share on other sites
45 minutes ago, Nlander said:

Hello.

I have the same problem.

 

You're right..., this file is not usable for 3d printing. It looks like all faces are inverted (or something like that). Sketchup does not produce usable stl-files out of the box (most of the time). Meshmixer (e.g.) identifies more that 5000 errors... Have you checked all the remarks that are mentioned in the linked blog post?

 

If you're in a hurry - here is your file - repaired with 3D-Builder. Merry Christmas!

overhang_repaired.stl

Edited by tinkergnome
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!