Jump to content
Ultimaker Community of 3D Printing Experts
LynG3

Ultimaker 2 Upgrade to 2+

Recommended Posts

Hi Everyone

I Recently aquired a Ultimaker 2, as a upgrade to my old Vertex 3d printer. I then noticed i got some problems with the print to do with retraction, where the knurl would grind the filament instead of feeding it.

After a quick read thorugh of the problem i decided to by the feeder upgrade to make the printer a 2+, https://www.makers-hut.com/product/ultimaker-2-extruder-upgrade-ultimaker-extended-go-2-3d-printer-geared-extruder/ .

After i mounted this with great difficulties since part was missing. I started to print however the feedrate seems to be stuck at what is was before hand where it fed properly. I did download the latest version of Cura 2.6.2 and then i updated the firmware of the printer, and this didnt help either.

I am running okay settings for a 0.4mm nozle:

layer height: 0.1mm

Intial Layer height: 0.2mm

Wall thickness: 0.8mm

Top/bot: 0.8mm

Print speeds tried: 30mm/s, 50mm/s and 60mm/s(last one is my usual one)

I have not enable retraction

and Combing Mode is set to all.

Im using PLA , where i heat it to 210 degrees and have the heated bed at 60 degrees.

Im using RS Pro Black PLA 2.85mm and the material is not deviating from the size written. I can push material through the nozzle manually hazzle free. It just seems like it is moving to slow and the print it makes is classic examples of under extrussion, where you get small pellets or missing layers, i just dont have any idea how to fix it.

This is why i come here for help

Thank you in advance

Jacob

Share this post


Link to post
Share on other sites

> I started to print however the feedrate seems to be stuck at what is was before hand where it fed properly.

You mean it's turning backwards?  when you switch from a UM2 to a UM2+ feeder, if you don't update the firmware, the feeder will be turning the wrong way.  Instead of slowly extruding it will just slowly retract the filament as you print all the way back to the feeder.

Is that what you mean?  If so make sure you use the select the UM2 *plus* machine before updating the firmware.

Also consider using tinkerMarlin which allows you to experiment with the steps/mm setting.

Maybe your problem is completely different than "extruder turning backwards" in which case please include a photo of the issue if possible.

  • Like 1

Share this post


Link to post
Share on other sites

> I started to print however the feedrate seems to be stuck at what is was before hand where it fed properly.

You mean it's turning backwards?  when you switch from a UM2 to a UM2+ feeder, if you don't update the firmware, the feeder will be turning the wrong way.  Instead of slowly extruding it will just slowly retract the filament as you print all the way back to the feeder.

Is that what you mean?  If so make sure you use the select the UM2 *plus* machine before updating the firmware.

Also consider using tinkerMarlin which allows you to experiment with the steps/mm setting.

Maybe your problem is completely different than "extruder turning backwards" in which case please include a photo of the issue if possible.

 

Yeah forgot that it was turning backwards at first, then I uploaded new firmware to it and I am sure it is on 2+ firmware.

It just seems like something is wrong with the firmware since when I load new filament it it fills the tube up til half and then stops at that rate and then it proceeds to take 10min to move the material to the nozzle.

Unfortunately I dont have any pictures of the prints as the cleaning lady thought it was trash and threw them out.

However, from googling underextrution you will find similar pictures. I'm on my phone so I can't show an example ATM.

I tried looking for a older version firmware but I can't find any.

It just seems to me that the stepper motor is moving what it should be when it's a um2 but after the gear upgrade it should be moving more to cover the same distance and that is not happening.

Share this post


Link to post
Share on other sites

Did you buy the stepper motor to go with it as well? The stepper in the UM2 is a 400 step/rev motor. The one that is used with the new feeder is a 200 step/rev motor.

No i did not, since i assumed the kit was covering what as needed, and i must have missed the step down in stepper motor, when i was reading about the upgrade.

Do you know any cheap Uk sites where they are selling the correct specced stepper motor?

Share this post


Link to post
Share on other sites

How did you get the old motor working with the new feeder? It should lack the cog... the new motor including this cog should be available from your Ultimaker reseller.

We bought the package linked in the first post, we mounted what came in that package, and it "worked".

Im not looking to by the whole update kit, im only looking to buy the specific stepper motor for the feeder motor and i could do with some information on that so i dont buy the wrong one :)

Edited by Guest

Share this post


Link to post
Share on other sites

Im not looking to by the whole update kit, im only looking to buy the specific stepper motor for the feeder motor and i could do with some information on that so i dont buy the wrong one :)

...but if you are satisfied so far and it is already working with the original motor... the only thing left to do is: adjust the steps/mm for the E-axis (on the printer), and you're through. Or did I got something wrong?

Send the following two commands to the printer, and that's it.

M92 E738

M500

The default value for the UM2+ is 369, you have to double it.

You can use (e.g.) Pronterface, or write the lines to a *.gcode file (with a text editor) and "print" it.

Keep in mind: The value is stored in EEPROM, you have to repeat this step after a "Factory Reset".

  • Like 1

Share this post


Link to post
Share on other sites

Im not looking to by the whole update kit, im only looking to buy the specific stepper motor for the feeder motor and i could do with some information on that so i dont buy the wrong one :)

...but if you are satisfied so far and it is already working with the original motor... the only thing left to do is: adjust the steps/mm for the E-axis (on the printer), and you're through. Or did I got something wrong?

Send the following two commands to the printer, and that's it.

M92 E738

M500

The default value for the UM2+ is 369, you have to double it.

You can use (e.g.) Pronterface, or write the lines to a *.gcode file (with a text editor) and "print" it.

Keep in mind: The value is stored in EEPROM, you have to repeat this step after a "Factory Reset".

I will try this withing the next 1.5 hours, and will report the results back it should do.

Cheers.

Share this post


Link to post
Share on other sites

@tinkergnome @gr5

i installed tinkermarlin firmware for the printer and then went into the settings and changed the steps per axis to 738. it do indeed now seem to print at the correct speed but it also seems that the zaxis is moving properly, since it seems to just be scraping the already printed material and adding a new layer in the same place. I just cant see it moving now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy