Jump to content
Modified_Gemini

Excessive travel movements. (possible to avoid?)

Recommended Posts

Posted · Excessive travel movements. (possible to avoid?)

Hello

after the release of Cura 3.4 I tried another shoot.

I attach gcodes for the same stl, two pieces in a single build plate.

I made slicing settings as similar as possible (wall thicness/lines, top bottom layers, infill percentace/pattern etc.)

Cura gives me 7.24 h print time, S3D 4.32 h

If you open both Gcodes with notepad++ you can see cura's one is 343272 lines while the one generated by S3D is 138115 (less than half)...

 

Is this normal?
Thanks

Pietro

 

image.thumb.png.6acca639cafdcbf0b70ccded0d919dc1.png

image.thumb.png.b85d563bd1f33d426ac0bc660c1bfdc6.png

 

gcodes.zip

Share this post


Link to post
Share on other sites
Posted · Excessive travel movements. (possible to avoid?)

Hello @pieri70, I think the difference is that Cura has the fill gaps between walls option enabled and this produces zillions of little line segments. Try turning that off and see if it makes a difference. Looking at the s3d gcode, it doesn't look as if the gap is being filled there. Hope this helps.

Share this post


Link to post
Share on other sites
Posted · Excessive travel movements. (possible to avoid?)

Check out the Cura 3.5 release notes in regards to excessive moves.

Share this post


Link to post
Share on other sites
Posted · Excessive travel movements. (possible to avoid?)

Hello @Deneteus

I just downloaded and installed Cura 3.5

Now I'm using Ideamaker as my preferred slicer

I tried to slice the same stl with the same settings where possible

 

Ideamaker makes my gcode 47600 lines while Cura 3.5 makes a 68600 lines one.

I like the way Ideamaker slices my stl and travels/movements seem to be ok

I must check what this new Cura version makes but the gcode volume seems to be a little too much..Bie

Share this post


Link to post
Share on other sites
Posted (edited) · Excessive travel movements. (possible to avoid?)

@Piero70 

The print time estimates are based on your printers acceleration settings entered into Cura. To reduce the print time estimate you have to enter your printers acceleration settings into Cura. It's not based on the lines of code that you see within the GCODE file.

The issue with unnecessary moves is based on what some of the settings were causing the extruder to do. Not knowing what settings you chose doesn't give anyone an idea of what the problem is. You would need to post your Profile settings file, the STL, the current gcode files, and your printers firmware settings for anyone to give you an idea of what is really going on.

How to export profiles: https://ultimaker.com/en/resources/20441-manage-profiles

This is where you would post your Issue: https://github.com/Ultimaker/Cura/issues

Here is an example: https://github.com/Ultimaker/Cura/issues/3323

Check out the following posts for specifics: 

Edited by Deneteus
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!