Jump to content
Ultimaker Community of 3D Printing Experts
Nebukadneza

Cura 2.7 strange retract behavior

Recommended Posts

Hi everyone,

I’m using Cura 2.7 to print with my marlin-based i3-style printer. However, I‘m noticing some strange retraction behavior.

First, here are my retraction-related settings:

2017-10-07-175921_412x479_scrot.png.452ea1c27352df85abf31beda4d106d3.png

I also have "Z Seam Alignment" set to random.

What I’m seeing is two-fold: First, when travelling over inner parts of a print, no retraction is triggered. This might be fine for infilled layers, but for solid layers, especially on the top, this is suboptimal: The filament oozed during these travels will show through to the the outermost layer.

Secondly, Even though Z-Seam is random, cura will travel to one fixed corner of the object, and do it’s layer-change-retraction there, then travel to a random corner, and re-start printing the now-new layer. Of course due to slight imperfections of re-start after retraction as well as hovering above this corner while retracting, this will make that corner ugly/blobby in Z-direction („up along the part“).

Does anyone have a gut feeling which setting to look at? Or any idea how to fix?

Thank, and best regards,

-NebuK

2017-10-07-175921_412x479_scrot.png.452ea1c27352df85abf31beda4d106d3.png

Share this post


Link to post
Share on other sites

I don't have much to help you - if you print colder you shouldn't care so maybe lower the temp by 15C just to see what happens. Even better go into the TUNE menu and lower the temp 5C at a time while printing and mark with a sharpie where you change the temp to see what works and what doesn't. You probably will also have to slow it down so set feedrate to 50% as an experiment also.

Having said that, 8mm retraction is too much! Unless your bowden is 2 meters long, 4mm should be plenty. Is this a bowden printer (if so around 4 to 5mm retraction - if not then around 1-2mm).

If you retract so much that air gets into the nozzle then the retraction will cause more problems than help. I'm assuming you have bowden printer - you want to retract enough so the filament at the top of the bowden arc moves from pushing against the inner top of the bowden to resting on the bottom of the arc of the bowden. If the filament actually pulls out of the head at all then that's too much retraction. You just want to relieve the pressure.

Share this post


Link to post
Share on other sites

Hi,

yeah, the initial retraction settings were a bit off the mark, but that’s not what I meant. Not saying I don’t appreciate your tips, it was helpful during tuning!

What i meant is the basic behavior of Cura. Take this example:

curastrange.thumb.png.54b5b4789d4952b0b6e93b927bc44bde.png

Cura will first print the outermost (red) wall, then the outermost-inner (green) wall, then travel to the innermost-inner wall (blue arrow), and continue there. During the blue-arrow, no retraction is triggered, and it oozes like hell. This is bad, since we’re on the first layer: The bottom-solid is going to be printed onto the oozed-across line which has considerable thickness. This destroys the evenness for the 2nd layer, and also the visual quality of the bottom of the part …. Also, this also happens for solid-top, where the ooze-lines then show through the roof, impacting visual quality and smoothness of the parts roof again.

This is — I fear — not tuning related, is it? If there’s a setting in Cura that alters this behavior, I’d be glad to know which (maybe I’m just blind, overlooking it …).

Anyhow, thanks a lot for your help so far!

-NebuK

curastrange.thumb.png.54b5b4789d4952b0b6e93b927bc44bde.png

Share this post


Link to post
Share on other sites

First i think there is basically something wrong with your printer (or with the travel speed), if it oozes so much during travel moves - but that's a different question ;)

Looking at your picture: the default behavior of Cura 2.7 is that it first prints all green lines and afterwards all the outer (red) lines. The blue arrow is a so called "combing move". The according setting seems to be hidden in your case. Use the search bar to find the setting for "Combing Mode". You can set it to "Off" or at least to "No Skin", this should generate a retraction before these travel move(s).

Your second question is probably related to the "Layer Start" coordinates. These are located in the "Travel" section too.

Share this post


Link to post
Share on other sites

Hi,

thanks for your reply! Indeed, Combining Mode is what i was looking for — mostly „no skin“. I then only needed to go and set most patterns to ZigZag instead of Lines, to avoid incredible amounts of retraction.

I have to admit that i didn’t quite understand what exactly the X/Y-layer-start biases, and how — but i’m experimenting around :-).

Thanks for your extremely helpful reply!

Best

-NebuK

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy