Jump to content
Ultimaker Community of 3D Printing Experts

Merge Models - Bad Coordinate Calculations


Recommended Posts

Posted · Merge Models - Bad Coordinate Calculations

I have been using Ultimaker 2+ Extended for some time with no issues. This is my first week using the Ultimaker 3, and I am not able to get Cura to merge the models correctly. The models that I am using have identical coordinate systems (I have them mated together in a solidworks assembly by the origin planes [top-top, front-front, right-right]), but when Cura merges them, there is an offset along each axis. Is Cura treating the center-of-gravity as the origin or something ridiculous like that? What happened to the feature that allowed me to place models overlapping each other and manually move them around?

  • Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations

    Hi and welcome,

    Normally if the models are designed correctly then they should merge without issues, i think it can fail somehow if you scale the models before merging.

    If you want to overlap models, there's an option in the general preferences in cura, it's called allow models to overlap or something like that.

    • Like 1
    Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations

    Cura uses the models origin to merge models. I think that solid works doesn't actually preserve that origin.

    The feature to manually move items is still there. Just group / merge objects and use ctrl click to select objects inside the group.

  • Link to post
    Share on other sites
    • 2 months later...
    Posted · Merge Models - Bad Coordinate Calculations
    25 minutes ago, RGordon87 said:

    This was my issue. Thank you! I had to merge first and then scale down. Thank you!!

    On 10/12/2017 at 3:13 AM, DidierKlein said:

    Hi and welcome,

    Normally if the models are designed correctly then they should merge without issues, i think it can fail somehow if you scale the models before merging.

    If you want to overlap models, there's an option in the general preferences in cura, it's called allow models to overlap or something like that.

    Nevermind. I thought it worked but I was mistaken. 

  • Link to post
    Share on other sites
    Posted (edited) · Merge Models - Bad Coordinate Calculations

    To anyone else having this issue,

     

    I did not realize that after models were grouped, they could still be moved relative to each other within Cura by clicking and dragging on one of the grouped models while holding CTRL. I was able to make this print work by zooming in and manually aligning by eye. 

     

    The "if designed correctly they will align automatically"-answer is frustrating. The two models in question began in solidworks as one model with two bodies. I deleted one body, saved as STL1. Went back to the 2 body model. Deleted the other body and saved as STL2. They had the exact same file format and origin definition, but they were automatically offset in all 3 dimensions when grouped in Cura. Please advise if this method is bad form...

     

    PS: No scaling before, after, or during. Default export settings. 

    Edited by IggyHolzman
    No scaling occurred...
  • Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations
    1 hour ago, IggyHolzman said:

    To anyone else having this issue,

     

    I did not realize that after models were grouped, they could still be moved relative to each other within Cura by clicking and dragging on one of the grouped models while holding CTRL. I was able to make this print work by zooming in and manually aligning by eye. 

     

    The "if designed correctly they will align automatically"-answer is frustrating. The two models in question began in solidworks as one model with two bodies. I deleted one body, saved as STL1. Went back to the 2 body model. Deleted the other body and saved as STL2. They had the exact same file format and origin definition, but they were automatically offset in all 3 dimensions when grouped in Cura. Please advise if this method is bad form...

     

    PS: No scaling before, after, or during. Default export settings. 

    The above posters answer about holding CTRL to move the other body worked for me as well. I agree about that other answer being frustrating. I did the same as you but suppressed instead of deleted one body and than the other. It didn't work that way either. BUT, I'm glad we got these parts to work. 

  • Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations
    21 hours ago, IggyHolzman said:

    The "if designed correctly they will align automatically"-answer is frustrating. The two models in question began in solidworks as one model with two bodies. I deleted one body, saved as STL1. Went back to the 2 body model. Deleted the other body and saved as STL2. They had the exact same file format and origin definition, but they were automatically offset in all 3 dimensions when grouped in Cura. Please advise if this method is bad form...

    Cura uses the origin of the file to figure out how to merge them. It could well be that solidworks is doing something to offset it. There is no way that Cura can figure out how two models that don't share an origin should fit together. So even though the answer is frustrating, it's the only one we can give.

  • Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations

    The answer is frustrating because it does NOT mention the origin or anything like that... Rather it implies that the fault is with the design alone.

     

    How does one make two models share an origin? Is there a setting during the export where I can make the STL use the same origin system as the SLDPRT? Obviously they have the same SLDPRT origin since they are aligned when constrained by mating the origin planes. 

  • Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations

    I don't know how to make solidworks do that. I've never used it.

  • Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations
    1 hour ago, IggyHolzman said:

    The answer is frustrating because it does NOT mention the origin or anything like that... Rather it implies that the fault is with the design alone.

     

    How does one make two models share an origin? Is there a setting during the export where I can make the STL use the same origin system as the SLDPRT? Obviously they have the same SLDPRT origin since they are aligned when constrained by mating the origin planes. 

     

    That's a question for the Solidworks forum...  The first result on google if i search for "solidworks stl origin":

    https://forum.solidworks.com/thread/93447

    • Like 1
    Link to post
    Share on other sites
    Posted · Merge Models - Bad Coordinate Calculations

    I've found the best way to do it is - within your part of multiple bodies in solidworks, right click solid bodies>save bodies. Then auto-assign names. This allows you to pick an origin for each body. Click on each saved body in the menu and select the same vertex in your model for EACH body. It's not enough to choose the vertex origin once for all. When saving your STL file, make sure 'Do not translate STL output data to positive space' is ticked in the options. 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...