Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
oliver-fueckert

Lines on surface

Recommended Posts

Hi Guys,

Now that I have my Ultimaker for a week, I have tried a selection of slicers, like Slic3r, Netfabb and Cura. I got to say, even after playing with the parameters quite a bit I still get the best results in Cura. Thanks for a great piece of software!

One small thing I noticed are lines which are especially pronounced on the surface of objects. They are related to the blue line seen here on the model:

Etv8Lqd.png

It seems like the slicer moves across the whole surface to start the layer fill on the opposite side ((starting front left in this pic to back right) and then the layer is printed perpendicular to the blue line which leaves a nasty line across the surface.

I was wondering why it does that ? It could just start the layer from the front left instead of moving over to the other side first to avoid this line across?

Here the printed result for reference:

Nwegqt3.jpg

best regards,

Ollie.

 

 

Share this post


Link to post
Share on other sites

The picture is too blurry. Is it extruding during the move? If so you can enable retraction and also uncheck "retract on jumps only". This will slow down the print and maybe make things worse but if it is extruding during that blue line it *will* help that one thing.

Hopefully Daid's new slicer (coming out soon!) will infill in a smarter order.

 

Share this post


Link to post
Share on other sites

Yes, that definitely makes it better! But unfortunately Cura makes a lot of 'unnecessary' movements which causes imperfections... Hope that the new slices makes a big difference regarding these movements :smile:

 

Share this post


Link to post
Share on other sites

If you only care about one of the spots on your print - I assume the bottom or top layer. Then you can edit the gcode yourself and put in a retraction move. Slice it both ways, look at the difference between the 2 files on the layer(s) you care about and just add retraction on those 2 layers only.

The gcode files are easy to read and edit. Each layer has a comment along with where perimeter starts, infill starts, loops start and so on.

Well not as easy as looking at a picture of the moves but just try it!

 

Share this post


Link to post
Share on other sites

Even with retraction enabled you're going to get this kind of problem because the head does travel moves across the surface, damaging it. What you might want to try is enabling the 'hop on move' capability, so that it lifts off the surface during moves. But Cura's not very smart about that - you might get better results with the equivalent setting in Kisslicer. You should also take a look at my blog post about z move speeds, and consider tweaking things to get slightly faster z-moves...

http://www.extrudable.me/2013/04/02/the-myth-of-z-speed/

 

Share this post


Link to post
Share on other sites

Note, it's not extruding during the blue moves. Those blue lines are just moves without extrusion. But, yes, they do scar the surface.

The new engine does a bit better, but there will always be moves on the top surface, no way to prevent it without teleportation.

 

Share this post


Link to post
Share on other sites

Yes... which is why I'd be interested to only turn it on for finished flat surfaces and/or have aesthetically aware path ordering for finished surfaces. :-)

1 small blob is easier to clean up than a stripe all the way across the surface of a print.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!