Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up
thopiekar

SolidWorks plugin (official thread)

Recommended Posts

Posted · SolidWorks plugin (official thread)

I'm going through the plugins now. Will do it step by step as I don't want to iterate across all plugins at once all the time, because of the feedback from Ultimaker. It just takes too much time from experience.w

  • Like 1

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

[gr5 edit - this part of the forum is supposed to be English only - please post english here - google translate follows]

I have Ultimaker_Cura-4.6.0-win64, but it does not have a tab for installing plugins.

How to be

 

[original]

У меня стоит Ultimaker_Cura-4.6.0-win64, но в нём нет вкладки для установки плагинов.

Как быть?

 

 

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

In the upper right corner of Cura click "marketplace" and make sure you are on the "plugins" tab and install "Mesh Tools".  Then restart Cura.  Now right click on your model, choose "mesh tools" and first choose
"check mesh", then if that passes choose "fix model normals" and "fix simple holes".

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Спасибо!

Это хорошо, но при открытии моделей solidworks, не которые модели устанавливает за пределы стола.

После этого увеличение, после уменьшения, не возможно. При инвертированном направлении увеличении камеры.

В остальном вроде как работает.

А что должно происходить при использовании инструмента mesh tool?

Визуально ни чего не происходит. 

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)

Thank!

This is good, but when opening the models.

After that, not possible. With the inverted direction of the enlarged camera.

Otherwise, it seems to work.

Mesh tool, what should it do?

Visually, nothing happens.

Edited by KIBRG

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Maybe show a photo of this "enlarged camera"?  Maybe it's something that is created by solidworks?  Maybe there is a way to not export the "camera"??  If your model has extra parts to it that you don't want, the mesh tool allows you to split your model up into components and you can then delete what you don't want to print.

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)
19 hours ago, XYZDesignPro said:

Вы можете установить плагин SolidWorks Integration таким же образом.

 

image.thumb.png.673eadbf1f3d19295cac3191d84c6502.png

The first thing he did

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)

Scr6.thumb.jpg.9b199a69e29a6fbdea6fa7c2945f329c.jpgScr5.thumb.jpg.ee6e876b7142bd9851611d152298d57b.jpgScr4.thumb.jpg.7b54dca8524f2efdb8bf8bf120493d3d.jpgScr3.thumb.jpg.9c84483e00b2752606350bc529ab1bd9.jpgScr2.thumb.jpg.231b86f6be3d850b2addecd15446f7a2.jpgScr1.thumb.jpg.d9c13df94c820c534419ef4d73eb3c05.jpg

When there is a checkmark (see picture 1).
Reduced (see picture 2) and when moving with the mouse roller, does not respond.
If you turn it off, then everything works.
But whoever works in solid works will understand that this checkmark is needed for convenience.

Edited by KIBRG

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Hi!

 

I'm new here with my first question. I'm using SolidWorks 2006 and macro in SW as well as SW integration in CURA doesn't work.

 

Any chance to get it working? Upgrade to some newer version of SW is not in plans for now.

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Sorry, but my question is closed. Save to .stl and open from CURA works.

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

No problem. After installing the plugin, you should be able to open SolidWorks files without saving as STL.

Are you sure the plugin is properly installed?

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)

The plugin is installed properly.  But it isn't important for me now.

 

3DS_1.png

3DS_2.png

3DS_3.png

3DS_4.png

Edited by Vaklin

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Please select SldWorks.Application.14 from the list.

According to the Wikipedia article here (https://en.wikipedia.org/wiki/SolidWorks#Release_history) version 2006 corresponds to API 14.

I never had any installation as old as this in my hands, so I guess there are API calls I do, which are not supported at your version, but let's investigate 🧐

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Selected. What I should do after that? There is only "Close" button. Restarting the CURA, after selection and close, doesn't improve anything.

 

Probably some new button near to the "Close" , like a "Remember", or "Select API" drop-down instead of "First choice" or just as a new drop-down will helps to resolve the situation?

API_14.png

CONFIG_API.png

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

The service checker is only to test the functionality of the connection to SolidWorks. Actually, I'm surprised that there are so many leftovers on your computer. Every entry in service checker indicates that some installation has been found on your computer.

However, the executable (.exe file) to your installation could not be found. Normally, it should be known by your registry for Windows' automation interface.

Could you be so kind and send me your log file? I should tell me more precise why the executable has not been found. I can imagine of either a malformed path or missing entry in your registry 🙂

If you need any further help or instructions, please let me know!

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

From where I should get the log?

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Hmm, looks like the registry keys are missing on your computer. That can be either because there is no support for external access via Windows Automation on your version or there is something special about your installation still.

Maybe some old conventions to register, I don't know of??

 

Which version of Windows are you using? 🙂

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

7 N

 

Installation is made from some files from original CD's, to maintain it minimalist. Windows automation (as I remember) was on the CD's, but not installed (for sure).

 

Drop this dead deal, bro. 😉

 

Probably I'm alone, who uses monsters like this one.

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Haha, well this part of the software (if really not installed), is essentially needed. Otherwise, the plugin can't interact with SolidWorks and get the file converted for you 🙂

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

As I said few posts before, saving as .stl is more than enough for me.

 

Thank you for your efforts.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...