Jump to content
thopiekar

SolidWorks plugin (official thread)

Recommended Posts

Posted · SolidWorks plugin (official thread)
3 minutes ago, AbeFM said:

I see you have "prepare for printing" - I'm assuming this is orientation? - but I don't know if it will smooth out the steps.

 

How do you mean? Is the question, whether the 3D-printing profiles I introduces are now detailed enough?

Please install the 0.5.0 release of the plugin. It should really give more detailed models than before with the profiles, which have been introduced by SolidWorks!

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)
2 minutes ago, AbeFM said:

"Invalid File
Failed to load <file-with-path>"

Can we please debug this? The really should not happen!

 

2 minutes ago, AbeFM said:

Can you point me in a good direction so I can get back to the topic of angular accuracy? :-)

Sure, but let's keep the focus on getting the plugin working (again) :) 

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

I did/tried-to install it. I'm unable to import any parts since the reinstall of the plug-in.

 

Do you have some suggestions to make this work again?

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

I have installed the 0.5.0 plugin for SolidWorks, but it does not work.  Here's the error message I receive:

5a832348729fe_LoadFailure.JPG.1b0dbdfaded77c93ee881ae653028f5e.JPG

 

It really looks interesting now that the resolution can be set to something more detailed than the "Fine" setting from SW.

I'm on SolidWorks Standard, 2018 SP 1.0

 

In the mean time, how do I return to 0.3.7?

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Could you both send me your logs?

 

26 minutes ago, XYZDesignPro said:

In the mean time, how do I return to 0.3.7?

Go to the plugin directory in the configuration directory and remove the CuraSolidWorksPlugin directory inside it, while Cura is closed.

After that start Cura again and install the plugin from the plugin browser.

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)
39 minutes ago, XYZDesignPro said:

Sorry to be so dense, but where is the location of the logs and the configuration directory?*|

Good that you are asking! You can find the configuration directory by using Cura itself.

 

Screenshot_20180213_213137.thumb.png.729ea68f7f46aeae59c1fe144fe66208.png

 

After clicking on it Windows Explorer should appear and you will find the directory called "plugins".

But before removing the plugin, don't forget to close Cura.

Oh, and in the configuration folder you can also find the log, which is a file called "cura.log".

 

Wish you success and don't hesitate to ask more questions!

Edited by thopiekar
Adding correct screenshot

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)
16 minutes ago, XYZDesignPro said:

Sadly I can't see any line, which is indicating an error or so.

Would you mind if I could take a look using a TeamViewer session?

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

I have team viewer installed on my system.  What time did you have in mind?  It is 2:50 P.M. PST (West coast of the U.S.)

  • Like 1

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

I guess I found the issue together with someone on GitHub:

https://github.com/thopiekar/CuraSolidWorksPlugin/issues/48

and the fix:

https://github.com/thopiekar/CadIntegrationUtils/commit/5ab985c2b879bf201160e5734c4897bf5e0a29d7

The problem is visible in the screenshot below:

image.thumb.png.e67933b4c980d6e2cd246e9d8fba2b02.png

Within my plugin, I'm asking Cura (Python to be precise), where the temporary directory is.

Well, as you can see the first answer is "None" (as known as "Nothing" on VisualBasic, which makes more clear that there is just nothing behind this variable).

However, because of a feature (even if it is the allowance to send usage info) or something else on my side tempfile.gettempdir() gets called, which fills this variable with content.

So when I'm using the plugin it works. However, using tempfile.gettempdir() is the correct way, so I replaced it.

 

Since I use this section of getting the temporary directory across all my CAD plugins, all of them should be broken in these cases.

I fixed the issue and packaged a new version for you, which will be online soon. Hope this will fix the current problems you have.

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)
1 minute ago, XYZDesignPro said:

The link still points to 0.5.0 no 0.5.1*|

Oops ':D The forum software is not getting my friend easily..

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)

@XYZDesignPro Which SolidWorks version are you using? According to the issue (https://github.com/thopiekar/CuraSolidWorksPlugin/issues/48#issuecomment-365449120), the plugin crashes while using 3MF. Cura's file-reader returns nothing, so could you be so kind, since I don't have SolidWorks 2017 or newer, to export into 3MF and open it in Cura manually?

I just want to be sure it is not a fault in my plugin, but SolidWorks, which is returning invalid 3MF data. Additionally, it would be great if you could upload the 3MF file if it can't be read with Cura.

 

Many thanks for testing so far!

Edited by thopiekar

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

a simple question.

Solidworks export to stl. Why should i use the plugin ?

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)

Fewer clicks. You can directly drag and drop your file into Cura.

You can open parts, assemblies or drawings (which include only one part or assembly) in Cura and the plugin will do the job to convert it into the correct orientation and best quality.

Each time you open a file, you can get asked which quality it should be and/or make the highest quality (or whatever you want) the default one.

(Sounds like I have to make it more clear what the benefits are..)

Edited by thopiekar
  • Like 1

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)
3 hours ago, thopiekar said:

(Sounds like I have to make it more clear what the benefits are..)

 

@Gigi According to your reaction, I guess it should do that.

Made a note about it and will add more details on my website later.

 

Thank you for your interest and feedback on this!

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

Cura 3.2.1

Solidworks plugin 0.5

Everything ok.

BUT.... if Cura is open, export to cura open another instance of CURA software,

Maybe if he detect that Cura is already open....

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited) · SolidWorks plugin (official thread)
11 minutes ago, Gigi said:

Solidworks plugin 0.5

 

Which version exactly? 0.5.2?

 

11 minutes ago, Gigi said:

BUT.... if Cura is open, export to cura open another instance of CURA software,

Maybe if he detect that Cura is already open....

You mean the behaviour of the macro button, I guess, right?

Edited by thopiekar

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)

0.5 plugin. (downloaded)

Yes macro. A way to detect if Cura is already open.

Share this post


Link to post
Share on other sites
Posted · SolidWorks plugin (official thread)
1 minute ago, Gigi said:

Yes macro. A way to detect if Cura is already open.

Known issue. Within the macro Cura gets started with an option, which should act like you should expect.

Therefore inside the macro, everything is done correctly. The issue is known by Ultimaker's Cura team and not fixed so far.

(And I'm not going to fix that.)

 

So I'm sorry for this, but you can't blame the issue on the software bundle which comes with the plugin.

 

Any other impressions? Critical feedback? :)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Survey: Understanding your workflow
      Interact with future concepts and aim to collect your feedback and opinion. In particular, if this would/could be a welcome addition to your 3D printing workflow. Interested?
      • 0 replies
    • Coronavirus: Let's do our part
      Through this post I would like to further explain what we are doing, and what you could be doing. 
      Our efforts consist of 2 layers. First; connect medical institutions and hospitals to (local) 3D Printing hubs to help them print parts of which a 3D model already exists. And second, contribute to design the necessary part and then have it printed via a (local) 3D printing hub. Experts are available from within Ultimaker and from within our network of 3D printing experts.
        • Like
      • 45 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!