Jump to content
Ultimaker Community of 3D Printing Experts

SolidWorks plugin (official thread)


Recommended Posts

Posted · SolidWorks plugin (official thread)

Hey @drayson,

 

thank you for your PM!

Noticed that the values are not even in millimeters, too. That fears me a bit, because it could mean that there is another unit, where it becomes even, but I can't imagine that the function to change these settings in the SWX API expects anything else than millimeters or inches. One of these units would be typical for most of the cases and millimeters itself just scientifically (international seen) correct.

 

However, will apply your values to the dialog now.

I also began to make changes on the other windows as well, so less code is needed. But ended up in a strange bug I don't understand.

 

Did someone already try the 0.6.0 so far?

  • Link to post
    Share on other sites
    • Replies 255
    • Created
    • Last Reply

    Top Posters In This Topic

    Top Posters In This Topic

    Popular Posts

    Hello Thomas hope all is well.  Just thought I'd drop you a line to let you know that your plugin is working very well in Cura 4.0.0 and SolidWorks 2019 SP2.  I really appreciate that now it has the a

    Oh, ah!So what is "3D-printing" versus "Solidworks" - neither is what I would associate with "quality". I assumed that WAS the orientation adjust.

    Without actually going through all of the steps you have outlined, I can tell you for sure that the setting for STL, 3MF and AMF export out of SWX 2018 all carry over.  The differences are only with r

    Posted Images

    Posted · SolidWorks plugin (official thread)

    Hey @XYZDesignPro,

     

    I posted the URL here before. But nevermind this download, because the I noticed a bug at some point that the saved values of both parameters are extracted from the cura settings in text form and not numbers. Therefore, if you don't modify the values before slicing the plugin will fail to convert your SolidWorks file.

    Will sit down on this and correct that soon.

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    When using Cura 3.4.x, then V4. V5 is for Cura 3.5 and upwards.

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Got it.

     

    Thanks for all of your work on this Thomas.  I may have an opportunity to test it out over the weekend.

    • Like 1
    Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    The link takes you to the plugin for SCAD

     

    CuraSolidWorksPlugin-v4-2018-11-07T20_26_08Z.curapackage

     

    image.thumb.png.3dfa965fc69ed7e0e68c51ac937208e1.png

     

    Help??

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Interesting.. Looks like there is a typo in the URL. It automatically redirects you then to a page, which seems to fit the best.

    Strange guess from the Wordpress plugin to take you to the OpenSCAD page ?

     

    Tested these links before posting them now:

    CuraSolidWorksPlugin-v4-2018-11-07T20_26_08Z.curapackage

    CuraSolidWorksPlugin-v5-2018-11-07T20_26_08Z.curapackage

     

    Sorry and enjoy! ?

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Oh, I was thinking it was just because the dialog "remembers" its settings once  you export something with them. If you just make changes and don't save a file, they get lost.

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    No, the function was there, but practically wrong data formats have been exchanged.

     

    How does it work for you? When using the same settings as in SolidWorks, is the quality the same?

    There was no unit defined for the deviation in the documentation, that's why I'm asking.

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    I've not been using CURA much lately, no good Mk3 profile and limited support for the MMU (Prusa's mutli material unit).

    But I'll be doing more now. ?

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    I have downloaded CuraSolidWorksPlugin-v4-2018-11-07T20_26_08Z.curapackage

     

    How do I go about installing it?

  • Link to post
    Share on other sites
    Posted (edited) · SolidWorks plugin (official thread)

    Drag and drop the file into Cura. That should do it.

     

    Regards from Huston, Texas 

    Edited by thopiekar
  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Hey guys,

     

    you tested it already? Any issues faced?

     

    Thanks!

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Hi!

    I gave it a try Tuesday afternonn but as I was in a hurry I have not checked in detail what happened - just re-installed 5.6 as 6.0 crashed cura when trying to open a SLPRT file...

    sorry for no more details, will try to find time this weekend and check the log file.

     

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Ok, let's get it tested and fixed soon, so I can roll out the new release 😉 

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    I installed 0.5.6, on Cura 3.4.1, but I saw no difference in the interface.  I was expecting a dialog box allowing me to adjust the resolution, but it did not.  Just acted the same as 0.5.5.  The Plugin toolbox indicates the 0.5.6 is installed.

     

    image.thumb.png.b0b25ff502b061c5da8bead8156f3fd9.png

     

    Any suggestions?

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Hey @XYZDesignPro,

     

    This is the version which is published but posted a link here before to the plugin package.

    This one is newer, then the one you can get via the Toolbox aka Marketplace..

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    I'm using the one you posted on 11-9 . 

     

    CuraSolidWorksPlugin-v4-2018-11-07T20_26_08Z.curapackage

     

    Not the one from the Toolbox (Marketplace).  What package am I supposed to be using?

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Hello @XYZDesignPro and others!

     

    I took some time to upgrade my build system here. I noticed that it took a lot of time to distribute work-in-progress code. Therefore I wrote my own script[1], which creates software packages (*.curapackage), plugin files (*.umplugin or *.curaplugin) and source archives for the upload to Ultimaker's contributors portal. Before I had to clean up the source code all the time, remove all file which was needed for version control and I got annoyed from that. So whenever I'm working on a feature or fix in a specific branch I can download the results on the project's pipeline page (Blender plugin for example [2]).

    On top of that, I can set for how long the files are hosted and then automatically removed.

     

    So yes, for Blender that concept works. The generated software packages work and the source archives seem to be complete.

     

    Guess I can spend some time on older Cura's for curaplugin/umplugin tests in the future, too.

     

    Will continue with the Autodesk Inventor plugin now, since I received a beta license again, but SolidWorks will follow soon, too!

     

    Cheers!

     

    ---------------------------

    [1] https://thopiekar.eu:5443/cura-plugins/CuraPluginOven

    [2] https://thopiekar.eu:5443/cura-cad-integration/CuraBlenderPlugin/pipelines

    • Like 1
    Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Hi, I have installed Ultimaker Cura 3.6 (Windows 10 64x) and through Cura MarketPlace I installed the 3ds Solidworks Plugin (0.5.6 version). We have a server license for Solidworks and no problem with it.

    When Cura is launched an error message about the plugin is shown (image at the end). I also added an extract of the cura.log file.

    1196221462_3dsSWpluginCuraerror.png.e10923099b22c061e3456ffa9c5aede0.png

     

    extract cura log.zip

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)
    11 hours ago, Noemi said:

    Hi, I have installed Ultimaker Cura 3.6 (Windows 10 64x) and through Cura MarketPlace I installed the 3ds Solidworks Plugin (0.5.6 version). We have a server license for Solidworks and no problem with it.

    When Cura is launched an error message about the plugin is shown (image at the end). I also added an extract of the cura.log file.

    1196221462_3dsSWpluginCuraerror.png.e10923099b22c061e3456ffa9c5aede0.png

     

    extract cura log.zip

     

    Thank you for reporting this. From your logs, I only see that the VersionUpgradeManager is going through my files.

    (Which I already find strange, since why should it know about upgradable files in my plugin(s).)

    Anyway, can you send me more lines? Maybe if you care about privacy, then you can send it via private message and then I can share my email address if even needed.

    Would really like to understand how it comes.

     

    Might be that the error code we get on your computer doesn't only happen with invalid licenses, but also something else. Therefore a wrong error message could be the case.

    I only remember that I went into this situation when I disconnected from the network and the server couldn't get contacted. But that doesn't seem to be your case 😕 

  • Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)
    17 hours ago, thopiekar said:

    I only see that the VersionUpgradeManager is going through my files.

     

    That's a bug that has been fixed for Cura 4.0 (https://github.com/Ultimaker/Uranium/commit/b58ce0caa494fc8c798d869a612f12e259b91eb7#diff-e85a1a432b40396c54ca875559096df3)

    • Like 1
    Link to post
    Share on other sites
    Posted · SolidWorks plugin (official thread)

    Ok, thanks! Never noticed the issue before or I was simply good in overlooking (or just forgetting) it. 😀

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • Startups, apply for the Forward AM Innovation Award!
        Are you a startup using 3D printing? Perhaps you should continue reading... 
         
        Together with BASF we are launching the Forward AM Innovation Award - the very first global contest for startups developing new applications with 3D printing!
         
        Why apply?
        The winning startup will receive €100,000 in goods and services*, along with coaching and marketing exposure from top-notch leaders in the industry.
         

         
        Who can apply?
        Your startup creates products using Additive Manufacturing, is less than 5 years old, and has less than 50 employees. We are looking for 3D printing applications with a strong focus on innovation, sustainability and scalability.
         
        Dental aligners, shoes, tools, automotive parts, music instruments, industrial tooling and molding, medical implants, sports equipment, toys, architecture, fashion, construction... all are welcome to join!
         
        Do you have an innovative, sustainable and scalable idea that leverages the unique possibilities of 3D printing? Then it is time to apply!
        More information can be found here.
         
        Applications close on March 28th, 2021
        * What does "in goods and services" mean?
        The winner will be able to pick any item from the overall product and service portfolio of the sponsors, e.g. printers, materials, consulting, software... Choose whatever you need to accelerate your startup.
         
          • Like
        • 0 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...