Jump to content
Ultimaker Community of 3D Printing Experts

3.0.3 Crashes when trying to set up printer.


Recommended Posts

Posted · 3.0.3 Crashes when trying to set up printer.

What OS do you use? If you use Windows, you could try the following:

Replace C:\Program Files\Cura 3.0\resources\shaders\grid.shader with this file:

https://raw.githubusercontent.com/Ultimaker/Cura/1313e01f04838ac0a2d83b332dc57b6f5db0b87c/resources/shaders/grid.shader

When adding the first printer, it is the first time the buildplate is drawn. The shader that should draw the grid lines on the buildplate is broken on older GPUs. A fix was made, though it was not included in the 3.0 release. Replacing the grid.shader applies that fix to your local installation.

  • Like 1
Link to post
Share on other sites
Posted · 3.0.3 Crashes when trying to set up printer.

I am installing it on a windows 10 machine. And I am trying to set up a custom printer because they done have the gMax listed. But when I go to the machine settings, the program freezes before I can even change any settings and then closes itself. I will look into replacing the shaders.

  • Link to post
    Share on other sites
    Posted · 3.0.3 Crashes when trying to set up printer.

    I have noticed that there seem to be a lot of issues with Cura and third party printer setups. I keep hoping someone will try to install an Ultimaker to see if it has the same issue.

    It either seems to be third party printers or Intel video chips that are the bane of this go around.

  • Link to post
    Share on other sites
    Posted · 3.0.3 Crashes when trying to set up printer.

    Tried updating my UM2 to the new cura 3.0.3 from 2.6.2 (win10) all seems to go well and it says firmware upgrade successful but my UM2 still shows 2.6.2 as current firmware :( tried numerous times but just won't update, so printer still on 2.6.2

  • Link to post
    Share on other sites
    Posted · 3.0.3 Crashes when trying to set up printer.

    What OS do you use? If you use Windows, you could try the following:

    Replace C:\Program Files\Cura 3.0\resources\shaders\grid.shader with this file:

    https://raw.githubusercontent.com/Ultimaker/Cura/1313e01f04838ac0a2d83b332dc57b6f5db0b87c/resources/shaders/grid.shader

    When adding the first printer, it is the first time the buildplate is drawn. The shader that should draw the grid lines on the buildplate is broken on older GPUs. A fix was made, though it was not included in the 3.0 release. Replacing the grid.shader applies that fix to your local installation.

    Thank you ahoeben. This fixed the issue.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...