Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
berrybot3d

Cura g-code making my extruder go backwards at the start of print??

Recommended Posts

Hi Guys, This is my first post! I am really liking Cura!! I have used all the others and my faviorite up to now has been KISSlicer however I am liking Cure for many reasons the main one being that is works hard not to make crossover moves all over the place. I love that!! One thing I have not figured out yet is why at the very beginning of every print my extruder runs backward about 200 mm before it starts to print. As you can imagine not good as my extruder will take forever to get re-primed. Up to now I have just been pinching the idler bearing arm to prevent the filament from moving until it stops and then let is continue as normal. This is a look at the start code Cure is generating:

;TYPE:CUSTOM

M92 E481.000000 ( The only place I can think of the I put this value in the program is under: Preferences/ Steps per E = 481??)

M140 S50.000000

M109 T0 S240.000000

T0

M190 S50.000000

; [mm] mode

G21

; absolute mode

G90

; Home

G28

; Heated bed control

M140 S<BED>

;LAYER:0

;TYPE:SKIRT

G1 X-73.494 Y-35.457 Z0.25 F3000.0

G1 X-73.4 Y-30.205 F600.0 E0.2257………………….

The thing I am not sure about is the why the M92 E481.000000 is being generated at the first line? And why that would make my extruder go backward if anything I would think It would try to extrude forward.

Thanks for the help Guys!

Werner

Designer of the BerryBot3D

YouTube: https://www.youtube.com/channel/UChZIa-t7aKDU2TE7tAuY3IA/videos

 

Share this post


Link to post
Share on other sites

Does it do this *before* it gets up to temperature? If so, then I suppose it's probably the M92 command. Why not just remove this line from the gcode? I'm going to guess if you set this to zero in preferences maybe it won't show up in the gcode file?

M92 is supposed to set steps for extruder but... Are you using Marlin? Whatever you are using, I've never heard of the T0 command either. What's that do?

If you remove the first line and it still does this, try adding an M0 between every line of gcode (which should pause). That way you can figure out which line exactly is causeing the retraction.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Introducing Ultimaker Cura 3.6 | Beta
      Ultimaker Cura 3.6 | Beta is available. It comes with new features, bug fixes, and UX improvements. We would really like to have your feedback on it to make our stable release as good as it can be. As always, you can download the beta for free from our website, for Windows, MacOS, and Linux.
        • Like
      • 95 replies
    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
        • Like
      • 30 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!