Jump to content
Ultimaker Community of 3D Printing Experts
Zekiguy123

No matter what I do, I can't level the print bed.

Recommended Posts

I recently got an Ultimaker 2, I owned a cheap 3d printer before so I have some experience, however, I could not seem to be able to level the build plate after following the build plate leveling guide and many other online guides, and even trying to do it myself. I uploaded a vid on youtube showing what I'm doing. Please help, am I doing something wrong?

Video link:

Thanks

-Zeki :)

Share this post


Link to post
Share on other sites

Above youtube video doesn't show. It doesn't work. If it works for you then you must have made it private. Please try again. A video would really help. I do the leveling procedure in this video here - about 3m 18 sec I show some leveling techniques. Somewhere in the first 6 minutes I show how to do the leveling wizard for UM2 and it's identical for UM3.

Share this post


Link to post
Share on other sites

Good video.

The main issue I think is the paper is too thick. If you watched my video I actually use no paper at all and level touching the glass. In your video it is doing exactly what I see when leveling too high.

I think that's all you need to do. In fact, skip the leveling procedure now and just rotate the 3 screws the same amount CCW to move the bed up. Go up about a half turn. You want some good squish. Maybe a full turn will be needed. Without good squish the part will look fine until it gets up about a cm and then start pulling off the bed on the corners.

I really think that's the only issue but it's possible your glass is also not very flat. This is tempered glass (for no good reason as far as I can tell) and tempered glass process leaves the glass higher in the center. When you do the leveling you tilt this mini-mountain so the front corners are fine and the rear center is fine but the rear corners are quite low. You can test all this with a ruler or straight edge. You can correct by inserting washers under the corners of the glass or buying neoceram glass but really I don't think this is the main issue.

Share this post


Link to post
Share on other sites

Nope, the main problem is still on the back right, with the filament not sticking onto the build plate, like the video I made. I watched your vid and followed your instructions, even with the washer but nope. I am wondering if the glass has a problem or maybe the settings I am printing on. I am using ColorFabb white PLA @ 220ish degrees. I am new to a lot of the setting for the Ultimaker like fan speed.

Share this post


Link to post
Share on other sites

Well in your video the entire outer line was too far from the glass. Did you try leveling with the nozzle touching the glass? If you did and the far right corner is still bad then it's almost certainly the glass. Check it with a ruler or a straight edge. Try different angles.

I fixed mine by bending the bed up in the rear corners very hard but that was foolish of me because I could have broken the heated bed circuit board. I forget that was under the aluminum.

If your glass is more than .2mm lower in that corner then I would insist on getting a replacement from your reseller. This is a known problem -- there is some variation these glass plates and some are worse than others.

Share this post


Link to post
Share on other sites

Oh wow. That is bad.

Did you enable support? You don't need support for this print. I hope you enabled support because if not I do't know what is going on under his hands.

It looks like a combination of underextrusion and support in places not needed. And bad overhangs.

Is this PLA or ABS? It looks like ABS printed with PLA settings. What was your layer height, print speed, temperature, material, nozzle diameter, and line width in cura?

Share this post


Link to post
Share on other sites

Okay well then some of the mess on the robot is support but the main issue is underextrusion. 60mm/sec at 220C and .4mm nozzle with 1mm shell (.5mm forced out of a .4mm nozzle for two passes) and assuming .2mm layer thickness - well that's too much. Try forcing cura to do .4mm line widths and make your shell either .8mm or 1.2mm. Usually the 1mm default works fine so I'm not sure what cura defaults are. Anyway try messing with the TUNE menu while it's printing the robot and cut the speed down to 50% and then try 25% and then 10% and see what speed it prints fine at and report back. You may have something wrong with your printer that is causing underextrusion or it might have just been a bad slicing. But I won't know if the printer is exceeding it's ability unless I know layer height as well.

Basically I know at a given temperature what the volume can go up to. So at 220C you should be able to print PLA around 3 to 5 mm^3/sec through a .4mm nozzle. 5 on a brand new printer but 3 is still reasonable. If you can only print 1 cubic mm without getting underextrusion then something is definitely wrong and we can go from there.

Share this post


Link to post
Share on other sites

hiya,

try this.

elevate the back left corner with some paper. I used 0.5mm but for me it as at the back right.

then level the build plate again.

once you have done that use the menu to raise the build plate. Or manually do it by lifting it by hand and possible rotating the Z screw. get the nozzle nice and close. then move the head left to right at the back and see if the height varies. if it does adjust the relevant corner with small sheets of paper. one happy check all around the build plate to see how it has affected the rest. you may need to adjust a little with the screw for levelling the bed. but once you have done it that should be you. and subsequent bed levelling done through the menu should result in near level build area.

Bex

  • Like 1

Share this post


Link to post
Share on other sites

Yeah - I agree. It's really bad. Here are the common causes - this list covers UMO, UM2 and UM3 - #1 is the most common cause of underextrusion. Pay close attention to that first. If it "used to work fine" and you changed nothing (not even slicer settings) then #3 is by far the most common. Yours seems so bad I would suspect a steps/mm setting which could happen if you updated firmware or messed with steps/mm or flow on the printer. For example the UM2+ firmware on a UM2 will do exactly what is shown above.

CAUSES FOR UNDEREXTRUSION AND HOW TO TEST FOR THEM AND REMEDY THEM

As far as underextrusion causes - there's just so damn many. none of the issues seem to cause more than 20% of problems so you need to know the top 5 issues to cover 75% of the possibilities and 1/4 people still won't have the right issue. Some of the top issues:

1) Print slower and hotter! Here are top recommended speeds for .2mm layers (twice as fast for .1mm layers) and .4mm nozzle:

20mm/sec at 200C

30mm/sec at 210C

40mm/sec at 225C

50mm/sec at 240C

The printer can do double these speeds but with huge difficulty and usually with a loss in part quality due to underextrusion. Different colors print best at quite different temperatures and due to imperfect temp sensors, some printers print 10C cool so use these values as an initial starting guideline and if you are still underextruding try raising the temp. But don't go over 240C with PLA.

2) Shell width confusion. Shell width must be a multiple of nozzle size (in cura 15.X. In cura 2.X it doesn't matter as much but still makes a difference). For example if nozzle size is .4mm and shell width is 1mm cura will make the printer do 2 passes with .5mm line width which is possible but requires you to slow down much more to make a .5mm line out of a .4mm nozzle. If you really want this then set nozzle size to .5mm so it's clear what you are asking Cura to do for you.

3) Isolator - this is most common if you've printed extra hot (>240C) for a few hours or regular temps (220C) for 500 hours. It gets soft and compresses the filament under pressure. It's the white part touching the heater block. It's very hard to test when not under full pressure (spring and bowden) so sometimes it's best to just replace it. Also if you notice parts of it are very soft (the blacker end where it touches higher heat) then it's too old and needs replacing.

4) Curved filament at end of spool - if you are past half way on spool, try a fresh spool as a test.

5) curved angle feeding into feeder - put the filament on the floor -makes a MASSIVE difference.

6) UM2 only: Head too tight? Bizarrely MANY people loosen the 4 screws on the head by just a bit maybe 1/2 mm and suddenly they can print just fine! Has to do with pressure on the white teflon isolator.

6b) UM2 only: Bowden pushing too hard - for the same reason you don't want the bowden pushing too hard on the isolator.

6c) Um2 only: Spring pushing too hard. Although you want a gap you want as small as possible a gap between teflon isolator and steel isolator nut such that the spring is compressed as little as possible.

7) clogged nozzle - the number one problem of course - even if it seems clear. There can be build up on the inside of the nozzle that only burning with a flame can turn to ash and remove. Sometimes a grain of sand gets in there but that's more obvious (it just won't print). Atomic method (cold pull) helps but occasionally you need to remove the entire heater block/nozzle assembly and use flame. I found soaking with acetone does not help with caramelized pla. Even overnight. Maybe it works on ABS though.

8) Temp Sensor bad - even the good ones vary by +/- 5C and bad ones can be any amount off - they usually read high and a working sensor can (rarely) fail high slowly over time. Meaning the sensor thinks you are at 220C but actually you are at 170C. At 170C the plastic is so viscous it can barely get out of the nozzle. You can verify your temp sensor using this simple video at youtube - on you tube search for this: mrZbX-SfftU

9) feeder spring issues - too tight, too loose. On the black UM2 feeder you want the tension such that you can clearly see the diamond pattern biting into the filament. You want to see at least 2 columns of diamonds. 4 columns is too much. On the white UM2 plus and UM3 feeders you usually want the tension set in the center.

10) Other feeder issues, one of the nuts holding UM2 and UM3 together often interferes with the feeder motor tilting it enough so that it still works but not very well. Other things that tilt the feeder motor, sleeve misaligned so it doesn't get a good grip. Gunk clogging the mechanism in there.

11) Filament diameter too big - 3mm is too much. 3mm filament is usually 2.85mm nominal or sometimes 2.9mm +/- .05. But some manufacturers (especially in china) make true 3.0mm filament with a tolerance of .1mm which is useless in an Ultimaker. It will print for a few meters and then clog so tight in the bowden you will have to remove the bowden from both ends to get the filament out. Throw that filament in the trash! It will save you weeks of pain

11b) Something wedged in with the filament. I was setting up 5 printers at once and ran filament change on all of them. One was slowly moving the filament through the tube and was almost to the head when I pushed the button and it sped up and ground the filament badly. I didn't think it was a problem and went ahead and printed something but there was a ground up spot followed by a flap of filament that got jammed in the bowden tube. Having the "plus" upgrade or using the IRobertI feeder helps you feel this with your hand by sliding the filament through the bowden a bit to see if it is stuck.

12) Hot weather. If air is above 30C or even possibly 25C, the air temperature combined with the extruder temperature can soften the filament inside the feeder such that it is getting squeezed flat as it passes through the feeder - this is obvious as you can see the problem in the bowden. The fix is to add a desk fan blowing on the back of the printer. Not an issue on the UM3 or UM2 "plus" series.

13) Crimped bowden. At least one person had an issue where the bowden was crimped a bit too much at the feeder end although the printer worked fine when new it eventually got worse and had underextrusion on random layers. it's easy to pull the bowden out of the feeder end and examine it.

14) Worn Bowden. After a lot of printing (or a little printing with abrasive filaments) the bowden resistance can be significant. It's easy to test by removing it completely from the machine and inserting some filament through it while one person holds it in the U shape. Preferably i nsert filament that has the pattern from the feeder.

15) Small nozzle. Rumor has it some of the .4mm nozzles are closer to .35mm. Not sure if this is actually true. I'm a bit skeptical but try a .6mm nozzle maybe.

16) CF filament. The knurled sleeve in the extruder can get ground down smooth - particularly from carbon fill. 4 spools of CF will destroy not just nozzles but the knurled sleeve also. Look at it visually where the filament touches the "pyramids". Make sure the pyramids are sharp.

17) Hot feeder driver. I've seen a more recent problem in the forums (>=2015) where people's stepper drivers get too hot - this is mostly a problem with the Z axis but also with the feeder. The high temps means the driver appears to shut down for a well under a second - maybe there is a temp sensor built into the driver chip? The solution from Ultimaker is that they lowered all the currents to their stepper drivers in the newer firmware. Another solution is to remove the cover and use desk fan to get a tiny bit of air movement under there. TinkerMarlin lets you set the currents from the menu system or you can send a gcode to lower the current. Ultimaker lowered the default currents in July of 2015 from 1300ma to 1200ma for X,Y,Z but left extruder at 1250. Other people (I think the support team of a major reseller but I forget) recommend X,Y,Z go down to 1000mA.

M907 E1250

Above sets the extruder max current to the default - 1250mA. So try 900mA. This will only change until next power cycle so if you like your new value and want to save it use M500. You can just put these into an otherwise empty gcode file and "print" this and it will change. Or get tinkergnome marlin! You will wonder how you lived without it: https://github.com/TinkerGnome/Ultimaker2Marlin/releases

M907 E900

M500

18) third fan broken. This tends to cause complete non-extrusion part way through a print. In the rear of the head for UM2 and the front of the head for UM3. Without this fan several things can go wrong. It can take a while as usually you also need several retractions to carry the heat upwards. There are a few failure mechanisms and I don't understand them all. One of them is probably that the molten PLA spreads out above the teflon and sticks to the metal in a core or fills the gap at the base of the bowden in UM2. Later it cools enough to keep the filament from moving up or down.

19) Spiralize/vase mode. This is a rarely used feature of Cura but you might have left it on by accident? In this mode the wall of your part is printed in a single pass. So if you have a .4mm nozzle and the wall is .8mm thick it will try to over extrude by 2X. This is difficult to do and may instead lead to underextrusion.

20) non-standard or bent fan shroud. Sometimes people print some fan shroud off of thingiverse or youmagine out of PLA or ABS. Some of these are great but most of them are crap. One needs to do good air flow modeling. Also if it's PLA it will slump and direct air differently. Air directed at the block or nozzle can cause severe underextrusion and also sometimes HEATER ERROR. Put the original shroud back on or just turn off the fan to prove that the fan is the problem.

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I tried pretty much everything you said and have come to a conclusion that the problem is with my filament feeding motor. I completely take out all the filament, then manually insert it while moving the motor thru the maintenance menu, and the filament just gets dented, with heavy markings of the motor and not get pushed up. I completely loosened it too, and it still does it.

I think I should replace the motor. Can somebody send me a link to one, should I get a UM2 one or a UM2+ one? (I have a UM2 but if the UM2+ one is compatible I would rather pay extra for a slight upgrade (+ version) if it is compatible and won't cause problems.

UPDATE: Today I cleaned out the motor and now I think the problem is not with the motor, but is with the extruder. When I manually pull the filament up to the extruder it moves the filament up fine, but the second some filament comes out the extruder, it is not able to push the filament up as well. Why could this be???

Edited by Guest
update

Share this post


Link to post
Share on other sites

Hi Zeki,

Just been looking into your posting here and noticed you've got lots of good advices here.

As I've got a «similar» printer as you have, I'll have noticed a few issues to comment.

But first, the feeder stepper motors used in UM2 and UM2+ is different and the main difference is the number of steps per rev (360 deg.). UM2 use a 400 step/rev. stepper motor and UM2+ use a 200 step/rev. stepper motor.

 

If the filament have heavy marks (dented), then, how much tension is your feeder set to?

Normally it should be between the lo pressure mark and half mark setting (the middle is about max I'm using). The tension indicator is located on the right side of your feeder unit, locking into shaft (the old type). The upper position of the mark, is the lo tension, turning the umbraco (hex) screw counterclockwise increase pressure.. Heavy markings, takes a lot of the torque from the stepper motor..

As you now manage to have the heath bed properly adjusted, actually very close to the bed, this will increase the feeder pressure somehow, especially when making the initial layer. So for an UM2, reduce the speed for the initial layer to 15 mm/sec. This will reduce the torque your feeder have to cope with and should helps a lot here.

Another thing to mention, is the temperature for the nozzle when using PLA, -well «normally» I'll never go higher than 204 Degrees Celsius. My best prints is usually done at about 186 deg. C. and at 30 mm/s print speed.

Assuming you bought this printer second hand(?), -so if nothing can improve, you might consider go for a full upgrade kit to have an UM2+.. Will almost be as a brand new printer.

Edit:

Just wrote this, when I'm saw you mail just arrived..

This could just be some remains partly blocking your nozzle, or a squezed coupler (the insulator block) on top of the extruder block.

For the nozzle to clear, try the “atomic-metod” and see if this clear the nozzle you might do it several times..

Here is how: https://ultimaker.com/en/resources/19510-how-to-apply-atomic-method

It is very important to follow this methode as it is described!

The coupler have to be replaced.

Anyway, good luck.

Thanks.

Torgeir

Share this post


Link to post
Share on other sites

Try printing at 1/4 speed from the TUNE menu. Just print that robot again from the same file but once it starts up go to TUNE menu and set the feedrate to 25%. Play with that speed until it starts printing beautifully. Report back on the exact speed, temp, layer height, nozzle width setup in cura. Also report back on *all* the speed settings in cura and *all* the line width settings in cura.

That way I can tell if your printer is actually normal and you are printing too cold/fast/thick or if there really is something wrong.

BTW - Whenever inserting filament, make sure you cut it to a point first as it can get hung up in several locations along the path before it gets to the nozzle and cutting it to a point allows it to get through those spots.

Share this post


Link to post
Share on other sites

I doubt it's your feeder but here is a picture showing one filament where the tension was too low and another where it was a bit too high. You want it in between these two examples.

Print at 1/4 speed and if it looks identical then something is wrong with your firmware. If it prints great at 1/4 speed then you are either printing too much volume (slicer settings) or it's most likely the teflon part which should be replaced often anyway.

filament1.thumb.jpg.536eeea5733a82f2af83084d26ac02a7.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!