Jump to content
Ultimaker Community of 3D Printing Experts

Cura from source libArcus not found

Recommended Posts


Has anyone run Cura from source on Ubuntu 17.10 (fresh install) I have hit a snag where cura_app.py can't find Arcus, I compiled libArcus following the instructions on the github


$ mkdir build && cd build$ cmake ..$ make# make install


Their is a Arcus.so file in /usr/local/lib/python3/dist-packages


Original exception was:Traceback (most recent call last):File "cura_app.py", line 54, in import Arcus #@UnusedImportModuleNotFoundError: No module named 'Arcus'


Share this post

Link to post
Share on other sites

Hmm maybe I have done it wrong as I did not install cura I cloned the repos following Nallath guide he posted in one of the github issues.

“Checkout Cura, Uranium, CuraEngine, LibArcus.

Build LibArcus

Build Cura engine

Ensure Uranium is in your pythonpath.

Run cura_app.py with python3

If complaining about dependencies, install those with pip.

That's pretty much how i recently installed my new laptop.”

maybe this method does not work on Ubuntu :/

Share this post

Link to post
Share on other sites

I kept getting stuck with the cura-build-environment I tried googling on how to resolve it but most of the stuff I found did not work.

make[3]: *** [getarch_2nd] Error 1

gemv.c: In function ‘sgemv_’:

gemv.c:248:41: error: ‘GEMM_MULTITHREAD_THRESHOLD’ undeclared (first use in this function); did you mean ‘GEMM_THREAD_TR’?




gemv.c:248:41: note: each undeclared identifier is reported only once for each function it appears in

Makefile:841: recipe for target 'sgemv.o' failed

make[4]: *** [sgemv.o] Error 1

make[4]: *** Waiting for unfinished jobs....

Makefile:143: recipe for target 'libs' failed

make[3]: *** [libs] Error 1

CMakeFiles/OpenBLAS.dir/build.make:113: recipe for target 'OpenBLAS-prefix/src/OpenBLAS-stamp/OpenBLAS-build' failed

make[2]: *** [OpenBLAS-prefix/src/OpenBLAS-stamp/OpenBLAS-build] Error 2

CMakeFiles/Makefile2:640: recipe for target 'CMakeFiles/OpenBLAS.dir/all' failed

make[1]: *** [CMakeFiles/OpenBLAS.dir/all] Error 2

Makefile:83: recipe for target 'all' failed

make: *** [all] Error 2

Share this post

Link to post
Share on other sites

Okay fixed that error by merging in https://github.com/Ultimaker/cura-build-environment/pull/20

But now I'm getting this and have not been able to sort it out I tried installing setuptools using pip3 and installing python3-setuptools from the repos but nothing :/

[ 5%] Built target Python

[ 10%] Built target Sip

[ 15%] Built target OpenBLAS

[ 15%] Performing build step for 'NumPy'

Running from numpy source directory.

Traceback (most recent call last):

File "setup.py", line 386, in


File "setup.py", line 363, in setup_package

from setuptools import setup

ImportError: No module named 'setuptools'

CMakeFiles/NumPy.dir/build.make:113: recipe for target 'NumPy-prefix/src/NumPy-stamp/NumPy-build' failed

make[2]: *** [NumPy-prefix/src/NumPy-stamp/NumPy-build] Error 1

CMakeFiles/Makefile2:416: recipe for target 'CMakeFiles/NumPy.dir/all' failed

make[1]: *** [CMakeFiles/NumPy.dir/all] Error 2

Makefile:83: recipe for target 'all' failed

make: *** [all] Error 2

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!