Jump to content
Ultimaker Community of 3D Printing Experts
Maxwell

Ultimaker Original Z-Axis issues

Recommended Posts

Hey all, so I've been trying to get an older Ultimaker working and I'm having a fair bit of issue and I'm not sure what to do at this point. So the Z-Axis isn't homing right to start with, in fact it will click the switch while homing then move down about an 8th of an inch for no reason. I've tried adjusting the screw that hits the switch and moving the switch itself, but the problem still persists. Because of this I'm completely incapable of leveling the bed (the screws aren't long enough) and also when I try to print anything despite the issues it refuses to move up or down. All of the limiters are clear of debris and all of the connections are secure and I've updated the firmware multiple times to double check. I don't know what else it could be

Share this post


Link to post
Share on other sites

You only need the top switch working. The bottom one isn't really used. Download and run pronterface and connect your printer to the computer with pronterface through USB:

http://koti.kapsi.fi/~kliment/printrun/

Then I think pronterface shows the current state of all switches. I forget if it always does this or if you have to do an M command or click something or what. You can certainly send an M119 through pronterface and the UM will report back on the state of all switches. So then push the limit switch and do M119 again and make sure pronterface shows that the endstop changed.

Also in pronterface, try moving the Z axis without homing. You don't need to home it to simply move it 10mm. Make sure it moves the right direction. As z gets larger it should move downards. Z=0 should be touching the glass (but you need to home it first and of course it won't home yet). Report back what happens - maybe include a 10 second video of the homing.

Share this post


Link to post
Share on other sites

After it homes in pronterface move it to z=10:

G0 Z10

That should move it 10mm such that the nozzle and bed are 10mm apart.

Actually everything is looking good in both these videos. The bottom video is just a home of x,y,z. The top also homes x,y,z and then moves the bed down a bit and homes x,y a second time. Then it seems to move the nozzle to 3 locations where the 3 screws are which I guess is some bed leveling thing that I've never tried.

It actually all looks good in the videos.

Share this post


Link to post
Share on other sites

It sounds like there is something wrong with the leveling wizard maybe. I'd just use the ulticontroller to home Z and then hopefully X,Y are not locked and you can push the head around. If not, then use the menu item, something like "turn off motors" and you can push the head around and level with a piece of paper or just have it touching the bed gently.

You should put the blue tape on before leveling because that will be a more accurate leveling. Also always clean the blue tape with isopropyl alcohol (aka rubbing alcohol) as soon as you put the tape down because if you don't it leaves a waxy surface on the tape (the stuff that keeps the tape from sticking to itself) and your prints won't stick to the blue tape.

Share this post


Link to post
Share on other sites

I think I'm having the same problem here, but not sure I really understand the solution as described. My system is doing the same as described by Maxwell in the original post and in the first of the two videos. I did try using pronterface as described above but couldn't even get it to connect to the printer.

 

Am I missing something obvious? The bed will rise up to the limit switch, near enough to the bed for me to make the proper adjustments, but it won't stay there. As Maxwell said, it's as if the screws aren't long enough, but I know that the problem is in software that the zero point is set wrong. Is there a way to set the zero in Cura 3.2.1? I have not tried actually printing anything, though, so I don't know if that would work or not.

 

Would appreciate some help!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!