Jump to content
Ultimaker Community of 3D Printing Experts

specific print shifts layers on same point


Recommended Posts

Posted · specific print shifts layers on same point

i've printed this several times, and it shifted layers at around the same point each time. i tried reslicing it, tightening the screws on the xy axis, still the same. other files print fine.

if i import the gcode in cura, it shows it being fine

IMG_0136.jpg

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    i've printed one other thing that worked just fine, it was taller than this, so it definetly passed the point where it keeps shifting.

     

    @IRobertI i'll try that, but shouldn't it shift more irregular if it's because of loose pulleys?

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    During the years I've learnt to never assume things like that. It has bitten me in the arse before ;)

     

    You could also set up a camera to record what happens to maybe get some clues. You could skip loading any filament and lower the print temp once the print is started (so as to not cook the material left in the nozzle) so you don't have to waste any material.

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    @IRobertI the set screw for the pulley on the motor shaft appears to be missing

  • Link to post
    Share on other sites
    Posted (edited) · specific print shifts layers on same point

    it wasn't gone, there was a slightly shorter set screw in there so it looked as if it was gone untill i got the motor out and had a beter look. while i was there i tightened it, hope it works now

    Edited by edwardlego
  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    I am watching this to learn. I thought that something that was mechanical like that would pretty much put the error in all prints at about the same place.

     

    Does this have anything to do with the specific movements this model requires?

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    It's the set screws.  Probably on one end or the other of the short belt.  Tighten the hell out of those.  Enough that you are scared you might break something.  Enough that if you used an L shaped allen wrench your fingers would hurt afterwards.  Hurt quite a bit.

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    i did that, failed again on the same spot... gcode attached below if anyone wants to try

    UM2_venator_20cm_2_aft.gcode

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    I took a quick look in Cura 3.1 and it looked good there. I will try to squeeze in a test print shortly just to see if it works.

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    What happens if you print this model, together with a simple test tower next to it? Thus a different design that you make yourself, and put it on the same build-plate? Do they both go wrong?

     

  • Link to post
    Share on other sites
    Posted (edited) · specific print shifts layers on same point

    Hi Folks,

     

    This is a very detailed print with some issues.

    I'll guess this is the engine part of some "future space station"?

     

    I've also had a look into this model in Cura 3.1 and in S3D 4.0.1 and here is the pictures:

     

    Cura_Eng_Detail.thumb.jpg.67a2c8372de7ae684a2060c11aff73cf.jpg  

    Here we see the retractions that is visible very much in Cura.

     

    S3D_Eng_Detail.thumb.jpg.aa50f35c6847190ad1beca7558f001a1.jpg

    This is S3D with same part of the model, but a little wider. The colors represent print speed at details.

     

    S3D_Eng_Detail_Cut.jpg

    Again, S3D, this picture show a "cutout" of the print at an interesting place, (color) of the speed information during printing at this layer.

    Well, just wondering if there is some head (extruder) play and a hit so the Y stepper loose steps? Or could the X/Y stepper current happen to be set to too lo current?

     

    You could say this is one of the reason why I alternate between those two slicers..

     

    Anyway, just a thought.

     

    Thanks.

     

    Torgeir.

     

     

     

    Edited by Torgeir
  • Link to post
    Share on other sites
    Posted (edited) · specific print shifts layers on same point

    Looks like the back of a Star Destroyer or something Star Warsy to me, but if you didn't model it, then its most likely an issue with the model? but you said it printed on a different printer? so not sure, but if it ALWAYS skips in the same place, then just for a test, sink the entire model to that rough point in cura or whatever and sit by it till it skips. I've had the head skip on one ultimaker I abused at my previous job, but a little sewing oil crossed fingers and a retry sorted it out. If it always does it at the same point its either the model and slicer software issues with it, or a particular action the print head is doing to skip a tooth or two on one or two of the belts. (are you 100% sure you tightened all the screws maybe you missed one?  just a thought?) also try printing slower and disable retraction?  Who knows, remodel it yourself I'd say, as the poor quality of most downloaded models are the main reason I learned to model objects myself. especially for printing regardless of how detailed they are! Just I just cant stand seeing those low poly cylinders and faces on large round and curved surfaces!

    Forget low poly unless you are an animator, its all about high poly when it comes to printing! I personally am not into the 'low poly look' its an unfinished look to me, but each to their own of course! I have not had one printing issue since modelling things myself. Before they would happen now and then. Things can get corrupted, best to just try again. Also just because it loads into CURA it doesn't mean its not corrupted!

    Edited by cloakfiend
  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    1) I still think it's the set screws.  Use a sharpie to mark the shafts and pulleys on the short belts (4 pulleys) to prove it.

    2) It's possible you simply have too much friction.  with steppers not engaged (most of the time) push the head around and see if X and Y resistance is equal.  You should be able to use your smallest finger on each hand pushing on the two end blocks and move the head easily in X or Y.  Add one drop of oil (any light petroleum oil such as 3 in 1 or sewing machine oil) to the 4 outer rods.  The two rods through the head shouldn't need any oil but maybe a half drop of oil might help.

     

    That it always happens in the same spot is not surprising.  The planner inside the printer is complicated and quirky.  There are ways to send the right gcodes such that you have  higher acceleration than normal (because of these "bugs" or features in the planner).  In fact the firmware has two accelerations: one should never be exceeded and is around 5 meters per second squared.  The other is to truly NEVER exceed (lol!) and is around 9 meters per second squared.  Just knowing that there are two different max accelerations tells you something right there.  I've looked at the code carefully and understand why they did this but the point is this: the right pattern of movement can exceed the lower of the two accelerations.  But this is rare and might only happen a few times within a print.

     

    Lowering the acceleration and jerk by half will indeed help but then the quality of your print will go down.  Better to fix the hardware so you get good quality prints than to compensate your hardware issues by messing with the firmware settings.

  • Link to post
    Share on other sites
    Posted (edited) · specific print shifts layers on same point

    it's the aft section of a venator star destroyer from starwars, i downloaded it, but i put a lot of work in it to fixing it for printing. the bow section printed just fine, the aft failed before and after i printed the bow

    it doesn't shift on the exact same layer each time, but it's only a couple of mm off

    i'll wait for @kmanstudios 's print

    Edited by edwardlego
  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point
    3 minutes ago, edwardlego said:

    it's the aft section of a venator star destroyer from starwars, i downloaded it, but i put a lot of work in it to fixing it for printing. the bow section printed just fine, the aft failed before and after i printed the bow

    it doesn't shift on the exact same layer each time, but it's only a couple of mm off

    i'll wait for @kmanstudios 's print

    It may be tomorrow afternoon before I can post any results. I am also not sure how it will print since I am using a UM3X and the GCode was for your type machine. But I like to live dangerously :p

  • Link to post
    Share on other sites
    Posted · specific print shifts layers on same point

    Living dangerously is the only way to go!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...