Jump to content
ahoeben

Z Offset plugin needs testers

Recommended Posts

Posted · Z Offset plugin needs testers
8 hours ago, ahoeben said:

 

It should, yes. I can't test it with all printers though. Specifically, I don't have a delta so I never tested the plugin with one.

 

I don't know if there is an issue with using G92 with a delta running Marlin.

 

How old is your Marlin? It could be this issue: https://github.com/MarlinFirmware/Marlin/issues/2106

It could very well be that old.  I am planning to update this printer, but have not bothered until now because "If it ain't broke, don't fix it".

 

I will try that.

DLC

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

Yes, we use it with Cura 4.3 on our S5, UM3 and Ender 3 (with the latest marlin).

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

Okay, would you mind posting the correct link to download it? I see there's multiple one's so I'm not sure which is the right one.

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers
35 minutes ago, Oliveros said:

Okay, would you mind posting the correct link to download it? I see there's multiple one's so I'm not sure which is the right one.

Just download through Cura, that will give you the correct version. 

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

The computer that we use for printing as well as 3D renderings and visualizations is not connected to the internet for security reasons, I have to download it and then transfer it to that computer via a USB. 

 

Is there a way to download it without being in Cura?

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

Awesome, I downloaded it, thank you. I'll try it out next chance I get.

 

Does anyone have experience with Monoprice's PETG and what offset works best?

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

0.1 or 0.15 can be a good start - depending on your nozzle distance after a good bed levelling. Try yourself. And I suggest opening a separate thread with this issue.

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers
On 4/19/2019 at 5:18 PM, ahoeben said:

Feedback is appreciated.

Installed the latest version today, using UM3E and S5.

 

image.png.7a55a905eec121d02d207f7e04ccffd2.png

After some failed prints and some investigation: z-Offset processes only the value from the first extruder, the value from the second extruder seems to be ignored. If both are the same - yeah, easy. Just another option to confuse yourself.

 

It helps to deactivate the unused extruder.

 

Watch out for ;ZOFFSETPROCESSED

;END_OF_HEADER
;ZOFFSETPROCESSED
;Generated with Cura_SteamEngine 4.3.0

 

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

The plugin cannot use a different offset per extruder; it has to choose one. In my "infinite wisdom", I chose to pick the lowest value between the active extruders (ie: the closest to the bed). I'm open to suggestions for better logic.

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers
1 hour ago, ahoeben said:

In my "infinite wisdom", I chose to pick the lowest value between the active extruders (ie: the closest to the bed). I'm open to suggestions for better logic.

Your wisdom is more infinite than mine 😀!

If it cannot use a different offset, why not share the customized offset on both extruders per default and visible in the settings? My fault was more than once to add an offset of maybe 0.15 on my preferred material and forget the other, unused material - whose offset was 0, of course. ZOffset used 0mm offset, as intended.

 

This behaviour was the reason for some serious glass plate chipping on both printers - something I wanted to avoid.

 

Maybe it is only my logic and instead of starting an extended discussion i will adapt.

 

I am very thankful for your plugin and use it almost all the time (with one extruder).

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

Based on my experience with the Z-offset, having the nozzle where it's squishing a little bit works good for PETg and Nylon.

 

My printer in the new software update comes with a Z-offset option so I'm using that and it works great.

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers
49 minutes ago, dxp said:

why not share the customized offset on both extruders per default and visible in the settings?

 

??

That's what it does, doesn't it? The only place where you can fill in different values is in the Material settings (if you have the Material Settings plugin installed!). The "sidebar" always shows a single value for all extruders.

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers
13 minutes ago, ahoeben said:

That's what it does, doesn't it?

Unfortunately (the way I do) not.

image.thumb.png.65d2f3508005cb6b406e204d0f048eec.png

UM S5 normal profile. I just changed Z-Offset on extruder 2 to 0.15. No Processing. No sharing. See gcode. I installed Material Settings. No change.

 

UMS5_string_test_fast_pyramid000-015.gcode

Share this post


Link to post
Share on other sites
Posted (edited) · Z Offset plugin needs testers

What version of the plugin do you have? You can find this on the "Installed" tab of the Marketplace. The current version is 3.5.3

 

image.thumb.png.36c5a6db610593aff7807aaae2a7ef6d.png

Edited by ahoeben

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers
14 hours ago, ahoeben said:

What version of the plugin do you have?

I'm using 3.5.3. Cura is 4.3.0 on a Win10 64bit machine. Z Offset is NOT shared (see picture), the tooltip is different from yours. Yesterday I backed all cura settings and restarted from zero. You can get all assistance and information you want 🙂

image.thumb.png.a8fbe710449e5a7bec86d6605045196e.png

The plugin is installed in my user folder.

image.thumb.png.3c4280d85f50dfcf8fd582334c599694.png

Share this post


Link to post
Share on other sites
Posted (edited) · Z Offset plugin needs testers
3 hours ago, dxp said:

I'm using 3.5.3. Cura is 4.3.0 on a Win10 64bit machine.

 

I want to believe you, but I can't tell from your screenshot. All that inset shows is that 3.5.3 is the version that is available from the Marketplace. Please check on the "Installed" tab of the Marketplace. Also please try removing the plugin and installing it again.

 

The second screenshot just manages to cut of the interesting lines of code. Can I see the next 4 lines too?

 

Update: nevermind, my bad. I'll get this fixed.

Edited by ahoeben

Share this post


Link to post
Share on other sites
Posted · Z Offset plugin needs testers

image.thumb.png.8e86d5fe892ca63a569640c43503b8bb.png

ZOffsetPlugin-v6.0.0-2019-11-05T11_14_47Z.curapackage checked. The value is shared between the extruders, hooray!

(And I added a little message to check which code is used.)

 

image.thumb.png.8143a7a6fd6c11414e6cb862f6b3b588.png

The "interesting lines of code" now read:

            "minimum_value": "-(layer_height_0 + 0.15)",
            "maximum_value_warning": "layer_height_0",
            "resolve": "extruderValue(adhesion_extruder_nr, 'adhesion_z_offset') if resolveOrValue('adhesion_type') != 'none' else min(extruderValues('adhesion_z_offset'))",
            "settable_per_mesh": False,
            "settable_per_extruder": False,
            "settable_per_meshgroup": False
        }

before:

           "minimum_value": "-layer_height_0",
            "maximum_value_warning": "layer_height_0",				 
            "settable_per_mesh": False,
            "settable_per_extruder": True,
            "settable_per_meshgroup": False

Seems reasonable. Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!