Jump to content
Ultimaker Community of 3D Printing Experts

Screen corruption with 3.2 on Mac


Recommended Posts

Posted · Screen corruption with 3.2 on Mac

Same here...

 

  Model Name:    MacBook Pro
  Model Identifier:    MacBookPro11,3
  Processor Name:    Intel Core i7
  Processor Speed:    2.5 GHz
  Number of Processors:    1
  Total Number of Cores:    4
  L2 Cache (per Core):    256 KB
  L3 Cache:    6 MB
  Memory:    16 GB
  Boot ROM Version:    MBP112.0142.B00
  SMC Version (system):    2.19f12

 

Intel Iris Pro:

  Chipset Model:    Intel Iris Pro
  Type:    GPU
  Bus:    Built-In
  VRAM (Dynamic, Max):    1536 MB
  Vendor:    Intel
  Device ID:    0x0d26
  Revision ID:    0x0008
  Automatic Graphics Switching:    Supported
  gMux Version:    4.0.8 [3.2.8]
  Metal:    Supported, feature set macOS GPUFamily1 v3
  Displays:
Color LCD:
  Display Type:    Built-In Retina LCD
  Resolution:    2880 x 1800 Retina
  Framebuffer Depth:    24-Bit Color (ARGB8888)
  Main Display:    Yes
  Mirror:    Off
  Online:    Yes
  Rotation:    Supported
  Automatically Adjust Brightness:    No
 

Screen Shot 2018-02-07 at 6.50.12 PM.png

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    This seems to affect a fair amount of OS X users, but unfortunately I have not been able to reproduce it on my wife's late 2015 macbook pro with OS X 10.13, or on a virtual machine hackintosh. That make it hard to figure out why this is happening.

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Mine's a "MacBook Pro (Retina, 15-inch, Early 2013)". MacOS High Sierra 10.13.3.

     

     

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac
    5 hours ago, nallath said:

    Have you updated your drivers?

     

    That’s the best joke ever hahaahahahah OSX hahahahahahaha

     

    This made my day XD

     

    Any chance of launching anything to generate a debug file so this issue can be fixed? Was on 3.1 beta, then fixed, now back again

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Same issue here.

     

    macOS 10.13.3

     

    Hardware Overview:

      Model Name:    MacBook Pro
      Model Identifier:    MacBookPro11,3
      Processor Name:    Intel Core i7
      Processor Speed:    2.6 GHz
      Number of Processors:    1
      Total Number of Cores:    4
      L2 Cache (per Core):    256 KB
      L3 Cache:    6 MB
      Memory:    16 GB
      Boot ROM Version:    MBP112.0142.B00
      SMC Version (system):    2.19f12
     

     

    NVIDIA GeForce GT 750M:

      Chipset Model:    NVIDIA GeForce GT 750M
      Type:    GPU
      Bus:    PCIe
      PCIe Lane Width:    x8
      VRAM (Total):    2 GB
      Vendor:    NVIDIA (0x10de)
      Device ID:    0x0fe9
      Revision ID:    0x00a2
      ROM Revision:    3776
      Automatic Graphics Switching:    Supported
      gMux Version:    4.0.8 [3.2.8]
      Metal:    Supported, feature set macOS GPUFamily1 v3
      Displays:
    Color LCD:
      Display Type:    Built-In Retina LCD
      Resolution:    2880 x 1800 Retina
      Framebuffer Depth:    24-Bit Color (ARGB8888)
      Main Display:    Yes
      Mirror:    Off
      Online:    Yes
      Rotation:    Supported
      Automatically Adjust Brightness:    No


     

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Can't reproduce on my Mac either (MacBook Pro 13'', latest OS version).

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    So of all the ones that has chimed in to this thread...who uses a retina MacBook and who does not?

     

    I see retina screens in use by the ones who reported issues and they also included their system info. But those who says "it works" have not posted if they have a retina screen...nor have they included their system info.

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    The macbook pro I tested on does have a Retina screen, but does not reproduce the issue. I tried different resolutions too (best for this device, more space, etc)

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Tested on my Macbook Pro 2016 up-to-date OSX and not seeing this issue.

  • Link to post
    Share on other sites
    Posted (edited) · Screen corruption with 3.2 on Mac

    We made a test version, it includes some bug fixes and a possible fix for the garbled texts. We have tested this version, but not extensively.

     

    The download location is from my personal could storage, since we don't have another way to distribute 'daily' builds (yet).

     

    Could you try Cura 3.2.1: https://stack.mybacklog.info/s/MgLnKXLL0P9ro4M 

    Edited by Msuurmond
  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Happy to try it but please can someone confirm that this is genuine. It isn't on the Ultimaker web site. I don't know what stack.mybacklog.info is. I'm afraid I'm new to this forum and don't know who the people are either. Can I trust this download?

     

    Julian

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac
    1 minute ago, Julian7 said:

    Happy to try it but please can someone confirm that this is genuine. It isn't on the Ultimaker web site. I don't know what stack.mybacklog.info is. I'm afraid I'm new to this forum and don't know who the people are either. Can I trust this download?

     

    Julian

    It is not an official version, but it has the fixes for the garbled text in it (at least we hope). The download location is from my personal 'cloud' folder, if you trust me/us that is something you need to decide for yourself.

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac
    On 08/02/2018 at 4:12 PM, neotko said:

     

    That’s the best joke ever hahaahahahah OSX hahahahahahaha

     

    This made my day XD

     

    Any chance of launching anything to generate a debug file so this issue can be fixed? Was on 3.1 beta, then fixed, now back again

    Thanks for being a constructive member of the community!

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac
    44 minutes ago, nallath said:

    Thanks for being a constructive member of the community!

     

    Where’s the issue there Nallath?

     

    My joking about updating drivers on a osx? (Osx ain’t windows)

     

    Or me asking for a feature to create a debug file so future graphical issues can be debugged better and easier by Cura team?

     

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac
    4 hours ago, Msuurmond said:

    We made a test version, it includes some bug fixes and a possible fix for the garbled texts. We have tested this version, but not extensively.

     

    The download location is from my personal could storage, since we don't have another way to distribute 'daily' builds (yet).

     

    Could you try Cura 3.2.1: https://stack.mybacklog.info/s/MgLnKXLL0P9ro4M 

     

    Unfortunately, garbled text issue is still there using 3.2.1.  No change for me a least.  Thanks.

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    @Msuurmond I have tried the 3.2.1 version and the problem with text corruption on the screen is still present.

     

    Julian

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Hi, tired the 3.2.1 version, the bolded text is now clear but the regular text is still all wonky. 

    Screen Shot 2018-02-12 at 10.52.49 AM.png

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    This is a long shot, but could you try this version: https://stack.mybacklog.info/s/dr4Dwy2lr4tNE0q

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    Just the same as before. Not fixed. Sorry

     

    Julian

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac
    1 hour ago, Julian7 said:

    Just the same as before. Not fixed. Sorry

     

    Julian

    I just changed the last part of the custom settings back as it was on 3.1, last try: https://stack.mybacklog.info/s/LDltcUP2BXur7AZ

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    That fixed it for me. Everything is readable now.

  • Link to post
    Share on other sites
    Posted · Screen corruption with 3.2 on Mac

    I think it may have been something on my system, though.  I have migrated my system using migration assistant from a dying 2008 mac pro to a 2017 iMac since my original post.

    Maybe whatever was causing the issue was left behind in the corpse...

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...