Jump to content
remars

Ultimaker setzt am Ende einen Batzen Filament drauf

Recommended Posts

Posted (edited) · Ultimaker setzt am Ende einen Batzen Filament drauf

Versionen: die Firmware war immer 2.6.2 - nur Cura Versionen geändert. Wobei ich die Tests jetzt alle mit Cura 3.2.1 gemacht habe.

 

Das mit dem M25 habe ich nicht so richtig verstanden - wo und wie genau sollte man das einfügen? Über Cura direkt oder manuell? Mit oder ohne zusätzlichen Kommentarzeilen? Bei manuell: Kommentar im Code oder danach und M25 vor oder hinter dem Kommentar? Ich meine letztendlich ist nur eine Lösung sinnvoll, die automatisch eingefügt wird also über Cura.

 

Vielen Dank für die Anregungen für weitere Tests und Überlegungen. Guter Tip, habe jetzt mal mit irgendeinem Text gearbeitet - geht - aber nicht immer.

Fazit: Mindestens 4 Zeilen Kommentar in Cura für Geräteeinstellungen (Einstellungen - Cura konfigurieren - Drucker - Geräteeinstellungen) bei "Gcode beenden" die Zeilen eingefügt. Was ich jetzt nicht probiert habe ist, ob die Länge des Textes auch einen Einfluss hat. Zumindest habe ich jetzt ein Work-Around.

 

Hier übrigens meine Testübersicht:

Hinten = Nach der letzten Zeile in der Datei / Im Code = zwischen den Zeilen "M107" und "M82..." hinten in der Datei

image.thumb.png.65c8677c137873ae1c1a28d754881fa4.png

 

 

Edited by ndimensional

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf
14 hours ago, ndimensional said:

Das mit dem M25 habe ich nicht so richtig verstanden - wo und wie genau sollte man das einfügen? Über Cura direkt oder manuell? Mit oder ohne zusätzlichen Kommentarzeilen? Bei manuell: Kommentar im Code oder danach und M25 vor oder hinter dem Kommentar? Ich meine letztendlich ist nur eine Lösung sinnvoll, die automatisch eingefügt wird also über Cura.

 

Wiest du das einfügst ist egal. Würde es zum testen den Editor bevorzugen

Genau der Reihenfolge in der ich es gepostet habe, M25 dann Kommentar bzw. den Kommentar kannst du auch weglassen.

Ich würde es vor ";End of Gcode" einfügen

Bsp:

G10
M107

M82 ;absolute extrusion mode
M25 ;Stop reading from this point on.
;End of Gcode

 

14 hours ago, ndimensional said:

Hinten = Nach der letzten Zeile in der Datei / Im Code = zwischen den Zeilen "M107" und "M82..." hinten in der Datei

 

Verstehe ich nicht, kannst du mal ein funktionierendes Ende posten + eines wo ein Blob verursacht

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

OK, "M25" getestet:

Wenn man es mit Editor wie von Dir vorgeschlagen einfügt funktioniert es - also der "Blob" verschwindet. Leider funktioniert es aber nicht, wenn man es über Cura automatisch einfügt, da es dann vor dem "M82" eingefügt wird und so logischerweise den Rest überspringen lässt. Aber wenn man sowohl "M82" als auch "M25" über Cura einfügen lässt, geht es - also der "Blob" verschwindet.

Die Datei sieht dann am Ende so aus:

..........................

M107
M82 ;absolute extrusion mode
M25 ; Stop reading from this point on
M82 ;absolute extrusion mode
;End of Gcode

............................

 

Zun zweiten Teil deiner Frage:

Mit "Blob":

-----------------------------------------------

M107
M82 ;absolute extrusion mode
;End of Gcode

-----------------------------------------------

Ohne "Blob", Kommentar durch Cura eingefügt:

-----------------------------------------------

M107
;Kommentar um Blob zu vermeiden
;Kommentar um Blob zu vermeiden
;Kommentar um Blob zu vermeiden
;Kommentar um Blob zu vermeiden
M82 ;absolute extrusion mode
;End of Gcode

-------------------------------------------------

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf
On 2/21/2018 at 8:05 AM, DidierKlein said:

Thanks @harbaum for pointing out that this topic also exists in German :) we are having a user in the french community with the same issue. No real solution so far.

 

All we know is that it was sliced in UltiGCode with Cura 3.2 on a MAC.

 

Any idea from here (sorry i don't speak german)?

 

@DidierKlein

 

https://community.ultimaker.com/topic/21686-nozzle-parking-and-oozing-at-end-of-print/?do=findComment&comment=201633

 

https://github.com/Ultimaker/UM2.1-Firmware/issues/2

 

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Work around:

You need either manually add "M25" before the M82 at the end of gcode file:

...............................

M107

M25 ; Stop reading from this point on
M82 ;absolute extrusion mode
;End of Gcode

...............................

or configure Cura (Preferences - Configure Cura - Printers - Machine Settings - End Gcode) to add two lines - copy the two lines into cura as they are:

M82 ;absolute extrusion mode
M25 ; Stop reading from this point on

 

At least this worked on my UM2(+)

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Hallo,

 

@tinkergnome kannst du für neugierige Leute erklären was da genau falsch programmiert wurde das da ein paar Kommentare bzw. das M25 Einfluss haben.

 

In Forum gibt es ja jetzt mehrere mit den gleichen Problem, und die posteten den gcode mit, und da funktionieren welche und welche wo ich keinen unterschied sehe funktionieren nicht??

Und warum tritt der Fehler erst jetzt mit Cura 3.2 auf, wenn der Firmware Fehler schon seit v2.6 vorhanden ist?

 

Gruß

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Asche auf mein Haupt - war wohl etwas zu voreilig. Möglicherweise ist auch die Dateigröße mitentscheidend.

Die Tests hatte ich mit einem Würfel von 5x5x2 mm gemacht. Frohgemut nun ein größeres Stück gedruckt (200x150x50mm) , welches ich schon öfters benötigt habe.... und siehe da, mit "M25" doch wieder ein "Batzen". Dann statt M25 wieder 4 Kommentarzeilen verwendet - Druck war ok, gleiches Teil gedruckt... also alles über Cura automatisch eingefügt, manuell werde ich nicht checken.

Werde jetzt erstmal bei den Kommentarzeilen bleiben, in derHoffnung das es das Problem vorerst löst.

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Hallo @ndimensional,

 

Wenn´st du 100% sicher sein willst würde ich die Firmware auf v2.5 downgraden.

Für mich macht das überhaupt kein sin weshalb Kommentare, Dateigröße oder sonst was, auf den Druckende auswirkt

 

Gruß

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf
On 2/25/2018 at 2:31 AM, zerspaner_gerd said:

@tinkergnome kannst du für neugierige Leute erklären was da genau falsch programmiert wurde

 

  • Für UltiGCode wird die E-Koordinate als Volumen (in mm³)  generiert, die Firmware rechnet das je nach konfiguriertem Materialdurchmesser um.
  • Für die "quickstop"-Funktion (M401) wurde kürzlich hinzugefügt, das die aktuelle Position nach dem Quickstop neu berechnet wird
  • Leider wurde dabei der Umrechnungsfaktor für die E-Achse vergessen
  • M401 wird nach Druckende (nur bei UltiGCode) von der Firmware automatisch aufgerufen
  • danach erfolgt die "end-of-print" Retraction
  • je nachdem, was die aktuelle E-Position am Druckende war, hat das den "Blob-Effekt" (wenn E sowieso grad auf Null steht, merkt man es hingegen überhaupt nicht)
  • M25 schließt die Datei vorzeitig, dann ist der Ablauf am Ende etwas anders, das kann evtl. "zufällig" den Fehler verstecken

 

Evtl. kommt noch hinzu, das in früheren Cura-Versionen die E-Koordinate am Ende auf Null steht, und mit Cura 3.2 nicht mehr..., aber das habe ich nicht kontrolliert.

 

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker setzt am Ende einen Batzen Filament drauf

Danke dir,

 

von gcode her ist kein unterschied zu sehen, bis auf den Kommentare am ende von gcode.

Dies vermute ich das es ein Bug von 3.2 ist das diese Settings am gcode ende fehlen.

 

Hier wurde allerdings geschrieben das es seit Cura2.6 keine Änderungen an der Firmware gab, also warum der Fehler erst jetzt?

Ein paar post weiter oben (von link) sind z.B. zwei gcode einer von Cura 3.2 (geht nicht) und einer von Cura 3.1 (geht) unterschied von gcode nur die Kommentare. kann natürlich auch Zufall zwecks Position der E-Achse sein

 

Bleibt weiterhin für mich mysteriös

 

Gruß

Edited by zerspaner_gerd

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Zur Info, die Fehler wurden gefunden:

 

In kurz form,

  1. Cura 3.2 hatte nur den Fehler das die benutzerdefinierten Einstellungen im G-Code nicht ausgegeben wurden
  2. zwei Fehler in der Drucker Firmware, einer davon irgendwas mit den Pufferspeicher
  3. Dies führte dazu das der alte noch nicht behobener Fehler in der Firmware, wo tinkergnome geschrieben hatte, in Erscheinung getreten ist und diesen Patzen verursacht hat

Gruß

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Ich finde es erstaunlich dass @tinkergnome der Autor der berühmten alternativen UM2(+) Firmware dies mit keinem Wort erwähnt :)

Ich bin schon vor Ewigkeiten auf die Tinkergnome-Firmware umgestiegen und bereue es überhaupt nicht. Drucke seit ein paar Wochen wieder über OctoPrint und bin sehr zufrieden damit.

Ich will allerdings die Standard-Firmware nicht schlecht machen - Bugs können immer wieder vorkommen. Es ist nur schade dass die Behebung des Bugs so lange dauert.

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Weiß jemand, ob in der Version 3.3.1 das Macproblem mit der Überextrusion am Ende jetzt endlich behoben ist?

In den Release Notes kann ich nichts finden.

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

War kein Mac Problem, Ursachen siehe 2 post weiter oben

25% Cura

75% Firmware

 

Aber ja Problem sind behoben also auch ein Firmware Update durchführen

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Hallo

ich habe genau dass gleiche problem wie hier beschrieben, allerdings erst seitdem ich auf die Tinker V17.10.1 Firmware umgestiegen bin.

Nun meine Frage diesbezüglich.

Hat sich seitdem etwas getan? oder gibt es einen Funktionierenden Workaround?

Ich habe die hier geschriebenen Funktionen getestet aber ich hatte IMMER einen Blob auf meinen teil

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf
20 hours ago, Chriss0023 said:

ich habe genau dass gleiche problem wie hier beschrieben, allerdings erst seitdem ich auf die Tinker V17.10.1 Firmware umgestiegen bin.

 

Wenn ich mich richtig erinnere war die Tinker Firmware von diesen Bug nicht betroffen!

 

Also muss es bei dir eine andere Ursache haben, hast du sonst noch was geändert?

Hast du nach den Firmware wechsel ein Factory Reset gemacht?

Kannst du den gcode teilen?

Druckst du mit gcode Flavor UltiGCode oder Marlin?

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Ich bin auf die Thinker umgestiegen weil ich mein Feeder gewechselt habe und habe alles eingestellt da sich die steps/mm geändert haben

Ja ich habe ein Firmware reset gemacht nachdem ich gewechselt habe, habe überall gelesen dass man dies machen sollte.

ich habe gerade nochmal ein gemacht, mal testen.

Gedruckt wird mit UltiGcode und der Cura version 3.5.

 

 

 

UM2E_ctrlV_3D_test.gcode

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

Einzige Idee noch schau mal am Drucker bei den Retract Einstellungen ob da auch bei end of Print Retract 20mm steht.

Sonst würde ich mal ältere Firmware Versionen versuchen.

Share this post


Link to post
Share on other sites
Posted · Ultimaker setzt am Ende einen Batzen Filament drauf

da habe ich nachgeschaut und da steht

retract 5mm

speed 10mm/s

 

end retract 20mm

 

mit den end retract habe ich bereits schon etwas herumgespielt, aber keine verbesserung festgestellt

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!