Jump to content
Ultimaker Community of 3D Printing Experts
Blizz

UM2+: Huge blob + grinding at end of print

Recommended Posts

Think there might be something wrong mechanically with your printer then... I'm using 3.2 as well and apart from the blob things print as nicely as ever. 

 

On topic: Just went back tot the firmware included with 3.1 and now testing a new print, hopefully the blob is no more.

Share this post


Link to post
Share on other sites

Hey Pieter. I also was left a little dumbfounded when the blob and the grinding appeared... however going back to Cura 3.1 everything solved itself and I am a happy camper again. I did upgrade the filament feeder to sanjui as my machine is a very high time used one with more than 9200 hours printing time on it. Try to go back and the problem will sort itself. Maybe there is some filament dust in the feeder. Mine also had the problem that the primary plastic gear (the one on the stepper motor was worn on the inside slipping somewhat) I just recently got myself the solex 3d head with the stainless steel race nozzles and that boosted precision and speed like crazy. Dunno if that comment helps you... Don't despair, I guess we still have the greatest machine on the market!

Share this post


Link to post
Share on other sites

This is known bug in 3.2.1.  3 bugs combined to create this issue.  There are many work arounds - one of which is to add 256 or more characters in comments at the bottom of the file.  one is to downgrade.  more details here just a few posts above your post.  Cura 3.1 should be fine.

Share this post


Link to post
Share on other sites

In the meanwhile we've also actually fixed this bug in the firmware. You can get a new hex file here: https://github.com/Ultimaker/cura-binary-data/tree/master/cura/resources/firmware

 

Or you could use the previous workaround: Put at least 512 bytes of comments in the end g-code of your printer.

 

Both should be in the Cura 3.3 release (the workaround is still in there for people who didn't update their firmware).

Share this post


Link to post
Share on other sites
On 3/19/2018 at 1:25 PM, ghostkeeper said:

In the meanwhile we've also actually fixed this bug in the firmware. You can get a new hex file here: https://github.com/Ultimaker/cura-binary-data/tree/master/cura/resources/firmware

 

 

Stupid question: how doI get the new firmware into the machine? Couldn't find a "howto" *|
 

Edited by Tafelspitz
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Tafelspitz said:

 

Stupid question: how doI get the new firmware into the machine? Couldn't find a "howto" *|
 

That's not a stupid question! ;)

 

You download one of these .hex files to your computer. Then you open up Cura and connect your computer to your printer with a USB cable. Then in Cura you click on your printer's name in the top-right, go to "Manage Printers...". Then click on "Upgrade Firmware" and select "Upload custom firmware". Then you should be able to select the .hex file you downloaded and it'll upload that firmware.

 

I don't know if it's documented somewhere on this website. If not, there should be some how-to somewhere I guess (though uploading custom firmware is fairly advanced).

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, createthis said:

I recently upgraded to the latest firmware on my UM2+ in order to gain the ability to print TPU for quadcopters. It prints great (love this!), but I immediately noticed a big blob on my prints. Switching back to PLA, there's that blob again. Is there a workaround short of waiting for Cura 3.3?

Two workarounds, depending on how technical you are. Choose one:

  1. Download this file: https://raw.githubusercontent.com/Ultimaker/cura-binary-data/master/cura/resources/firmware/MarlinUltimaker2plus.hex And then upload it via Cura by going to the machine manager, click Upgrade Firmware then Upload Custom Firmware and select that hex file (also connect via USB first).
  2. Or go to the machine manager, click Machine Settings, and then paste the following text in the "end g-code" field:
Quote

 

;Version _2.6 of the firmware can abort the print too early if the file ends

;too soon. However if the file hasn't ended yet because there are comments at

;the end of the file, it won't abort yet. Therefore we have to put at least 512

;bytes at the end of the g-code so that the file is not yet finished by the

;time that the motion planner gets flushed. With firmware version _3.3 this

;should be fixed, so this comment wouldn't be necessary any more. Now we have

;to pad this text to make precisely 512 bytes.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, ghostkeeper said:

Two workarounds, depending on how technical you are. Choose one:

  1. Download this file: https://raw.githubusercontent.com/Ultimaker/cura-binary-data/master/cura/resources/firmware/MarlinUltimaker2plus.hex And then upload it via Cura by going to the machine manager, click Upgrade Firmware then Upload Custom Firmware and select that hex file (also connect via USB first).
  2. Or go to the machine manager, click Machine Settings, and then paste the following text in the "end g-code" field:

 

 

I installed 3.3-beta last night and that seems to have resolved the problem.

 

Share this post


Link to post
Share on other sites

I would add the 512 character comment at the bottom of a gcode file to see if that helps.  There is a sample one 3 posts above this post.  Are you using cura?  S3D?  Other?  How many characters of comments are at the bottom of the generated gcode file?

Share this post


Link to post
Share on other sites

MIt is already in the program.  This is how the end of the program posts:

 

;Version _2.6 of the firmware can abort the print too early if the file ends

;too soon. However if the file hasn't ended yet because there are comments at

;the end of the file, it won't abort yet. Therefore we have to put at least 512

;bytes at the end of the g-code so that the file is not yet finished by the

;time that the motion planner gets flushed. With firmware version _3.3 this

;should be fixed, so this comment wouldn't be necessary any more. Now we have

;to pad this text to make precisely 512 bytes.

;Comment to stop blob and grinding

 

;Comment to stop blob and grinding

 

;Comment to stop blob and grinding

 

;Comment to stop blob and grinding

M25; Stop reading from this point

 

I have tried every combination.  With and without the M25, also with and without the Comment.

 

Tony

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 122 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!