Jump to content
Ultimaker Community of 3D Printing Experts

Cura 3.2.1 Crashes, Qt5Qml.dll?

Recommended Posts

Hi all,


This is my first time posting to the Ultimaker forums and hopefully I am in the correct place. 

I have been using Cura as my primary slicer since I started 3D printing back in 2013, the last Cura build I used was the legacy version 15.04.6 and a little bit of 2.1.3 which had always worked well and I never made the move over to the newest versions of Cura. 

Cura 2.1.3 use to work well but sometime last year it became unstable and I continued to use 15.04.6 without issues.

I decided to give the latest 3.2.1 build a go to see it no longer crashed with no luck. I am trying to figure out why the 2.x.x and 3.x.x versions of Cura always crash. (ive tried them all) I am assuming there was a windows update or a driver update that is creating all of these issues. 15.04.6 still works and never had any issues however it has been uninstalled while I try and solve the 3.2.1 crash issue.
The crashes are very inconsistent in nature but ALWAYS happen, I have yet to have a session of Cura end without issue. I believe the problem is from a faulty .dll file but I have not been able to resolve the issue. Any help would be really appreciated. I attached the cura.log file and below is what the Event View shows.


Event Viewer:

Fault bucket 2186857364538711821, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0
Problem signature:
P1: Cura.exe
P3: 5a562cae
P4: Qt5Qml.dll
P6: 587fe2fc
P7: c0000005
P8: 0000000000172470

Faulting application name: Cura.exe, version:, time stamp: 0x5a562cae
Faulting module name: Qt5Qml.dll, version:, time stamp: 0x587fe2fc
Exception code: 0xc0000005
Fault offset: 0x0000000000172470
Faulting process id: 0x3e90
Faulting application start time: 0x01d3ac31e5bd3458
Faulting application path: C:\Program Files\Ultimaker Cura 3.2\Cura.exe
Faulting module path: C:\Program Files\Ultimaker Cura 3.2\Qt5Qml.dll
Report Id: 75e40b38-f4a7-4bf6-b8cc-f982144f9394
Faulting package full name:
Faulting package-relative application ID:


Any thoughts? 




Share this post

Link to post
Share on other sites
7 hours ago, thopiekar said:

Please tell us more about your system. Windows version, graphics card incl. driver, etc...

Below is the system information



OS Name Microsoft Windows 10 Pro
Version 10.0.16299 Build 16299
Other OS Description  Not Available
OS Manufacturer Microsoft Corporation
System Name IA-PC
System Manufacturer ASUS
System Model All Series
System Type x64-based PC
System SKU All
Processor Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz, 3301 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1801, 5/15/2015
SMBIOS Version 2.8
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.16299.248"
User Name IA-PC\Justin
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.9 GB
Available Physical Memory 24.2 GB
Total Virtual Memory 36.7 GB
Available Virtual Memory 27.6 GB
Page File Space 4.75 GB
Page File C:\pagefile.sys
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes
Name NVIDIA GeForce GTX 980 Ti
PNP Device ID PCI\VEN_10DE&DEV_17C8&SUBSYS_49923842&REV_A1\4&31024D2F&0&0018
Adapter Type GeForce GTX 980 Ti, NVIDIA compatible
Adapter Description NVIDIA GeForce GTX 980 Ti
Adapter RAM (1,048,576) bytes
Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7a39871618b19f06\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7a39871618b19f06\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7a39871618b19f06\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7a39871618b19f06\nvldumdx.dll
Driver Version
INF File oem110.inf (Section096 section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 3840 x 2160 x 59 hertz
Bits/Pixel 32
Memory Address 0xFA000000-0xFB0FFFFF
Memory Address 0xC0000000-0xFBFFBFFF
Memory Address 0xD0000000-0xD1FFFFFF
I/O Port 0x0000E000-0x0000EFFF
IRQ Channel IRQ 40
I/O Port 0x000003B0-0x000003DF
I/O Port 0x000003C0-0x000003DF
Memory Address 0xA0000-0xBFFFF
Driver c:\windows\system32\driverstore\filerepository\nv_dispi.inf_amd64_7a39871618b19f06\nvlddmkm.sys (, 16.68 MB (17,493,824 bytes), 2/22/2018 10:49 PM)


Share this post

Link to post
Share on other sites



I have since formatted my computer with a fresh install of Win10. the first program I installed was Cura 3.2.1,, the same problem still exists and Event Viewer still shows the Qt5Qml.dll. I am not sure what to do next. I thought for sure a fresh install was going to fix my issues. I have run as Admin and Compatibility Mode nothing has helped. Same issues is still present, is there anything else I can do that would help diagnose the issue? All drivers are up to date and I have even rolled back my graphics driver to the earliest one NVidia had, no luck.

Share this post

Link to post
Share on other sites

I have a feeling it is related to a graphics card issue. If and when Cura doesn't immediately crash, its easy to get it to hang up by scrolling through the Setting page fast, it cant load the settings quick enough and will crash every time.

I have a:

NVIDIA GeForce GTX 980 Ti

Driver: 391.01 


I have rolled back the a driver from April of 2017

Driver: 381.89

No luck, it still showed the same issues. 

Share this post

Link to post
Share on other sites



and you can confirm the file exists:

On 2/23/2018 at 12:37 AM, crazy1pilot said:

C:\Program Files\Ultimaker Cura 3.2\Qt5Qml.dll



I can try to take some time today and explain to you how to use a "dependency walker". As many other Windows libraries (*.dll-files) also this module probably depends on a file, which is not installed on your computer. (For a reason I don't know.)

The dependency walker will recursively check what is missing.



Share this post

Link to post
Share on other sites

The file is in its correct spot.
if you are able to describe the steps to use a dependency walker to diagnose the issue farther I would give it a shot. 


I thought formatting my computer with a fresh install of Win10 Pro would fix the issue but it is still the same as before.


thank you for the help. 

Share this post

Link to post
Share on other sites



I downloaded Dependancy Walker and ran Cura. This is what came back, I am not sure if you have a specific command you would like me to run but I just ran a generic script.

C:\>A:\Downloads\Depends22_x64\depends.exe /c /f:1 /pb /pp:1 /pg:1 /ot:Log.txt "C:\Program Files\Ultimaker Cura 3.2\Cura.exe"


It returned this information below, also there is a link to the full .txt file.

GetProcAddress(0x00007FF9E3EB0000 [MKL_AVX2.DLL], "mkl_lapack_ps_avx2_dgetrs_small") called from "MKL_CORE.DLL" at address 0x00007FF9E6309BF8 and returned 0x00007FF9E4582E30.
GetProcAddress(0x00007FF9EBF80000 [OPENGL32.DLL], "glTexImage1D") called from "QWINDOWS.DLL" at address 0x00007FF9EC0D6DB8 and returned 0x00007FF9EC0570B0.
GetProcAddress(0x00007FFA31860000 [KERNEL32.DLL], "GetSystemTimes") called from "NVOGLV64.DLL" at address 0x000000006BDC4C08 and returned 0x00007FFA318819F0.
qml: TableViewSelection: index out of range
qml: TableViewSelection: index out of range
Second chance exception 0xC0000005 (Access Violation) occurred in "QT5QML.DLL" at address 0x000000006DBB2470.
Exited "CURA.EXE" (process 0x4BAC) with code -1073741819 (0xC0000005).

Full Log File


Edited by crazy1pilot
Fixed typos

Share this post

Link to post
Share on other sites

These crashes are NOT due to missing ddls - they are caused by an inconsistent compliment of dlls.


When an application does not specify its dll dependencies, the dll loader checks whether calls issued by it can be satisfied by an already memory resident dll (to save memory by not having to load a new copy of a dll). If the already loaded dll is not the same version as that used during linking this application the result is unpredictable. This was a major problem with the early versions of windows.


So when an application hasn't specified its dll dependencies it is pot luck whether it will crash or not on another computer and hence cannot be considered as truly portable.


Even if it does run, it should not be assumed that it will produce the same results as running on the computer where it was linked.


This is true for applications on many OS's and consequently a method has been devised to solve this problem - it is called a manifest. When linking an application, generation of a manifest may be selected.


On Windows the manifest may exist as a separate file in the same directory as the executable (app_name.exe.manifest) or may be incorporated into the executable.


The ddl loader then uses the info in the manifest to ensure that exactly the same version of a dll is loaded or an error is issued. The application is then running the exact same code as on the original host. For example in Windows, earlier versions of ddls are under the \Windows\winsxs directory to provide backward compatibility.


The manifest is missing for the Cura application, so which dlls are loaded on a particular PC depend on the current OS version, what applications are running using a manifest (resulting in a memory resident dll with the specific version for that app), order of running etc etc ...  ie unpredictable!!!!.


Some combinations run (how correctly cannot be specified), others crash.

Share this post

Link to post
Share on other sites

I have a laptop on which I can select whether an application uses the Processor HD4400 graphics or a NVidia GT750M. With the HD4400 Cura crashes with the same error as you have posted. Using the GT750M Cura crashes while trying to parse the printer definition file prior to initialising the graphics.


In my opinion there is nothing that you can do to resolve the issue.


Cura requires a manifest so that the OS can ensure the relevant environment for it to run. That can only be provided by the developer.

Share this post

Link to post
Share on other sites
21 hours ago, Control Eng said:

Cura requires a manifest so that the OS can ensure the relevant environment for it to run. That can only be provided by the developer.

Would you be able to create a post on GitHub reporting the issue? You would be able to explain the issue much better then I would. If not, I can give it a shot. I haven't been able to find any other post on this issue, but maybe I'm looking in the wrong spot.

Share this post

Link to post
Share on other sites

Sorry for not replying earlier, I got so frustrated with Cura that I had a play with IceSL! Returned to Cura today and managed to find what my problems were.


  1. When Cura crashes it leaves corrupted (incomplete) files in its' cache directory. On the next run Cura crashes while trying to parse these incomplete files due to 'uncaught exception' deficiencies in the Cura exe. The files are in your user_name/AppData/Roaming/Cura/3.2 - delete the directory with all contents to fix (need to select show hidden files).
  2. depends shows far more information if 'Log DllMain calls for all other messages, including thread attach and detach' is selected. You see that there are over 50 threads created and how the application attaches to resident dlls and loads other dlls as the process are created. You are able to see which thread is causing the crash and that some repeated messages are from different threads.
  3. Crashes in NTDLL are due to 'Invalid address specified to RtlFreeHeap'. These appear to be due to a  32 dll being loaded and the OS trying to generate a 'thunk' - a piece of dynamic glue code on the system heap. For some reason this seems to fail.
  4. In my case the problem occurred when a system facility which tries to cache display icons was invoked from MSI.DLL. This code is Dell specific and part of 'Dell backup and recovery'. My failure was on Windows 8.1 - the same code did not fail on Windows 10.


I have temporarily removed 'Dell backup and recovery' from my laptop and Cura no longer crashes, although there are still 'First chance exception's occurring labelled as Microsoft C++ Exception. These also occur when running on Windows 10.


Originally I thought that my crashes were caused by "TableViewSelection: index out of range" as appears in your 'depends' log, however I now see that when no crash occurs there is one instance of a pair of these messages. In your case there are two instances.


Maybe you will be able to identify were you problem lies by running depends with /pn:1 added, this will display thread ids that will probably give you more clues.




Edited by Control Eng
Accidentally submitted incomplete

Share this post

Link to post
Share on other sites

Here is what was generated. 



DllMain(0x00007FF8E03E0000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "COREUICOMPONENTS.DLL" called by thread 1.
DllMain(0x00007FF8E03E0000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "COREUICOMPONENTS.DLL" returned 1 (0x1) by thread 1.
DllMain(0x00007FF8D6E30000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "TEXTINPUTFRAMEWORK.DLL" called by thread 1.
DllMain(0x00007FF8D6E30000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "TEXTINPUTFRAMEWORK.DLL" returned 1 (0x1) by thread 1.
qml: TableViewSelection: index out of range
qml: TableViewSelection: index out of range
qml: Failed to load Style for CheckBox_QMLTYPE_136(0x22a34ce5b70)
qml: Failed to load Style for CheckBox_QMLTYPE_136(0x22a346b0d10)
Thread 12 exited with code 0 (0x0).
qml: Failed to load Style for CheckBox_QMLTYPE_136(0x22a46a44af0)
Second chance exception 0xC0000005 (Access Violation) occurred in "QT5QML.DLL" at address 0x0000000066A02470 by thread 1.
Thread 9 exited with code -1073741819 (0xC0000005).
Thread 7 exited with code -1073741819 (0xC0000005).
Thread 8 exited with code -1073741819 (0xC0000005).
Thread 10 exited with code -1073741819 (0xC0000005).
Thread 2 exited with code -1073741819 (0xC0000005).
Thread 11 exited with code -1073741819 (0xC0000005).
Thread 14 exited with code -1073741819 (0xC0000005).
Thread 16 exited with code -1073741819 (0xC0000005).
Thread 15 exited with code -1073741819 (0xC0000005).
Thread 17 exited with code -1073741819 (0xC0000005).
Thread 19 exited with code -1073741819 (0xC0000005).
Thread 18 exited with code -1073741819 (0xC0000005).
Thread 1 exited with code -1073741819 (0xC0000005).
Thread 20 exited with code -1073741819 (0xC0000005).
Thread 22 exited with code -1073741819 (0xC0000005).
Thread 21 exited with code -1073741819 (0xC0000005).
Thread 23 exited with code -1073741819 (0xC0000005).
Thread 24 exited with code -1073741819 (0xC0000005).
Thread 25 exited with code -1073741819 (0xC0000005).
Thread 27 exited with code -1073741819 (0xC0000005).
Thread 28 exited with code -1073741819 (0xC0000005).
Thread 29 exited with code -1073741819 (0xC0000005).
Thread 31 exited with code -1073741819 (0xC0000005).
Thread 30 exited with code -1073741819 (0xC0000005).
Thread 32 exited with code -1073741819 (0xC0000005).
Thread 33 exited with code -1073741819 (0xC0000005).
Thread 35 exited with code -1073741819 (0xC0000005).
Thread 36 exited with code -1073741819 (0xC0000005).
Thread 37 exited with code -1073741819 (0xC0000005).
Thread 38 exited with code -1073741819 (0xC0000005).
Thread 26 exited with code -1073741819 (0xC0000005).
Thread 39 exited with code -1073741819 (0xC0000005).
Thread 40 exited with code -1073741819 (0xC0000005).
Exited "CURA.EXE" (process 0x3554) with code -1073741819 (0xC0000005) by thread 34.



Also below is the link where the full log is located.


Full Log2 File

Share this post

Link to post
Share on other sites

I cannot see any dll errors in your log (other than the ones that exist in running Cura logs).


In my opinion your crash looks similar to mine when some of the Cura files were corrupted.


I downloaded the latest version of Cura yesterday and noticed that the error reporting has been significantly enhanced. It also now has an option to reset the configuration files when a crash occurs.


Having said that, the first time I ran the newly installed Cura it immediately crashed!


I would recommend that you download the latest version of Cura 3.2.1.


Before installing, uninstall the current Cura 3.2.n and delete the directories User_name/appdata/local/Cura/3.2 and User_name/appdata/roaming/Cura/3.2.


Don't allow Cura to run when finishing installation (untick option). Run depends on Cura to see if the log gives any different clues.


Share this post

Link to post
Share on other sites

I currently have 3.2.1 installed, I tried pretty much every version of Cura 3.x.x and Cura 2.x.x with similar issues. However, the legacy version of Cura 15.04.3 never had any issues. 15.04.3 doesn't have a lot of the features I would like to use like 3.2.1 does. 

I even went as far as formatting my system completely and the first program I installed was Cura 3.2.1, on its first boot up it still crashed..... 

I can try uninstalling 3.2.1 and clearing the directories and reinstalling again. I will report back.

I would love to use Cura as my primary slicer, but its not looking promising.


Thanks again for the direction and help trying to figure this issue out. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!