Jump to content
Ultimaker Community of 3D Printing Experts
mechamecha

Cura 3.2: Strange gaps in inner walls

Recommended Posts

I've been really happy with the development of Cura lately. It seems to give the user nearly complete control over every aspect of the printing process. I've especially been excited about the new adaptive layers feature, which the 3D printing community has been wanting for quite a while now. Even though I have a Simplify3D license, I've found myself using Cura most of the time for these reasons.

 

However, over the past week or so, I've been noticing some odd slicing behaviors which have affected the quality of my prints, forcing me to go back to Simplify3D. I've attached some screen shots below: one from Cura and another from Simplify3D. The settings for each are as similar as I could make them using three perimeters/walls for the shell. As you can see, Cura generates seemingly random gaps in the innermost wall which results in noticeable rough spots on the printed surface. I tried changing a bunch of different settings, but no matter what I did, the gaps remained. Simplify3D, on the other hand, generated the walls exactly the way I expected, resulting in an impressively smooth print surface.

 

So... Any idea what's causing this problem in Cura? As I mentioned before, I'd prefer to use Cura because it offers so much control over pretty much every printing parameter but, first and foremost, I care about printed surface quality and, unfortunately, Simplify3D is giving me much better results at the moment.

 

5a98b4be37ef5_ScreenShot2018-03-01at9_12_20PM.thumb.png.3f0378a24b5f27d9968e5bab613b2a43.png5a98b4c6cd9e0_ScreenShot2018-03-01at9_16_01PM.thumb.png.dd84d9707b4fe2df64ebfe2565b399ee.png

  • Like 1

Share this post


Link to post
Share on other sites

discussion about this (or similar) here:

https://github.com/Ultimaker/Cura/issues/2665#issuecomment-349396443

 

I understand why it happens - the walls are ever so slightly thinner where there is missing filament - I mean cura *thinks* it's thinner due to floating point rounding issues.  It thinks it's probably a micrometer smaller and isn't smart enough to just let things be (decide it's close enough) and fill that gap with "wall".

 

s3d probably has a nice hack where it says "well it fits within 1% so just don't worry about that last 1% error and fill it with wall".

 

I'm not sure what the solution is.  The people in the above post had the most luck using less wall and using diagonal infill.  That will be slower and not as beautiful.  but it will give you a nice solid wall.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the files. I can slice that and get all the walls if I use a line width of 0.38 or lower but I am unsure of the print quality as it relies on the wall overlap compensation performing well which, unfortunately, it generally doesn't. If you disable the overlap compensation, it will try to print two lines where there is only space for one and if you enable the overlap compensation the width of the last wall to be printed will be higgledy-piggledy (technical term, aka pretty random).

 

The bottom line is that Cura really doesn't cope very well with walls that are an odd number of lines wide.

 

Hope this helps.

  • Thanks 1

Share this post


Link to post
Share on other sites

I noticed this problem last week when printing cylinders and wall thickness is a multiple of line width and an odd number of walls. Ex, Line Width: 0.4mm, cylinder wall thickness: 2.0mm 2/0.4 = 5. When I increased Line Width to 0.5 thus making wall line count become 4 it worked as expected (4 solid lines no gaps).

 

I also tested by changing the wall thickness to 1.6 (4 lines 0.4 line) and 2.4 (6 lines 0.4) and they all worked as expected, I tried to make it 1.2 (3 lines) and just like 2.0 (5 lines) I got alot of gaps in the center inner wall line making my print print very slowly since it has to retract->travel->extrude for every tiny gap.

Share this post


Link to post
Share on other sites

Hey!, I found a solution that worked on my part, not sure if it will work on yours. I changed the setting under Shell -> Top/Bottom Pattern to Zig Zag. This forces the pattern to be designed differently. This worked on the part that I had, which was a wider area than yours, but it was the same problem. Let me know if it works, Like I said worked for me.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!