Jump to content
Ultimaker Community of 3D Printing Experts
SteveCox3D

Cura Interaction with Autodesk Fusion 360

Recommended Posts

Would it be possible to change the Cura software in the way it interacts with Autodesk's Fusion 360 to the same way it did with 15.04?

 

What I mean specifically is that with 15.04 once I'd chosen to 3D print a part from Fusion 360 and automatically sent it to Cura it would open a new session if Cura wasn't already open.  After that if Cura was left open and further transfers were made it inserted the model into the same session.  With latest Cura each time I send a model to 3D print it opens up a brand new session even if there's one already open.  This adds time to the process because you have to wait for Cura to open up again.

 

When is this a problem?  When I'm optimising a design for 3D printing I check the layer stack in Cura, then go back into Fusion 360 and make modifications to make difficult areas easier to print, and then repeat the layer stack check.  It's not unusual for me to do three or four repeats of this to get to a final design for 3D printing, and opening a new Cura session each time makes this less efficient.

 

This is part of a Design for Additive Manufacturing (DfAM) workflow that I teach as part of my Fusion 360 training activities.  I mentioned this to @ghostkeeper at the recent Community event when we had the software discussions on the Friday afternoon.  

Share this post


Link to post
Share on other sites

When starting Cura with a system command, you can provide the option --single-instance. This will not launch a new instance of Cura if one is already open but instead re-use the old one (replacing the build plate with the newly loaded file if a file name is also provided).

 

I don't know exactly how Fusion 360 calls Cura with its "make button", but I'd expect it to be some sort of macro that calls Cura via a system command. It should add the --single-instance parameter to its call.

Share this post


Link to post
Share on other sites

Thanks @ghostkeeper  I'm a bit confused though about where the system command is. When I use Cura 15.04 as the 3DP Utility it opens a single instance, but when I use 3.2.1 it doesn't.  

 

As I write this though I have maybe realised the difference.  When I use Cura 15.04,  that's already available as  pre-installed option in the default dropdown list, whereas I have to link Cura 3.2.1 as a "Custom" 3DP Utility.  There must be a different system command being used when it's installed from the pre-installed link compared to the custom generated link.

 

My apologies - it doesn't sound like Cura is the issue here. Once I understand it better I may need to post this request to the Fusion 360 IdeaStation instead.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | People
      The goal of this contest is to design a set of people figurines that could be used in such a project to make an area, office or mall seem populated. 
      Think of different types of people in different environments, like walking people, people standing still, working people, and both men and women.
       
      • 6 replies
    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!