Jump to content
Ultimaker Community of 3D Printing Experts

View print steps option


Recommended Posts

Posted · View print steps option

Hello @espadan3d, that is because your layer view is using compatibility mode. It's doing that because either your computer's hw/sw are not suitable or you have forced it to use compatibility mode in the cura preferences. If it is the sw, maybe updating drivers is required?

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option

    That should be enough.

     

    The new layer view requires OpenGL 4 because it needs geometry shaders. Your graphical card supports OpenGL 4.5 according to this spec sheet: https://www.geforce.com/hardware/notebook-gpus/geforce-gt-740m/specifications

    So I think you just need to update your graphical drivers. Once you've done that, Cura should be able to detect that you have OpenGL 4 support and allow the fancier rendering of layer view. Also be sure to disable the "Force layer view compatibility mode" option in the preferences.

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option

    I think your laptop has both an integrated (Intel) and an dedicated (nVidia) GPU. If that is true, you should be able to configure your ("Optimus") driver to launch Cura with the dedicated GPU.

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option
    3 hours ago, ghostkeeper said:

    That should be enough.

     

    The new layer view requires OpenGL 4 because it needs geometry shaders. Your graphical card supports OpenGL 4.5 according to this spec sheet: https://www.geforce.com/hardware/notebook-gpus/geforce-gt-740m/specifications

    So I think you just need to update your graphical drivers. Once you've done that, Cura should be able to detect that you have OpenGL 4 support and allow the fancier rendering of layer view. Also be sure to disable the "Force layer view compatibility mode" option in the preferences.

    Thanks for your reply

    i checked my driver was final update.

    i couldn't find Force layer view compatibility mode .when is it?

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option
    3 hours ago, ahoeben said:

    I think your laptop has both an integrated (Intel) and an dedicated (nVidia) GPU. If that is true, you should be able to configure your ("Optimus") driver to launch Cura with the dedicated GPU.

    image.png.483ef06fcdf71ae72855182dd7298d42.png

    Thanks for your reply

    I think you are right, how able configure ("Optimus") driver to launch Cura?

     

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option
    1 hour ago, espadan3d said:

    i couldn't find Force layer view compatibility mode .when is it?

    It's under Preferences -> Configure Cura... -> Viewport Behavior -> all the way down at the bottom of the category.

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option

    You might also need to force windows to use your dedicated GPU for Cura. You can do that in the Nvidia control panel (right click desktop -> Nvidia control panel):

    image.thumb.png.da859dd58aaf21afd563cdffcb46c6b3.png

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option
    5 hours ago, IRobertI said:

    You might also need to force windows to use your dedicated GPU for Cura. You can do that in the Nvidia control panel (right click desktop -> Nvidia control panel):

    Thank you, my problem was solved

  • Share this post


    Link to post
    Share on other sites
    Posted · View print steps option
    5 hours ago, ghostkeeper said:

    It's under Preferences -> Configure Cura... -> Viewport Behavior -> all the way down at the bottom of the category.

    Thank you, my problem was solved

  • Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...