Jump to content
Ultimaker Community of 3D Printing Experts

Heat bed support for netfabb - how?


thereza
 Share

Recommended Posts

Posted · Heat bed support for netfabb - how?

I can't get netfabb to support the heatbed that I've added. I've even tried to add the M140/M190 commands to the header/footer of the gcode, but netfabb keeps adding M104 S0 commands to turn off the heatbed all over the gcode.

Is there some way to force netfabb to work with my heatbed?

thanks,

reza

 

  • Link to post
    Share on other sites

    Posted · Heat bed support for netfabb - how?

    Did you add the heat bed temperature to your Material settings? You need to put the temp for the heatbed into the profiles along with the nozzle temperature. I find Netfabb doesn't pre-heat the bed though, it puts the M140 command at the start of layer one instead of at the beginning of the code so I usually move it myself to the top before printing.

    Cheers,

    Troy.

     

  • Link to post
    Share on other sites

    • 3 months later...
    Posted · Heat bed support for netfabb - how?

    I've improved my Ultimaker with a heated bed too. After modifying the firmware, the Ulticontroller supports the heated bed. But I dont find a way to activate the heated bed in netfabb. I've set the teperatures for the bed in all material definitions. But there is displayed still only the selection "No heated bed"

    Thanks for help

    Norbert

     

  • Link to post
    Share on other sites

    Posted · Heat bed support for netfabb - how?

    I can print with the heated bed using the M140 / M190 codes putted to the GCode Header. But I belive that there should be a better solution because netfabb seems to support a heated bed in the "machine" tab form. There is a selection for "Heater bed" But the only selection is "No heated bed" I think that it should be possible to configure the heated bed in the Ultimakerconfig.xml file.

     

  • Link to post
    Share on other sites

    Posted · Heat bed support for netfabb - how?

    Again, did you try this part of codemaven's instructions?

     

    Did you add the heat bed temperature to your Material settings? You need to put the temp for the heatbed into the profiles along with the nozzle temperature.

     

    I have never used netfabb. It just seems like codemaven gave you an answer but you didn't respond to his question.

    I think maybe you *did* respond but it's not clear to me. Maybe codemaven understands.

     

  • Link to post
    Share on other sites

    Posted · Heat bed support for netfabb - how?

    Yes. I've defined the temperatures in the material settings. This will work. At start of printing, the bed temperature will change to the value defined in the material settings.

    But my goal is to configure netfabb for the heat bed option: There is a print screen of the prepared selection for the heated bed:

    http://umforum.ultimaker.com/index.php?/gallery/image/1531-netfabb/

     

  • Link to post
    Share on other sites

    Posted · Heat bed support for netfabb - how?

    Hi ePower,

    I've not changed that option in NetFabb. I leave it as "No Heated Bed". I believe that only affects the manual control options. Which, I suppose could be an issue if you don't have an ultracontroller... but I do not connect my UM to my computer anymore, I do all of my printing through the ultracontroller.

    Regards,

    Troy.

     

  • Link to post
    Share on other sites

    Posted · Heat bed support for netfabb - how?

    Hi Troy and gr5

    Thanks a lot for your responses. I own a UltiController an I've added there a menu item to "cooldown nozzle" and "cooldown bed" as separate selections :-) But I'm still looking for a solution to activate the heated bed in netfabb. I'm sure this must be just a setting in the configuration file. I've seen the heated bed option working with the fabbster engine. I've called now the support of netfabb for a solution.

    Regards - Norbert

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 10 replies
    ×
    ×
    • Create New...