Jump to content
Ultimaker Community of 3D Printing Experts

Introducing Ultimaker Cura 3.3 | Beta


Recommended Posts

Posted · Introducing Ultimaker Cura 3.3 | Beta

When we're making a stable version out of this beta version we're planning on making another explanatory video about some of the great new features and how they work. Last time we explained a lot of features but did not catch all the features people were most curious about. So I want to ask you; after having read the release notes and/or trying beta 3.3;

- which feature would you like to see explained in the next video?

 

After reading this thread, my initial input would be:

- new bridging settings

- support blocker

 

What else? :)

 

Note: A nominee is no guarantee. We can not include everything, but we'll do our best to make it as conclusive as possible. 

 

Edit: If you haven't seen the previous explanatory video; check my first post in the previous Stable introduction for reference.

  • Link to post
    Share on other sites
    • Replies 168
    • Created
    • Last Reply

    Top Posters In This Topic

    Top Posters In This Topic

    Popular Posts

    After another period of continuous research and development, we're proud to share the latest Ultimaker Cura Beta with you. We're excited to hear what you think of the new and improved features. With y

    Drawing a polyline on a mesh inside Cura to create new geometry would be quite computationally expensive (to the point of not being feasible for now).   The “christmass may come early” plugi

    Thanks for the mention @SandervG, I will put together a topic that describes the new bridging features and the associated settings.

    Posted Images

    Posted (edited) · Introducing Ultimaker Cura 3.3 | Beta

    OK, playing with 3.3- Mac OSX 10.13.4 

     

    constantly getting the "Unable to slice" feedback. But then sometimes, 20-30 seconds later it just starts slicing..? Also, Still a rather major lag in hitting the "prepare" button and anything happening, slicing or not. Last time I just counted in my head, and was like 20-25 seconds from hitting the button to getting feed back from the program. 

    Screen Shot 2018-04-04 at 5.25.49 AM.png

    cura copy.log

    Edited by Thomllama
  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    2 hours ago, Thomllama said:

    OK, playing with 3.3- Mac OSX 10.13.4 

     

    constantly getting the "Unable to slice" feedback. But then sometimes, 20-30 seconds later it just starts slicing..? Also, Still a rather major lag in hitting the "prepare" button and anything happening, slicing or not. Last time I just counted in my head, and was like 20-25 seconds from hitting the button to getting feed back from the program. 

    Screen Shot 2018-04-04 at 5.25.49 AM.png

    We need some logs :)

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Just a thought, and I'm sure it has come up somewhere already, and it's not a bug per se, but a minor annoyance.
    But wouldn't it be nice if the slicing could be held off until all of the settings in cura are made? I find it mildly annoying, especially with bigger and more complex builds when cura starts slicing after every single parameter change.

    Or, at the very least, make it optional to behave one way or the other as I'm sure some folks like it the way it is ;)

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    5 hours ago, SandervG said:

    When we're making a stable version out of this beta version we're planning on making another explanatory video about some of the great new features and how they work. Last time we explained a lot of features but did not catch all the features people were most curious about. So I want to ask you; after having read the release notes and/or trying beta 3.3;

    - which feature would you like to see explained in the next video?

     

    After reading this thread, my initial input would be:

    - new bridging settings

    - support blocker

     

    What else? :)

     

    Note: A nominee is no guarantee. We can not include everything, but we'll do our best to make it as conclusive as possible. 

     

    Edit: If you haven't seen the previous explanatory video; check my first post in the previous Stable introduction for reference.

     

    I guess it's technically a plugin and not a feature, but I would add a quick explanation and demonstration of Scaleable Extra Prime to the video.  It's an absolute godsend for PETG printing, and in my opinion it's tied with the new bridging settings as the feature that improves the quality of prints the most.  The difference it makes is really astounding.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 minute ago, Tafelspitz said:

    Just a thought, and I'm sure it has come up somewhere already, and it's not a bug per se, but a minor annoyance.
    But wouldn't it be nice if the slicing could be held off until all of the settings in cura are made? I find it mildly annoying, especially with bigger and more complex builds when cura starts slicing after every single parameter change.

    Or, at the very least, make it optional to behave one way or the other as I'm sure some folks like it the way it is ;)

     

    This is already a setting!  It's under Preferences -> Cura Settings, then uncheck the 'Auto Slice' box.

    • Like 3
    Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 minute ago, AirBronto said:

     

    This is already a setting!  It's under Preferences -> Cura Settings, then uncheck the 'Auto Slice' box.

    :+1:

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 hour ago, AirBronto said:

     

    I guess it's technically a plugin and not a feature, but I would add a quick explanation and demonstration of Scaleable Extra Prime to the video.  It's an absolute godsend for PETG printing, and in my opinion it's tied with the new bridging settings as the feature that improves the quality of prints the most.  The difference it makes is really astounding.

     

    Thanks, we'll keep it in mind!

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    I'm still noticing very diminished speed when connected to the network vs network disabled.  Brand new computer with no previous Cura installs and plenty of hardware to handle slicing.

    cura.log

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    8 hours ago, ahoeben said:

    several-different-sized-logs-on-a-white-

    LOL, that funny as hell!  It was early morning and I was rushing out to work,.. ya,.. that's my excuse .. ya,.. sticking to it ;) 

     

     

    cura copy.log

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    15 hours ago, AirBronto said:

     

    This is already a setting!  It's under Preferences -> Cura Settings, then uncheck the 'Auto Slice' box.

    Just when you thought you had all of the preferences checked out. Thank you so much!

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Is there a way to disable the camera monitor? I have checked preferences and such but cannot seem to find anything.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    10 hours ago, msurunner said:

    Is there a way to disable the camera monitor? I have checked preferences and such but cannot seem to find anything.

     

    Yes!  It's under the OctoPrint settings dialog.

     

    Settings -> Printers -> Manage Printers -> [SELECT YOUR PRINTER] -> Connect to OctoPrint -> Uncheck "Show Webcam Image"

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    On 04/04/2018 at 11:22 PM, Thomllama said:

    LOL, that funny as hell!  It was early morning and I was rushing out to work,.. ya,.. that's my excuse .. ya,.. sticking to it ;) 

     

     

    cura copy.log

    It seems to be spending a lot of time performing the error check (9 - 15 seconds!). That's probably why it's taking so freakishly long for the slicing to start. By the looks of it it has everything to do with your custom machine setup.

    Is it also happening if you add a new custom machine?

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    4 hours ago, nallath said:

    It seems to be spending a lot of time performing the error check (9 - 15 seconds!). That's probably why it's taking so freakishly long for the slicing to start. By the looks of it it has everything to do with your custom machine setup.

    Is it also happening if you add a new custom machine?

    yup, added a new machine with the beta

     

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    well I tried this again but instead of adding my UM3 I added UM2+ and it worked so I then tried to add UM3 and the software died, crashed, closed down ...... don't know why this is.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    The 3.3.0-BETA AppImage chrashes on start :-(

    System information:

    Auswahl_003.png.27cbb63734350b75b1bca12e0d0ae47c.png

     

    Error traceback:

    Traceback (most recent call last):
      File "<frozen importlib._bootstrap>", line 969, in _find_and_load
      File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
      File "<frozen importlib._bootstrap>", line 634, in _load_backward_compatible
      File "/build/env/3.3/inst/lib/python3.5/site-packages/cx_Freeze/initscripts/__startup__.py", line 12, in <module>
      File "<frozen importlib._bootstrap>", line 969, in _find_and_load
      File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
      File "<frozen importlib._bootstrap>", line 634, in _load_backward_compatible
      File "/build/env/3.3/inst/lib/python3.5/site-packages/cx_Freeze/initscripts/Console.py", line 21, in <module>
      File "<frozen importlib._bootstrap>", line 969, in _find_and_load
      File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
      File "<frozen importlib._bootstrap>", line 634, in _load_backward_compatible
      File "/build/3.3/build/inst/bin/cura", line 141, in <module>
      File "/build/3.3/build/inst/lib/python3.5/site-packages/cura/CuraApplication.py", line 649, in run
      File "/build/3.3/build/inst/lib/python3.5/site-packages/cura/Machines/VariantManager.py", line 76, in initialize
    KeyError: 'hardware_type'
    

    Any hints, where to look for this "KeyError: hardware_type" ?!?

     

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    HAve you installed any custom variants in your configuration folder? If so, these must be updated.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Yes I have two variants for my printers for different nozzles, what exactly must be updated?

    [general]
    name = 0.4
    version = 2
    definition = K8200

    [metadata]
    author = BerndJM
    type = variant
    setting_version = 2

    [values]
    machine_nozzle_size = 0.4

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Under metadata, add

    hardware_type = nozzle

    Also version must be 3 and setting_version must be 4 in Cura 3.3

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Thanks so far, this helps a little bit. But it seems I have to configure some things from scratch :-(

     

    RuntimeError: QualityChangesGroup[<4 - Adaptive & Support>, available = False] tries to overwrite the existing node_for_global QualityNode[fdmextruder_4 - adaptive & support] with QualityNode[k8200_4 - adaptive & support]

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Hi,

    I just installed cura 3.3, because of the support block feature. 
    But after the changelog screen it's crash immediately.
    Do you guys have some tips for me maybe? :) 
    Thank you,

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...