Jump to content
Duncan_B

Printer and material profiles lost 3.2.1

Recommended Posts

Posted · Printer and material profiles lost 3.2.1
13 hours ago, Msuurmond said:

We can only help you further if you can give us the complete config folder. With that we can extract it on our development machines and create the exact same situation as you have. If anything goes wrong we can than see it and fix it.

How do I do that when zip files are not allowed to be posted.  I would gladly send you anything you want but don't know how

Dr. Dave

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
10 hours ago, Drdave said:

How do I do that when zip files are not allowed to be posted.  I would gladly send you anything you want but don't know how

Dr. Dave

A few options:

- You could use https://wetransfer.com/ to upload the zip to and share the link here so we can download it.

- Rename the zip-file so it doesn't end on .zip but on .3mf for example

 

 

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
9 hours ago, Msuurmond said:

A few options:

- You could use https://wetransfer.com/ to upload the zip to and share the link here so we can download it.

- Rename the zip-file so it doesn't end on .zip but on .3mf for example

 

 

Sheesh that was freaking BRILLIANT

I should have thought of that

Here is the 3mf that is REALLY a ZIP file after you change it back

Thank you SO much

Dr D

3.3.3mf

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
On 4/28/2018 at 6:19 PM, Drdave said:

Sheesh that was freaking BRILLIANT

I should have thought of that

Here is the 3mf that is REALLY a ZIP file after you change it back

Thank you SO much

Dr D

3.3.3mf

Ok I got the files, but I only see a 'cache' folder in the zip-file. We need the whole 3.2 folder e.g.:

 

Screen Shot 2018-04-30 at 09.55.39.png

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
On 4/26/2018 at 6:27 PM, pgrunwald said:

I'll try it tonight when I get home from work.

 

I'm still at 3.2.1,  Do you want me to just try a normal upgrade?

 

 

Hey @pgrunwald, yes. But first make sure to delete the 3.3 configuration folder before you launch the 3.3.1.

Let me know how it goes! :)

 

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
On 4/28/2018 at 6:19 PM, Drdave said:

Sheesh that was freaking BRILLIANT

I should have thought of that

Here is the 3mf that is REALLY a ZIP file after you change it back

Thank you SO much

Dr D

3.3.3mf

 

Hey @drdave!

 

I also got the file, and same as @Msuurmond, I see only the cache and it looks like it's 3.3.

Can you please check the \Application Support\Cura  again and look for the whole 3.2 folder? That's what we need to check. :)

 

Thanks

 

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
37 minutes ago, ElleCross said:

 

Hey @drdave!

 

I also got the file, and same as @Msuurmond, I see only the cache and it looks like it's 3.3.

Can you please check the \Application Support\Cura  again and look for the whole 3.2 folder? That's what we need to check. :)

 

Thanks

 

SO SORRY I thought you wanted the 3.3 here is 3.2 change to zip 

Sorry I misunderstood I thought you wanted the new folder created not the old one

Dr Dave

 

3.2.3mf

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
7 hours ago, Drdave said:

SO SORRY I thought you wanted the 3.3 here is 3.2 change to zip 

Sorry I misunderstood I thought you wanted the new folder created not the old one

Dr Dave

 

3.2.3mf

Got the file, but this is still only the cache folder. We need this folder: 

$USER/AppData/Roaming/cura/3.2/

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
16 hours ago, Msuurmond said:

Got the file, but this is still only the cache folder. We need this folder: 


$USER/AppData/Roaming/cura/3.2/
 

I am right clicking the folder as you asked then clicking add to zip then renaming it and sending it NOT sure what else I can do

I also can't be the ONLY one with this issue so how about someone else stepping up here and getting the team what they need

When I first posted this there were several others who had the exact issue

Here is the file labeled stl return to zip and let me know, please

THANK YOU ALL

Dr. D

 

3.2.stl

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1

@Drdave That is the correct content! I used it to run Cura 3.3.1 and it works here (on my MacBook). I also see you have some plugins installed, it might be that your Octoprint plugin needs an update.

To get Cura running again you could try to delete the folder OctoPrintPlugin:

1948183739_ScreenShot2018-05-02at07_49_46.thumb.png.b74e62217608aa793ceccf0e9ad179fb.png

 

When Cura runs again you can redownload it from the plugin browser.

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
10 hours ago, Msuurmond said:

@Drdave That is the correct content! I used it to run Cura 3.3.1 and it works here (on my MacBook). I also see you have some plugins installed, it might be that your Octoprint plugin needs an update.

To get Cura running again you could try to delete the folder OctoPrintPlugin:

1948183739_ScreenShot2018-05-02at07_49_46.thumb.png.b74e62217608aa793ceccf0e9ad179fb.png

 

When Cura runs again you can redownload it from the plugin browser.

Bummer that didn't work either

Anyone else having this non-install issue?

Help Msuurmond by posting your copy of the installed 3.2 folders so they can review the difference between working ones and broken ones

Dr. D

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1

Dr Dave,

The only luck I have had was to delete the 3.2 & 3.3 folder. Opening Cura accepting all the popups then closing out and replacing the 3.2 file in the deleted location from the trashbin.

 

cura stuff.PNG

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
19 minutes ago, Preston3 said:

Dr Dave,

The only luck I have had was to delete the 3.2 & 3.3 folder. Opening Cura accepting all the popups then closing out and replacing the 3.2 file in the deleted location from the trashbin.

 

cura stuff.PNG

Preston

That is what I reverted to as well

The only problem is that I can't get Windows to default to the 3.3 version upon clicking on an STL file so I have to open the 3.3 manually then drag and drop otherwise it opens the file in 3.2

Have tried to rename the 3.2 and the like but then I get a Win10 error talking about a pathway error occurring

I am OK with it I guess the added features of 3.3 are worth it but this dang software is SO buggy I can't for the life of me figure out why

I had a similar issue when we all started on 2.0 or maybe 2.5 or so 

NOT sure why the install doesn't simply copy the entire contents of the previous version instead of asking to remove the older versions.  I have LOTS of medical software that we run concurrent versions of why not Cura?

Thank you for taking the time and if anyone figures a viable fix let me know

Awaiting another version with still more great new features

Dr D

Share this post


Link to post
Share on other sites
Posted (edited) · Printer and material profiles lost 3.2.1

Grr!! Having this issue again this year (had it last year during another upgrade).I am a UM3 / OS X user.

 

I just upgraded to 3.3.1 and having the issue of all profiles disappearing. I tried deleting all directories in ~/Library/Application\ Support/cura, launching Cura, in the configuration wizard that pops up I tell it I have a UM3, and tell it to connect to my printer. The preferences window automatically pops up, and at this point I DO have profiles in there. I can even exit Cura and reopen and they are still there. But the moment I go to upper right, click the dropdown to select my configuration, the profiles disappear.

 

(This animated gif begins where I am opening preferences and you see the profiles exist)

 

Screen%20Recording%202018-05-25%20at%200

Edited by Croy9000

Share this post


Link to post
Share on other sites
Posted (edited) · Printer and material profiles lost 3.2.1

I am attaching a file that has the section of my cura.log that captures the moment I click to select my configuration.

 

This area looks notable (but maybe not related?)

 

2018-05-25 15:42:53,215 - INFO - [MainThread] cura.Settings.MachineManager._updateQualityWithMaterial [1144]: No available quality types found, setting all qualities to empty (Not Supported).
2018-05-25 15:42:53,217 - DEBUG - [MainThread] cura.Machines.Models.CustomQualityProfilesDropDownMenuModel._update [15]: Updating CustomQualityProfilesDropDownMenuModel.
2018-05-25 15:42:53,219 - INFO - [MainThread] cura.Machines.QualityManager.getQualityChangesGroups [186]: Cannot find node for machine def [ultimaker3] in QualityChanges lookup table

cura.log

Edited by Croy9000

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
10 hours ago, Croy9000 said:

I am attaching a file that has the section of my cura.log that captures the moment I click to select my configuration.

 

This area looks notable (but maybe not related?)

 

2018-05-25 15:42:53,215 - INFO - [MainThread] cura.Settings.MachineManager._updateQualityWithMaterial [1144]: No available quality types found, setting all qualities to empty (Not Supported).
2018-05-25 15:42:53,217 - DEBUG - [MainThread] cura.Machines.Models.CustomQualityProfilesDropDownMenuModel._update [15]: Updating CustomQualityProfilesDropDownMenuModel.
2018-05-25 15:42:53,219 - INFO - [MainThread] cura.Machines.QualityManager.getQualityChangesGroups [186]: Cannot find node for machine def [ultimaker3] in QualityChanges lookup table

cura.log

Could you share your whole config folder as a zip-file? Than we can use that to reproduce it on our development machines.

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1

@Msuurmond I have shared 2 zip files (renamed to 3mf to get them to upload). cura-before is ~/Library/Application Support/cura right after deleting all files in that directory and relaunching Cura so it populates it with clean data. cura-after is after the profiles go missing as described above.

cura-after.3mf

cura-before.3mf

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1
On 5/26/2018 at 2:03 PM, Croy9000 said:

@Msuurmond I have shared 2 zip files (renamed to 3mf to get them to upload). cura-before is ~/Library/Application Support/cura right after deleting all files in that directory and relaunching Cura so it populates it with clean data. cura-after is after the profiles go missing as described above.

cura-after.3mf

cura-before.3mf

 

Hi @Croy9000, I have checked your video. Turns out that the missing profiles was caused by the machine settings. I took a screenshot of your video and highlighted the part:

The combination of empty material together with BB 0.4 doesn't have any supported profiles. That's why you see no profiles in the list.

To solve this, you can disable the 2nd extruder since it has no material there: right-click on the 2nd extruder and choose "Disable Extruder". This way the profile list will only take into account the 1st extruder when it tries to find suitable profiles.

To enable the extruder again, you can right-click and choose "Enable Extruder".

 

Selection_001.png

Share this post


Link to post
Share on other sites
Posted · Printer and material profiles lost 3.2.1

@lfei WOW! Thanks for that find. I confirmed what you said works. I also placed my AA core in that #2 slot and it does not have the issue either.

 

Was this a regression with 3.3.1 though? 3.2 did not have this issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 11 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!