Jump to content
SandervG

Ultimaker S5 | impressions & opinions

Recommended Posts

Posted (edited) · Ultimaker S5 | impressions & opinions

Thanks Smithy.   Yes, I'll stick with UM2+ for now, and just see how things go with the UM3 and 5.   

 

Couldn't be happier with the UM2+.   But my dilemma is whether to go to a Ver 3.x  Cura  or stay with Ver 2.    Does Ver 3.x offer any significant advantages on a UM2+ or is it just frills ?   If any worthwhile advantages I would like to try it but that involves upgrading the UM2+ firmware and I've read of this sometimes  "bricking" some printers. I can't risk that.  I use the printer almost every day and I'm not a programming geek who easily get into the Auduino bootloading sections and code etc to unbrick it!  What version do you use on your UM2GO?

Edited by JonD
typo

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
21 hours ago, Smithy said:

It is really hard to say, but the UM3 and S5 are, basically the same. You got a much better feeder, filament sensor and touch display with the S5 and ofc a bigger build volume. The glass doors are also a nice feature. But if your budget is not that issue, I would go with the S5, because I like those small extras and I like the bigger volume.

It also has the Ulti-bus, which we will use in the future. Appart from that, it also has significantly improved stepper drivers (making it more silent and being more future proof).

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
1 hour ago, JonD said:

What version do you use on your UM2GO?

I use the latest Tinkergnome firmware because I upgraded the printer with a heated bed. Works fine without problems. But the UM2GO is a small UM2 printer and there were a lot of changes to the UM2+, but I guess there are a lot of UM2+ printers with latest firmware or Tinkergnome firmware.

 

40 minutes ago, nallath said:

It also has the Ulti-bus, which we will use in the future.

Ahh, is this the connector at the back beside the NFC connector?

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
3 hours ago, JonD said:

Thanks Smithy.   Yes, I'll stick with UM2+ for now, and just see how things go with the UM3 and 5.   

 

Couldn't be happier with the UM2+.   But my dilemma is whether to go to a Ver 3.x  Cura  or stay with Ver 2.    Does Ver 3.x offer any significant advantages on a UM2+ or is it just frills ?   If any worthwhile advantages I would like to try it but that involves upgrading the UM2+ firmware and I've read of this sometimes  "bricking" some printers. I can't risk that.  I use the printer almost every day and I'm not a programming geek who easily get into the Auduino bootloading sections and code etc to unbrick it!  What version do you use on your UM2GO?

 

Cura won't brick your Ultimaker, if anything it would be the firmware. Since it's freely available from our website you could just download it, give it a try. And if you don't like it you can install your current version again. 

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
On 10/26/2018 at 11:56 PM, Bigbrit said:

WiFi stability fixes? I'm down.

  

Will you also impliment the firmware upgrade part of the menu so that it is easier to understand? Currently you have no idea whether you are on the latest version already and are re-installing the firmware or are upgrading.

 

Not to be nit-picky, but I said connectivity stability. If your Ultimaker is currently just not connecting to your router for whatever reason, that won't be fixed by this firmware version most likely. What will be improved is stability between your Ultimaker and Cura / Connect. If you have occasionally lost connection or camera feed, that connectivity should become better. 

 

Just trying to set the proper expectations ?

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
3 hours ago, SandervG said:

 

Not to be nit-picky, but I said connectivity stability. If your Ultimaker is currently just not connecting to your router for whatever reason, that won't be fixed by this firmware version most likely. What will be improved is stability between your Ultimaker and Cura / Connect. If you have occasionally lost connection or camera feed, that connectivity should become better. 

 

Just trying to set the proper expectations ?

Hi SandervG 

 

In my case;

 

Typically when I have the network issue if I look on the touch screen it shows “properly” connected however, it is not visible within Ultimaker Cura nor remotely.

 

If I redo Cura Connect reset on the printer all is good again.

 

I am connected via WiFi with a MAC address assigned IP so the IP never changes as such it is not a DHCP issue; or at least not in the traditional sense.

 

Is this what I can expect to be fixed?

 

BTW; I also see “unknown” network on the touch screen from time to time too and this always seem to happen after the printer in on but not used for a period of time.

 

Takes care.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
1 hour ago, Shadowman said:

Hi SandervG 

 

In my case;

 

Typically when I have the network issue if I look on the touch screen it shows “properly” connected however, it is not visible within Ultimaker Cura nor remotely.

 

If I redo Cura Connect reset on the printer all is good again.

 

I am connected via WiFi with a MAC address assigned IP so the IP never changes as such it is not a DHCP issue; or at least not in the traditional sense.

 

Is this what I can expect to be fixed?

 

BTW; I also see “unknown” network on the touch screen from time to time too and this always seem to happen after the printer in on but not used for a period of time.

 

Takes care.

 

Exactly the same as me mate and what I have reported in this thread previously.

 

What I meant is stability with cura connect over wifi connection to printer, have you fixed this yet or not @SandervG? Also can you comment about how the firmware upgrade part of the printer will behave post new update? will you be making this more intuitive? 

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
8 minutes ago, Bigbrit said:

 

Exactly the same as me mate and what I have reported in this thread previously.

 

What I meant is stability with cura connect over wifi connection to printer, have you fixed this yet or not @SandervG? Also can you comment about how the firmware upgrade part of the printer will behave post new update? will you be making this more intuitive? 

We both have made this situation known and in my speaking with others directly some; I dare say all are affected.

 

At least one person has simply deferred to using USB and only visually monitoring; thus option is not acceptable to me on such a printer. I have printers that cost far less that this situation was known from day one hence aceepted.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions

As I was pointed to information by @Smithy in this thread:

I am wondering how much of this issue may be caused by this and what can be done other than being 'router stoopid' like myself.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker S5 | impressions & opinions
50 minutes ago, kmanstudios said:

As I was pointed to information by @Smithy in this thread:

I am wondering how much of this issue may be caused by this and what can be done other than being 'router stoopid' like myself.

As long as the printer is managing the IP address by DHCP it can and often changes during reboot as well as when the DHCP lease expires. In therory when the DCHP lease is renewed it should use the same IP address however, this often does not happen. The lease time can be altered, meaning, extended but the easiest way is to go into the router and do a MAC IP assignment.

 

The purpose for the DHCP lease time is so that roaming devices always have access to your IP address pool. If this did not happen sooner or later nothing could connect because there would be no available IP addresses.

 

In any case; 

 

Once you do a MAC IP assignment within the router the DHCP query created by the printer will see this and the printers IP address will remain constant; effectively a static IP address.

 

 

Edited by Shadowman
Spelling

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
20 hours ago, SandervG said:

 

Cura won't brick your Ultimaker, if anything it would be the firmware. Since it's freely available from our website you could just download it, give it a try. And if you don't like it you can install your current version again. 

 

My apologies SandervG,  I meant the firmware,  not Cura itself.  Should I be checking  and updating the firmware with each new version of Cura that I install?   i.e. are they "linked"  or totally unrelated and independent  of one another?  Am I correct in thinking that some updates and new features in later versions of Cura won't work without an associated firmware upgrade?

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker S5 | impressions & opinions

Well, I am afraid I have to report in as a user with an issue with my s5.  As of this morning, it won't boot up and start properly.  After running a couple successful prints last night, I woke up to a failed print this morning (no big deal...was printing a very small model with very little surface area and I didn't want to use a brim).  Anyway, when I cleared the bed and sent the print to the printer again, I got the bed leveling error which I have seen before, including once last night amid my successful short prints.

 

Because I was unable to get past the printer failing calibration when I would retry my print when prompted from the failure, my fix last night and my attempt this morning was to power the printer off and on again.  Last night, that seemed fine.

 

This morning, the printer won't boot up at all.  I turn it on...it flashes the Ultimaker logo on the touch screen...goes black...and nothing.  Silence.  No fans...No lights in the printer...no nothing.

 

I tried reseating the power cable.  I tried switching outlets.  I tried removing the USB stick (which I never really use since I print over the network).


I'm dead in the water.  Here's a video of what is happening.

 

 once it's loaded.  You can see what happens.

Edited by chuckmcgee

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions

Hi,

 

yesterday, the Cura PPA was updated, and today Cura was able to detect the S5 again. Yay!

 

The printer offered me a firmware update from 5.0.19.20180622 to 5.1.7.20181023.

 

Idiot me chose to install the fiormware update. It says now:

Quote

 

Installing firmware…

Do not turn off the printer…

Please wait…

 

 

for the past five hours!

 

What the crap is happening?

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
3 minutes ago, asb said:

Hi,

 

yesterday, the Cura PPA was updated, and today Cura was able to detect the S5 again. Yay!

 

The printer offered me a firmware update from 5.0.19.20180622 to 5.1.7.20181023.

 

Idiot me chose to install the fiormware update. It says now:

 

for the past five hours!

 

What the crap is happening?

Relax...

 

Turn the printer off and restart the FW update and you will be fine

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
On 10/31/2018 at 11:14 AM, Smithy said:

Ahh, is this the connector at the back beside the NFC connector?

 

Yup

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
48 minutes ago, Shadowman said:

Relax...

Not easy when it happens the first time you see it. I too am used to it now, but it is a bit of a shellshock to see it for the first time and bringing on the fear of bricking a printer....

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker S5 | impressions & opinions
5 minutes ago, kmanstudios said:

Not easy when it happens the first time you see it. I too am used to it now, but it is a bit of a shellshock to see it for the first time and bringing on the fear of bricking a printer....

I understand as I was the same; the first time I let it sit all night concerned that it was akin to a bios reflash.

Edited by Shadowman
Spelling

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
2 hours ago, kmanstudios said:

Not easy when it happens the first time you see it. I too am used to it now, but it is a bit of a shellshock to see it for the first time and bringing on the fear of bricking a printer....

It's a good exercise to wake up in the morning and to increase blood circulation ?

 

3 hours ago, Shadowman said:

Relax...

Turn the printer off and restart the FW update and you will be fine

Yes, nothing can happen, but do the FW update via the menu and not via the popup notification or via the top right yellow icon. There is a small chance that the update stalls if you go via these options. (is fixed in the latest firmware)

 

  • Like 2

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
8 minutes ago, Smithy said:

(is fixed in the latest firmware)

We will see because mine crapped out in this latest firmware update. So, hopefully next time it is smooth.

 

But, with the new update, Cura Connect wiped out my history. And, I just finished a print and it did not go into my history.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
13 hours ago, kmanstudios said:

Cura Connect wiped out my history

That is unknown behavior. Can you describe which steps you have taken? Did you also manually delete any files from any list? And to be clear, which history do you mean? With the new firmware there is also new analytics, but this does not load 'old information', so that should be empty after installation.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions
2 hours ago, SandervG said:

That is unknown behavior. Can you describe which steps you have taken? Did you also manually delete any files from any list? And to be clear, which history do you mean? With the new firmware there is also new analytics, but this does not load 'old information', so that should be empty after installation.

 

Same here. Print queue history is empty after the update.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions

What steps taken....updated firmware.

 

Now, two prints finished, neither print made it to update history.

 

Steps taken, printed objects. Looked at history. ?

 

Basically, it ain't behaving as before.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions

Did you/anyone manually delete any prints from your queue in between, or was there no manual intervention between having a full history - update - empty print history?

 

Can you send me the logs from your Ultimaker S5 for closer inspection, if this has plagued you?

Share this post


Link to post
Share on other sites
Posted · Ultimaker S5 | impressions & opinions

Well, the second print finally popped up. Talk about a delayed reaction.

 

Did not do any of the above things though. Here is the basic operation I employ.

 

1. Slice and send to queue

2. May arrange or rearrange based on current need

3. Print

4. See print pop in up history

 

I did not expect the print to show up until completed or aborted. Oddly enough the print was completed, but it finished in the wee hours when I was asleep. For some reason it hanged there and when I cleared the print and, for some reason, it showed as something else other than 'finished, so I aborted the final 'whatever it was doing'. Print was finished though.

 

So, something happened there that I am not completely aware of all steps, but am keeping an eye out for the current print I am running.

 

Will track that much better.

 

Active Leveling is much, much faster though....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!