Jump to content

Cura hangs when opening on second monitor


Recommended Posts

Posted · Cura hangs when opening on second monitor

I've been using Cura 3.2.1 successfully for a few weeks but it is now hanging on startup. The main window appears but is all white and has the 'not responding' title bar. The problem appears to be due to it starting on my second monitor - I noticed in the stack trace (attached) that it was calling GetMonitorInfoA and disabling the second monitor caused it to start successfully on the first monitor. I then had to re-enable the second monitor with Cura open, then close Cura, to make it to open on the first monitor when reopened.


I now know the work around if it happens again but is this a known issue and is there a better solution than temporarily disabling the extra monitor?


Cura hang stack trace.log

  • Link to post
    Share on other sites

    • 2 years later...
    Posted · Cura hangs when opening on second monitor

    This is still an issue in 2020 with 4.6.1. I'm quite sure it has to do with the fact that one of the monitors runs with the integrated intel UHD graphics 630 card, and the second one with the dedicated GeForce GTX1060, but I still couldn't find a way around it. I tried changing the graphics card cura uses or disabling the integrated graphics card, but none of them worked for me. When it opens on the wrong monitor there is no way around it other than closing it and opening again with only one display.



  • Link to post
    Share on other sites

    Posted · Cura hangs when opening on second monitor

    There is an option in the General preferences now that will at least stop Cura from crashing by forcing it to start up on the primary screen. The caveat is that you need it to start at least once; temporarily disabling the second screen should work with that.


    In the General settings, uncheck the "Restore window position on start" checkbox.

  • Link to post
    Share on other sites

    • 2 months later...
    Posted · Cura hangs when opening on second monitor

    Had the same problem with Fusion 360. Submitted a bug post and process dumps to Autodesk and they came up with this. Can confirm that this works for both Cura and Fusion 360

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 10 replies
    • Create New...