Jump to content
Ultimaker Community of 3D Printing Experts

Cura hangs when opening on second monitor


Fulby
 Share

Recommended Posts

Posted · Cura hangs when opening on second monitor

I've been using Cura 3.2.1 successfully for a few weeks but it is now hanging on startup. The main window appears but is all white and has the 'not responding' title bar. The problem appears to be due to it starting on my second monitor - I noticed in the stack trace (attached) that it was calling GetMonitorInfoA and disabling the second monitor caused it to start successfully on the first monitor. I then had to re-enable the second monitor with Cura open, then close Cura, to make it to open on the first monitor when reopened.

 

I now know the work around if it happens again but is this a known issue and is there a better solution than temporarily disabling the extra monitor?

 

Cura hang stack trace.log

  • Link to post
    Share on other sites

    • 2 years later...
    Posted · Cura hangs when opening on second monitor

    This is still an issue in 2020 with 4.6.1. I'm quite sure it has to do with the fact that one of the monitors runs with the integrated intel UHD graphics 630 card, and the second one with the dedicated GeForce GTX1060, but I still couldn't find a way around it. I tried changing the graphics card cura uses or disabling the integrated graphics card, but none of them worked for me. When it opens on the wrong monitor there is no way around it other than closing it and opening again with only one display.

     

     

  • Link to post
    Share on other sites

    Posted · Cura hangs when opening on second monitor

    There is an option in the General preferences now that will at least stop Cura from crashing by forcing it to start up on the primary screen. The caveat is that you need it to start at least once; temporarily disabling the second screen should work with that.

     

    In the General settings, uncheck the "Restore window position on start" checkbox.

  • Link to post
    Share on other sites

    • 2 months later...
    Posted · Cura hangs when opening on second monitor

    Had the same problem with Fusion 360. Submitted a bug post and process dumps to Autodesk and they came up with this. Can confirm that this works for both Cura and Fusion 360
    https://knowledge.autodesk.com/support/fusion-360/troubleshooting/caas/sfdcarticles/sfdcarticles/Fusion-360-user-interface-menus-don-t-work-on-a-Windows-MSI-GT72S-Computer.html

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...