Jump to content
Ultimaker Community of 3D Printing Experts

How to force retracts for ALL travel moves?


Recommended Posts

Posted · How to force retracts for ALL travel moves?

Hello! I am getting good prints except for my non-retracted travels leaving blobs everywhere. When cura does retract the travel areas look good. How do I force Cura to retract for ALL travel moves?

  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?

    I couldn't figure out how to edit my initial post, but I figured out my problem was I had "combing" enabled. Combing moves do not include retracting. So I can get nice retracts with no  combing, or I can get combing with no retracts. Any way to get both?

  • Link to post
    Share on other sites
    Posted (edited) · How to force retracts for ALL travel moves?

    Combing is when travelling on places already (or will be) printed in the same layer

     

    Did you try these settings ?

     

    CaptureCombing.JPG.353395698ff687ac3b3fd0b094c7821a.JPG

     

    I think they will be a good compromise between quality and speed (retraction is time consuming, z hop movements as well)

     

     

    Edited by JCD
  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?

    There is also now a Max Comb Distance With No Retract setting that when set to a non-zero value, all combing moves longer than that distance will use retraction (but not z-hop). So this gives you the ability to comb short distances and retract for long distance travel.

    • Like 1
    Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?
    16 hours ago, smartavionics said:

    There is also now a Max Comb Distance With No Retract setting that when set to a non-zero value, all combing moves longer than that distance will use retraction (but not z-hop). So this gives you the ability to comb short distances and retract for long distance travel.

     

    This sounds perfect! If I understand correctly, it will retract "while" combing? And this is available in the current release of Cura? I'm away from my PC right now but I'm excited to check ASAP.

  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?
    2 minutes ago, Gabe_D said:

     

    This sounds perfect! If I understand correctly, it will retract "while" combing? And this is available in the current release of Cura? I'm away from my PC right now but I'm excited to check ASAP.

     

    It's in the 3.4 beta so will be in 3.4 when it arrives.

  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?

    Awww, hurry up and wait I guess ? Any source for pre-compiled beta binaries?

  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?

    There's a link to the beta binaries on the Ultimaker Cura download page, https://ultimaker.com/en/products/ultimaker-cura-software .

     

     

  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?
    1 minute ago, KickahaOta said:

    There's a link to the beta binaries on the Ultimaker Cura download page, https://ultimaker.com/en/products/ultimaker-cura-software .

     

     

    Excellent, thanks so much!

  • Link to post
    Share on other sites
    Posted (edited) · How to force retracts for ALL travel moves?


    never mind, found the comb distance setting.

     

     

     

    Edited by Gabe_D
  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?

    It's definitely there (at least in the Windows beta). You may have to go to the configuration screen and make the setting visible.

     

     

    Comb Retract.PNG

  • Link to post
    Share on other sites
    Posted (edited) · How to force retracts for ALL travel moves?

    Is it possible to use this setting to avoid these diagonal travel lines on the first layer?

     

    TravelLines.jpg

    Edited by Uhlhorn
  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?
    9 hours ago, Uhlhorn said:

    Is it possible to use this setting to avoid these diagonal travel lines on the first layer?

     

    To completely avoid those lines you need to:

     

    1 - set combing mode to no skin

     

    2 - use z-hop

     

    Also, setting the max comb distance with no retract will help reduce oozing while combing.

  • Link to post
    Share on other sites
    Posted · How to force retracts for ALL travel moves?

    Thanks!

    I set „Max comb distance with no retract“  to something different than zero and it works! 🙂

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...