Jump to content
Cura Connect | Survey Read more... ×
Ultimaker Community of 3D Printing Experts
jens3

Cura 3.4 not importing previous profiles correctly

Recommended Posts

Just tried to install the newest version of Cura. This is an upgrade from 3.31 for me.

On startup, 3.4 reported that several profiles were corrupt and asked if it could reset to factory defaults. This killed all profiles and printer initialization strings.

At this point even my 3.31 installation has the profiles destroyed (probably inadvertently by me trying to get around the problem)

I tried copying the old profile (for 3.3) over to the 3.4 folder but again Cura 3.4 reported errors/corruption. At the same time, 3.3.1 loaded the profiles just fine.

I am stuck and do not know how to get around this issue without recreating everything manually from scratch - an option that is not pleasant to think about!

Share this post


Link to post
Share on other sites

Yes I have the same issue. I manually started all over in 3.4 and I have 16 printers so it was a couple of hours as I did a few and walked away from the computer and I used the new backup plugin which works great and kept adding a couple of printers, backed cura up and closed cura and reopened. For some reason after the 14th printer if I add another printer backup and restart cura never reopens. Then I have to delete the 3.4 folder and it does a hard boot comes back open shows me all my printer profiles from 3.31 and the list is really long and it ask you to reset your profiles but it only has a reset button and doesn't give you an option to say no. If you don't reset every time you open 3.4 its still there and in front of your build screen so cura is worthless unless you click the reset button. After that its like a fresh install. Using my back up I'm able to get it back working with only the 14 printer profiles so I'm sticking with version 3.31 until someone fixes this. Not sure if 3.31 is causing this issue and I have to have both up to enter in my settings. I haven't tried print screening the settings and only have 3.4 open at the time. It worked with no issues until that point.

Share this post


Link to post
Share on other sites

Having the same problem. After installing version 3.4 the program reported that there where corruption problems and reset to defaults. I had to recreate my custom printers and all seemed to be fine for about 2 days. This afternoon the same message came up when launching Cura and profiles were deleted again. I reverted to version 3.3.1 all seems to be OK.

 

My installation is on Windows 10.

Share this post


Link to post
Share on other sites

The current version, Cura 3.4.1, seems to import the profiles ok but there are a number of other issues that remain and that forced me to give up on the newer versions.

 

One example - the visibility data (what options are visible on the right side of the screen) is not brought across.

Another issue, the plugin manager can't connect to the server even though 3.3.1 run on the same computer works just fine.

It also seems that the octoprint configuration isn't carried across nor is the initialization g code for the printer.

Direct inter-operation with Freecad files doesn't work (that was my big incentive to upgrade)

 

None of these examples were researched in any way to see if this is just fat finger syndrome on my end. I just decided to stick with the 3.3 branch for now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Architect Design Contest | People
      The goal of this contest is to design a set of people figurines that could be used in such a project to make an area, office or mall seem populated. 
      Think of different types of people in different environments, like walking people, people standing still, working people, and both men and women.
       
      • 9 replies
    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!