Jump to content
Cura Connect | Survey Read more... ×
Ultimaker Community of 3D Printing Experts

Cura Crashing on Gcode Save

Recommended Posts

Cura has always crashed on me when I attempt to make any settings/profile changes. It didn't used to be a big deal, but recently when I built my custom printer, I created a custom profile for it in Cura so I could slice files for it there. I wasn't even able to use Cura on my computer (Worked fine on my other desktop) to slice for the printer because it would crash anytime I tried to make any setting changes. I contacted my laptop's manufacturer and they suggested I install new drivers for my built in graphics card. That seemed to work. I was now able to slice and edit my slicer/printer settings without a problem. When I hit "save to file", however, Cura crashed. I tried again, and same thing. The weird thing is, it actually writes and saves the gcode - just not all of it. After I hit save to file, Cura immediately seizes and stops working. I can find the saved gcode file and look at it, however. Everything looks fine, until the very end. Cura writes the last line of actual gcode, and then just gives up. It doesn't add the "end gcode", so when the print finishes, my printer just stops moving at the last line of code. It doesn't return to home, it doesn't turn off the hot end or fans, it just stops. This is really frustrating because it means I have to manually add that code, or I have to monitor my printer. It also means I have to reboot Cura if I want to reslice or slice something else.


Any ideas what may be wrong?

Share this post

Link to post
Share on other sites

I should note that Cura freezes/crashes on me when I try to make setting changes to my printer, save gcode, or change the visibility on slicing settings. It happens no matter which printer profile I select, but especially when I select my "Custom FDM Printer" ("Hephaestus"). Also, if I save directly to my other printer's SD card there's no crash - only if I try to save direct to file.

Share this post

Link to post
Share on other sites

I can't find anything obvious in the logs what could be causing this. There also isn't really a difference between saving to SD directly or you computer, just that it shows a nice popup to safely remove if you save to SD.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Architect Design Contest | People
      The goal of this contest is to design a set of people figurines that could be used in such a project to make an area, office or mall seem populated. 
      Think of different types of people in different environments, like walking people, people standing still, working people, and both men and women.
      • 9 replies
    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!