Jump to content
szurgot

Dual-extrusion - Heating takes place right on model

Recommended Posts

Posted · Dual-extrusion - Heating takes place right on model

Been working with getting Dual extrusion setup, both with two extruders, and with Palette+. I've mostly got it working correctly, except that when it switches extruders, it just stops at the last command and calls the temperature change and waits until it heats up before moving. Usually, this means it's sitting right over the model, and ends up melting part of what it printed. What would be the appropriate way to have it move the nozzle, up or a least away from the model before doing this temperature change?

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

I have not tested this, but I think you can edit your extruder definition (or definition_changes config) to include machine_extruder_end_pos_abs, machine_extruder_end_pos_x and machine_extruder_end_pos_y.

https://github.com/Ultimaker/Cura/blob/master/resources/definitions/fdmextruder.def.json#L135

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

It's less clean, but a lot easier, just add a line in the printer definition:

 

image.png.03367f5952be64002fe385261b766979.png

 

I did this on both tools, and it works fine. It's annoying it isn't built in, but this works.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited) · Dual-extrusion - Heating takes place right on model

Same problem here, 8 months later, there still isn't any official solution to this issue ? Every model I will print I need to define the X and Y location of the extruder? to avoid traveling to much left or right when printing in different location of the bed.

 

Also is there an option to keep the temperature high all the time? is there any problem regarding this when printing PETG and PVA for support ? 

 

I noticed the cooldown of the active extruder happens before it finished printing with it, maybe 10 seconds before, why the heating of the next extruder doesn't happen before using it? to avoid waiting so much time. On a small model (a 30x30mm dice) I think the waiting time will double the print time. 

 

Here's a video of what I would expect, after printing a layer with Color 1 start printing directly with Color 2, I don;t know why it cools down the other nozzle.

 

 

Thank you.

Edited by sibianul

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model
On 1/25/2019 at 11:14 AM, sibianul said:

Every model I will print I need to define the X and Y location of the extruder?

No.  You just do it once in machine settings.

 

Yes it does preheat before starting printing and it pre cools just before finishing printing.  Search for "standby" to find and adjust the temperature of the inactive nozzle.  These values are perfect for ultimaker cores on the UM3 or S5.

 

I can't find the settings where you tell it when to start preheating.  I'll keep looking...

 

update: it's called "heat up speed" and "cool down speed".  These are in degrees C per second.  If cura knows the speed to heat and cool then it knows when to switch the heater back on so that it reaches printing temperature just at the moment when it needs to use the other nozzle.

 

I don't know how to mess with those values because for a UM3 or S5 they aren't editable.  Hopefully for your printer you can edit them directly.  If not then they are probably set in one of the json files for your printer.  You can view the current values in the profile dialog if you select the extruder1 tab.

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

...and keep in mind that the LulzBot Edition of Cura is quite different (the video suggest a LulzBot printer...?)

 

Share this post


Link to post
Share on other sites
Posted (edited) · Dual-extrusion - Heating takes place right on model
6 hours ago, gr5 said:

No.  You just do it once in machine settings.

 

But each model is different, it could be a very small model, and setting the point far away on a side, it could lose alot of time only because of those travels.

 

I hoped that when USE TOWER is checked, the nozzle will wait to heat up on the tower , but to my surprise, it does the same thing, it waits on the part, and than travels to the tower, extrudes a layer and than comes back.

 

I also hoped that when Z HOP was enabled , it will go above the part, before moving on any side, but it didn;t, it made the Z HOP when it arrived on the tower, this was weird, it traveled at the same layer height, and when it reached the tower, it did the Z HOP. Maybe COMBING MODE set to ALL was the issue , when traveling on the same distance, I haven't printed yet with COMBING DISABLED. But I will

 

I noticed the printer is changing temperatures set on those values

 

PRINTING TEMPERATURE .. i set it at 215 deg C

INITIAL PRINTING TEMPERATURE ... was automatically set to 205 deg C

FINAL PRINTING TEMPERATURE ... was automatically set to 200 deg C

 

so each time the printer has to swap colors, it increases and decreases the temperature to those values, with many seconds of waiting. Do you know if there could be any problem to set them all to 215 deg C? .. hopefully, there will be no wait time to heat up. Is there any problem if I won;t cool down the unused nozzle ? 

 

In cura 3.6 I haven't found those settings "heat up speed" and "cool down speed", do you have v4 (Beta)? or a developer edition ?

 

Thank's again for any advices!

Edited by sibianul

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

@ahoeben says you can access "heat up speed" and "cool down speed" but only if you do two things.  You have to pick a gcode flavor different from "griffin" or "ultigcode".  Also you need the "printer settings plugin".

 

Regarding the tower - the whole point of the tower is to wipe off any little tiny strings/sausages coming out of the nozzle so you don't want it to hop over the tower.

 

It's fine to set those temps the same but it won't help.  You need to change the "standby" temperature.  But again, if you can set the "heat up speed" and "cool down speed" properly then it will all work perfectly and be completely at temperature with no waiting when you switch nozzles.

 

What is the risk if "stand by" temperature is too hot?  It may leak and if the leak is long enough it may end up in the print.  Your part is very small however so for this part in the video you could just set standby temp to the same temp as the printing temp and the tower will take care of any tiny strings/sausages.

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

I think if you find the right cfg file for your printer you can probably edit it there and restart cura.  I found these in my local area - not in the cura installation folder.  Your local folders will override the ones in the cura installed folder.

 

Most printer profiles inherit from fdmprofile so it could be you can edit them there.  

a.thumb.png.87967080d119b49f25a10f026c092501.png

 

To see what your current values are go to this profile dialog:

b.thumb.png.8b607639706539086caabb35603d1f5a.png

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

Thank you guys, later, after work I will install the plugin and check the files, now those values are not shown in Extruder tab.

 

Will post back, after more tests, with those settings tuned up.

Share this post


Link to post
Share on other sites
Posted (edited) · Dual-extrusion - Heating takes place right on model

I installed the PRINTER SETTINGS plugin and I found 2 two variables HEAT UP and COOL DOWN, but in my first test I didn't noticed any difference between the g-code generated with a value of 2 deg / sec .. compared to the gcode generated with a value of 1deg/s, all the M104 lines ware exactly at the same line in both files, I expected to find the M104 S255 line a few lines above, in the file that was set with 1deg/sec, isn't this what the HEAT UP option should do ? 

 

Today I mounted again the dual nozzle head and started the tests again, but until I figure out what's up with HEAT UP and COOL DOWN settings I used the same temperature for INITIAL and FINAL PRINTING TEMPERATURE so it keeps both nozzles hot. And also disabled WAIT FOR NOZZLE HEAT UP.

 

There is no pause between color changes with those settings, but it makes a little hop (, a movement on Z axis up, and than back down) when it moves from PRINTED PART to PRIME TOWER , for both support section and part sections, and I don't know what it causing this hop, and how it can be eliminated?

 

Please check this video, at second 11 you see the hop (a movement on z axis only, up, and than back down) I'm talking about

 

 

Coasting set to 0.5mmc and minimum volume to 2mmc, seems to help reduce the extra material extruded when that "hop" happens, and there ware no empty space in the printed part, comparing to what CURA is showing in the preview, probably my long (50cm) bowden tube act as a spring and it extrudes more material even when extruder motor stops.

2124743848_coastignenabled.thumb.jpg.28be3fe6af84b1ac8e176ab5cba022d9.jpg

 

The printed part looks like this bellow, there are no empty spaces where coasting is stopping extrusion, in the blue material (in my final part that will be PVA filament) you can still see over-extrusion but only because of that UP and DOWN movement.

2068507951_printedpartwithcoastignandoozeshieldv3.thumb.jpg.e30b9eb0f202cb062bd03df40e9c56a3.jpg

 

Any help tracking down the setting that generates that UP and DOWN movement is appreciated, any other suggestions are also welcome!

TEST dual colors - heatUP1sec - oozeSHIELD - coasting.gcode

Edited by sibianul

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model

I went a kind of similar route as @AbeFM and added Extruder End G-Code, but instead of taking fixed values I used the following line:

 

G1 {prime_tower_position_x} {prime_tower_position_y}

 

that always simply moves the hotend in the middle of the prime tower letting out the oozing in there and not over the model.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Dual-extrusion - Heating takes place right on model
On 6/27/2019 at 3:02 PM, Christanoid said:

I went a kind of similar route as @AbeFM and added Extruder End G-Code, but instead of taking fixed values I used the following line:

 

G1 {prime_tower_position_x} {prime_tower_position_y}

 

that always simply moves the hotend in the middle of the prime tower letting out the oozing in there and not over the model.

Minor Screw Up on my side, I just noticed that doesn't work. Instead the line has to be:

G0 X{prime_tower_position_x} Y{prime_tower_position_y}

 

As it was in my original comment it just results in nothing happening at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!