Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Gcode 3.4.1

The gcode does not work as expected in Cura 3.4.1

 

 

It's like this in the Start code

;Sliced at: {day} {date} {time}

;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}

;Print time: {print_time}

;Filament used: {filament_amount}m {filament_weight}g

;Filament cost: {filament_cost}

;M190 S{print_bed_temperature} ;Uncomment to add your own bed temperature line

;M109 S{print_temperature} ;Uncomment to add your own temperature line

G90; EXTRUSORA NO POSICIONAMENTO ABSOLUTO

M83; EXTRUSORA NO MODO RELATIVO

M106 S255; LIGA VENTILADOR

G4 P500; PAUSA MOVIMENTO

M106 S0; LIGA VENTILADOR

M140 S{print_bed_temperature}; TEMPERATURA DA MESA

M190 S{print_bed_temperature}; AGUARDA MESA AQUECER

M109 S100; FAZ AQUECIMENTO DO BICO

M104 S{print_temperature}; FAZ PRE AQUECIMENTO DO BICO

M402

G28; HOME GERAL

M400

G29 V4 T ; AUTO NIVELAMENTO

M400

G1 X1 Y1 Z0.8 F1000; VAI PRA PONTO DE PURGA

M109 S{print_temperature}; FAZ AQUECIMENTO DO BICO

G92 E0; RESETA EXTRUSOR

G1 X1.0 E9.0 F1000.0 ; PURGA

G1 X100.0 E12.5 F1000.0 ; PURGA

M117 IMPRIMINDO...

M400

G1 E-6.0000 F4200

G1 Z0.600 F3000

T0

Why are you leaving like this?

;FLAVOR:Marlin
;TIME:35423
;Filament used: 85.3195m
;Layer height: 0.2

;POSTPROCESSED
;ChangeAtZ instances: 1
;Generated with Cura_SteamEngine 3.4.1

▶︎M190 S115 ◀︎
▶︎M104 S250◀︎
▶︎M109 S250◀︎
M82 ;absolute extrusion mode
;Sliced at: Thu 12-07-2018 15:09:50
;Basic settings: Layer height: 0.2 Walls: 1.5 Fill: {fill_density}
;Print time: 09:50:23
;Filament used: [85.32]m [225.7392328125]g
;Filament cost: [0]
;M190 S110 ;Uncomment to add your own bed temperature line
;M109 S225 ;Uncomment to add your own temperature line
G90; EXTRUSORA NO POSICIONAMENTO ABSOLUTO
M83; EXTRUSORA NO MODO RELATIVO
M106 S255; LIGA VENTILADOR
G4 P500; PAUSA MOVIMENTO
M106 S0; LIGA VENTILADOR
M140 S110; TEMPERATURA DA MESA
M190 S110; AGUARDA MESA AQUECER
M109 S100; FAZ AQUECIMENTO DO BICO
M104 S225; FAZ PRE AQUECIMENTO DO BICO
M402
G28; HOME GERAL
M400
G29 V4 T ; AUTO NIVELAMENTO
M400
G1 X1 Y1 Z0.8 F1000; VAI PRA PONTO DE PURGA
M109 S225; FAZ AQUECIMENTO DO BICO
G92 E0; RESETA EXTRUSOR
G1 X1.0 E9.0 F1000.0 ; PURGA
G1 X100.0 E12.5 F1000.0 ; PURGA
M117 IMPRIMINDO...
M400
G1 E-6.0000 F4200
G1 Z0.600 F3000
T0
G92 E0
G1 F1500 E-6.5

  • Link to post
    Share on other sites
    Posted · Gcode 3.4.1

    Because you use old, deprecated replacement patterns. Use “material_bed_temperature” instead of “print_bed_temperature”, and “material_print_temperature” instead of “print_temperature”.

    • Like 1
    Link to post
    Share on other sites
    Posted · Gcode 3.4.1
    Could you tell me if you can remove these lines?

    ;Generated with Cura_SteamEngine 3.4.1
    ;M82 ;absolute extrusion mode
    ;M190 S105 ;Uncomment to add your own bed temperature line
    ;M109 S225 ;Uncomment to add your own temperature line
    G90; EXTRUSORA NO POSICIONAMENTO ABSOLUTO
    M83; EXTRUSORA NO MODO RELATIVO
    M106 S255; LIGA VENTILADOR
    G4 P500; PAUSA MOVIMENTO
    M106 S0; LIGA VENTILADOR
    M140 S105; TEMPERATURA DA MESA
    M190 S105; AGUARDA MESA AQUECER
    M109 S100; FAZ AQUECIMENTO DO BICO
    M104 S225; FAZ PRE AQUECIMENTO DO BICO
    M402
    G28; HOME GERAL
    M400
    G29 V4 T ; AUTO NIVELAMENTO
    M400
    G1 X1 Y1 Z0.8 F1000; VAI PRA PONTO DE PURGA
    M109 S225; FAZ AQUECIMENTO DO BICO
    G92 E0; RESETA EXTRUSOR
    G1 X1.0 E9.0 F1000.0 ; PURGA
    G1 X100.0 E12.5 F1000.0 ; PURGA
    M117 IMPRIMINDO...
    M400
    G1 E-6.0000 F4200
    G1 Z0.600 F3000
    T0

    ▶︎ E0◀︎

    ▶︎ F1500 E-6.5◀︎

    ;LAYER_COUNT:654
     

  • Link to post
    Share on other sites
    Posted · Gcode 3.4.1

    Hello

     

    I also have a problem with the code ahead of the 'start code'

    My machine is a UMO with heated bed and dual extruder. I use the nozzles to keep different materials loaded, rather than as dual extrusion. I also need to keep the working area at maximum, so have created a single extruder machine that uses the second nozzle. However, the code at the top (shown in bold):

    ;FLAVOR:Marlin
    ;TIME:18013
    ;Filament used: 7.09843m
    ;Layer height: 0.15
    ;Generated with Cura_SteamEngine 3.4.1
    M190 S60
    M104 S210
    M109 S210

    M82 ;absolute extrusion mode
    G21 ;metric values
    G90 ;absolute positioning

     

    ...seems to get both nozzles to heat up.

    How can I stop this code being written?

     

    Thanks, Colin

  • Link to post
    Share on other sites
    Posted · Gcode 3.4.1

    Make sure your startgcode contains the literal strings “{material_print_temperature}” and “{material_bed_temperature}”, even if it is in a comment. Cura will see this as a preheating sequence, and won’t add one of its own.

  • Link to post
    Share on other sites
    Posted · Gcode 3.4.1

    Thanks, that works perfectly.

     

    Here is my start code for reference:

     

    T0 ;Switch to the 1st extruder

    M104 S0 ;switch off nozzle 0

    T1 ;Switch to the 2nd extruder

    M190 S{material_bed_temperature} ;Set bed temp and wait to reach temp

    M109 S{material_print_temperature} ; Set extruder temp and wait to reach temp

    G4 S20 ;Wait for extruder temp to stabilise

    G21 ;metric values

    G90 ;absolute positioning

    M107 ;start with the fan off

    G28 X0 Y0 ;move X/Y to min endstops

    G28 Z0 ;move Z to min endstops

    G1 Z15.0 F9000 ;move the platform down 15mm

    G92 E0 ;zero the extruded length

    G1 F200 E15 ;extrude 15 mm of feed stock

    G92 E0 ;zero the extruded length again

    G1 F9000

    ;Put printing message on LCD screen

    M117 Printing...

     

    I have also used this code when using the first extruder, but with the nozzle numbers reversed in the first 3 lines.

    Note that I have added a pause (G4 in line 6) to allow the extruder temperature to stabilise, and increased the length of the priming extrusion.

  • Link to post
    Share on other sites
    Posted · Gcode 3.4.1

    I am now using the 'Printing Temperature - Initial Layer' parameter, so the extruder heat-up line can be changed to:

    M109 S{material_print_temperature_layer_0}

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...