Jump to content
Ultimaker Community of 3D Printing Experts
varazir

Unnecessary travels

Recommended Posts

Hello, 

 

I'm trying to print a model I have designed in Fusion 360 ( STL attached ) 

When looking at the travels for this part it's a lot that shouldn't be needed. 
There are 2 outer walls and a inner. 

Gidq6ip.png

 

 

Seam settings is set to Sharpest corner and Hide seam. 

 

Don't know what settings you want so please let me know and I'll post them. 

 

 

Flower Pot MK II v22_Flower Pot MK II v22_OuterPot_1_Body1_OuterPot.stl

Share this post


Link to post
Share on other sites

Here's my attempt. I am using a relative x/y z-seam hint without any corner preference. The z-seam is located on the left hand side of the little bump all the way from the bottom to the top. Hope this helps.

 

Screenshot_2018-07-26_21-48-26.thumb.png.a89ad6f95f31a8db02eb8b8df2101d01.png

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, smartavionics said:

Here's my attempt. I am using a relative x/y z-seam hint without any corner preference. The z-seam is located on the left hand side of the little bump all the way from the bottom to the top. Hope this helps.

 

Screenshot_2018-07-26_21-48-26.thumb.png.a89ad6f95f31a8db02eb8b8df2101d01.png

 

I still get this, any other settings I should look at ? 

iga1F0b.png

Share this post


Link to post
Share on other sites

Thanks for the project file. I can see what is happening. The travels across air are due to a combination of settings and a deficiencies in the version of Cura that you have. The "no skin" combing option has always been broken as it doesn't stop combing travel over skin and allows travel over air. Actually, the "no skin combing" option works OK when you understand that it actually combs over infill and nowhere else. So it should have been called the "infill only combing" option and then its behaviour would match its name perfectly! I have a fixed version submitted for a future Cura release that really does comb over non-skin areas (i.e. walls and infill). So when I use that the travels from side to side are being routed over the wall rather than through air which is why you don't see them but the travels are still happening as you can see here:

 

Screenshot_2018-07-27_08-02-13.thumb.png.5d67ae5ced9baae662058313e68caa8f.png

 

The other problem is that Cura doesn't make a good job of walls that are an odd number of lines wide. Your model has walls approx 1.2mm wide so if I was printing that I would just up the wall line width to 0.6 (which my 0.4 e3d v6 has no problem with) and you get 2 walls with no extra travels. If you want to persist with 3 walls then I recommend that you enable the wall overlap compensation and also there is a setting called Minimum Wall Flow which, when set to something like 10 or 20, will remove a lot of the lines that have been overlap compensated down to a small flow. It still wants to travel rather a lot and with the combing bug mentioned above is pretty unusable with your model.

 

Share this post


Link to post
Share on other sites

@smartavionics Well the walls are 1.2 mm ( I can change that easily with variables in fusion ) 
Edit: looks like I have calculated the value on radius and not diameter 

 

Think this the best I seen so far but I still don't under what's about the right spot.

To me it looks like it's going back to fix something it missed but it's not there on all layers. 

b3j5vwd.png

MLaHy4K.png

 

 

CFDMP_Flower Pot MK II v23_Flower Pot MK II v23_OuterPot_1_Body1_OuterPot.curaproject.3mf

Edited by varazir

Share this post


Link to post
Share on other sites

I don't think the 'no skin' should be changed in the way you describe, it would make much more sense to rename it as you have mentioned 'infil only combing'. Then a true no skin should be added as an additionally option. I would not want combing over wall, for example a thin wall, maybe two or so walls thick, will suffer if coming is used and the extra material deposited into the wall, it makes the wall look inconsistent due to the extra material. Please consider creating another option and keeping the 'infil' only combing as it is, but named correctly. That would be the best solution. 

Edited by Link

Share this post


Link to post
Share on other sites

Hello @Link, the problem with combing over infill only mode is that it doesn't recognise the existence of skin and walls and so won't avoid them and therefore the nozzle will happily traverse a skin region when moving from one side of a part to another. Personally, I would not mind if the existing "no skin" behaviour was still available as a "infill only" option as I would never use it!

 

As for combing over thin walls leading to ugliness due to extra material being deposited, there is now an option to retract when combing distance is greater than a threshold so that can be used to reduce dribble.

Share this post


Link to post
Share on other sites
24 minutes ago, varazir said:

Think this the best I seen so far but I still don't under what's about the right spot.

To me it looks like it's going back to fix something it missed but it's not there on all layers. 

 

Yes, it looks like it is going back to fix something. Anyway, as I mentioned, life gets much easier if the walls are an even number of line widths wide.

  • Like 1

Share this post


Link to post
Share on other sites
38 minutes ago, smartavionics said:

Hello @Link, the problem with combing over infill only mode is that it doesn't recognise the existence of skin and walls and so won't avoid them and therefore the nozzle will happily traverse a skin region when moving from one side of a part to another. Personally, I would not mind if the existing "no skin" behaviour was still available as a "infill only" option as I would never use it!

 

As for combing over thin walls leading to ugliness due to extra material being deposited, there is now an option to retract when combing distance is greater than a threshold so that can be used to reduce dribble.

 

 

I am sure you understand this better than me ;), but if i set min travel that will affect the whole part so even moves which would have been over infil (where I don't care about the extra material) would result in a retraction, which I don't want. Not sure I understand what you mean about the nozzle will happily traverse a skin when moving. As I understand it in all areas other than infil retractions will be applied rather than combing. Setting avoid printed parts when travelling will ensure parts are avoided, regardless of whether the move is a retraction or a comb. Certainly setting min travel, and thus enforcing more retractions will not be a great solution. As I say I am sure you understand this better than me, but I cannot see why the current mode is not good (when named correctly). The OP firsts picture shows a number of moves with are actually retractions rather than combing moves, so Cura has done what It is supposed to do. it still avoids printed parts and used retractions.

 

 

Edited by Link

Share this post


Link to post
Share on other sites
Just now, smartavionics said:

Well, I'll submit some PRs to reinstate the "not over skin" behaviour as "over infill" and the Cura developers can decide what to do.

 

Great thanks, ?

Share this post


Link to post
Share on other sites

Here's a comparison of the different combing modes. Note that this is using my Cura that has some other changes to the code that creates the combing boundaries.

 

Combing All mode - note unretracted travels over skin.

 

Screenshot_2018-07-27_11-02-26.thumb.png.74d6c8bcef16d7d86c460f6a46c28cad.png

 

 

The new Not In Skin mode avoids travels across the skin areas (what a surprise!)

 

Screenshot_2018-07-27_11-01-57.thumb.png.4f7901777d995c8558cdf8c07902b305.png

 

The new Within Infill mode (this is the old Not in Skin) does unretracted travels all over the place.

 

Screenshot_2018-07-27_11-01-30.thumb.png.35ada265472b4e2de0ca6e784b29ea3f.png

Share this post


Link to post
Share on other sites

that is odd, I don't see that sort of behaviour of 'within infil' you are seeing, I don't see any combing travel outside of infil, anything outside of that is a retraction

 

200107496_ScreenShot2018-07-27at12_58_24.thumb.png.b767cec66c612bf74eec3a26dda1d80a.png

Share this post


Link to post
Share on other sites

652872589_ScreenShot2018-07-27at13_04_09.thumb.png.edf7ac168239b3494aa8e016243bf9cd.png

 

again not seeing moves without retraction like you get, something odd there. No skin in my slice looks like your fixed version, but I haven't changed anything.

Edited by Link

Share this post


Link to post
Share on other sites

The only way I can achieve the sort of issue you are seeing is to set the 'retraction minimum travel' to a massive number, in this case 20mm, normally its set to 0.7. What value do you have for this ?

 

2018422418_ScreenShot2018-07-27at13_11_56.thumb.png.c095b4e4d4f85c5f2a34a82ca0f15b41.png

Share this post


Link to post
Share on other sites

I just tried another model and see the issue, but only on this model strangely 

 

this is no skin, but is performing coming travel (dark blue line) in the skin, I can't see why this model would be problematic but others are not...

 

 

 

Screen Shot 2018-07-27 at 13.30.14.png

Share this post


Link to post
Share on other sites
27 minutes ago, Link said:

652872589_ScreenShot2018-07-27at13_04_09.thumb.png.edf7ac168239b3494aa8e016243bf9cd.png

 

again not seeing moves without retraction like you get, something odd there. No skin in my slice looks like your fixed version, but I haven't changed anything.

 

But it's showing no-retract travels over the skin on the head, isn't it?

 

Share this post


Link to post
Share on other sites

yes, you are right !, I stand corrected !, any idea why it seems to be random, I am seeing less moves than you but as you say still moves when it shouldn't !

 

ideally then could you fix the 'comb over infil only' and also your version which will comb over walls and infil (but not skin'

 

Thanks very much, really great if these can get fixed !

Share this post


Link to post
Share on other sites
1 hour ago, Link said:

this is no skin, but is performing coming travel (dark blue line) in the skin, I can't see why this model would be problematic but others are not...

 

The old "no skin" combing fails badly when there is no infill present on the layer because no travels can hit the (non-existent) combing boundary and so all travels happen "as the crow flies" irrespective of whether they cross walls or skin.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 19 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!