Jump to content
Ultimaker Community of 3D Printing Experts
Brion

Error message This file will override machine settings with settings from the slicer

Recommended Posts

Hello.  I recently started receiving the message "this file will override machine settings with settings from the slicer".   I have an Ultimaker Extended 2+. 

 

I have scoured the internet and this community for a solution.  I have tried every suggestion I could find and I still get the same message.  My friend has the exact same printer.  We compared settings and they are exactly the same.  I created a model and converted it to .STL.   I used Cura 15.04.5 and 15.04.6 to set up the print job.  I save it to the SD and insert it in the machine. I select print and get the error.

My friend who has the exact same machine and we have identical settings can take the same model I created and set it up in Cura on his computer (same version) and save it to the same SD card I was using and I can print without any problems on my Ultimaker. 

 

I have tried multiple SD cards. 

 

Does anyone have any suggestions what I may be missing. 

 

Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

That should be a warning - not an error.

 

In cura 15.X you can go into machine settings and you want "ulticode" style gcode.

 

In reprap style gcode you set certain parameters in cura.  In ulticode you set certain parameters on the printer.  Here is an incomplete list:

nozzle temp, bed temp, fan speed (on printer it's a multiplier so in ulticode mode you use both cura and printer to set fan speed and printer multiplies the fan speeds by it's set value - e.g. ABS I think is 50%), retraction distance, retraction speed.  I forget what else.  All of these should be in the materials settings on the printer.

 

Anyway - don't think of this as an error.  Think of this as an optional way to print.  for example if you have 3 um2go's like I do, I have a different bed temp for each one but that is set on the printer, not the slicer.  So I can slice once and print it on any of my printers.  There's no "right way" or "wrong way" to do this.

Share this post


Link to post
Share on other sites
On 9/4/2018 at 2:48 PM, Brion said:

the firmware version si 15.05.5ex.

 

I'm not sure where this firmware comes from? It's probably quite old?

AFAIK the last version that came with legacy Cura was 15.04.6 - and the firmware that came later with Cura2 started with 2.x and so on.

But i may be wrong.... @gr5 did you ever heard of a version 15.05?

 

@Brion - just to be sure that we do not compare the incomparable...: can you upload the (Ulti-) gcode file that shows the warning message, perhaps someone else can have a look at it and try it on a different printer.

Have you compared the generated gcode file from your friend with yours? Perhaps can you upload his file as well.

I see that you have configured two machines in Cura, is this for a specific reason?

Share this post


Link to post
Share on other sites

Hello,

 

I attached the G-code.  The file named "DDG_plug2_top-only.gcode" is the file that works on my printer.  I created the model but to get it to print my friend had to create the g-code on his computer and save it to my sd card. 

 

The file with the name "DDG_plug2_top_only04Setp18.gcode" is the code I generated using my computer.  I get the slicer warning with this code. 

 

This morning I did an experiment by taking the file that will print and copying it and changing the name.  I get the slicer warning with this file too.  This file is named "G_code_that _will_not_work.gcode".  I created this file by copying the "DDG_plug2_top_only.gcode" and saving it with the new name.  I did this all in the Unencrypted folder. 

 

With my latest experiment it seems the issue may be from my computer.  Hopefully someone has experienced this issue before and has a solution. 

 

I configured two machines.  I made one reprap and one Ultigcode.  I have deleted both machines and created a new one that is Ultigcode.

 

Thank you for your help. 

 

 

DDG_plug2_top_only.gcode

G_code_that_will_not_work.gcode

DDG_plug2_top_only_04Sept18.gcode

Share this post


Link to post
Share on other sites
6 hours ago, Brion said:

The file with the name "DDG_plug2_top_only04Setp18.gcode" is the code I generated using my computer.  I get the slicer warning with this code.

 

Well, if the problem suddenly appears after re-naming the (formerly working) file...

what happens if you shorten the name of your file to 26 characters (or less)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!