Jump to content
Ultimaker Community of 3D Printing Experts
Artefakt

Top menu missing in Cura

Recommended Posts

The top menu in Cura is not visible. How do I solve this?

[Edit: The solution was to update the Intel HD Graphics Driver, but not through the computer's 'Dell Update' software, since it didn't find any new updates. See post below.]

 

I just installed Cura 3.4.1 in Windows 10 on a Dell XPS 13 laptop with onboard graphics and the latest drivers including the Intel HD Graphics driver.

 

Unfortunately I can not see the top menu. See attached image. Everything in the program window seem to be shifted up, so to click something I have to click about 6 mm below the visible item (the graphics are shifted up but not the click areas). Therefore it is still possible to access the invisible menu, but it is annoying not to be able to see things properly and not be able to click on the item directly.

 

I have seen similar behavior in the Libre Office suite, and to fix it in that program you have to disable OpenGL in the Libre Office settings to see the normal window with the menu at the top.

 

Any idea how to solve this problem for the Cura software?

 

 

Cura_menu_missing.jpg

Edited by Artefakt
Writing solution.

Share this post


Link to post
Share on other sites

Thanks @ahoeben for the suggestion. I had previously today updated the Intel HD Graphics driver via the 'Dell Update' software and this didn't help, and there were no more updates available according to Dell Update. But, due to your suggestion, I went to Dell's website and scanned the computer for updates, and then there were several updates available including a newer graphics driver. Lo and behold, now the windows are rendered correctly in Cura with a visible top menu, and it looks as it should.

The current working driver is:

Version 23.20.16.4973, A12
File name: Intel-HD-Graphics-Driver_10X01_WIN_23.20.16.4973_A12.EXE

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

...or visversa, yes.  I haven't tried changing the default graphics for Cura.

I think it defaulted to my certified NVidia driver. 

Updating NVidia drivers to non-certified driver risks my bread-n-butter apps.

I'll see if I can force Cura to go to the win32gdu.

 

Oh, and it is also Win7 pro.

 

I'll get there one way or another.

Share this post


Link to post
Share on other sites

I finally got to confirm the settings.  By default, my CAD-leaning Lenovo P70 running Windows 7 Pro didn't recognize Cura as a 3D app.  Similar situation with an older Dell running a similar hardware configuration.  The top bar menu simply does not show up, and mouse click positions are offset.  I know this has been going on since V2.3 because that is when I gave up on this last time.  My Win10 laptop just isn't equipped for Cura.

 

Today I added Cura as a 3D app in the NVidia desktop.  Left all the setting at default and restarted Cura.  Now Cura is running on the NVidia card and the menu finally shows up.

 

Share this post


Link to post
Share on other sites
On 9/23/2018 at 10:55 PM, ahoeben said:

If your Lenovo has both integrated graphics and an nvidia card, you could try forcing it to run on the nvidia card. The described issue is Intel-specific.

 

Yep, that was it.  Funny how NVidia didn't recognize Cura as a 3D App by default.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!