Jump to content
SandervG

New: Ultimaker Cura 3.5

Recommended Posts

Posted · New: Ultimaker Cura 3.5
2 minutes ago, P3D said:

OK, somehow Cura does not display those settings for me, even when I select "show all settings... maybe the "old" custom material profile carried over from 3.4.1 is to blame?

The feature is only enabled for Top/Bottom Pattern concentric and for infill pattern Cross.

If you are not using those and you still have random lines in the gcode then you should definitely file a new bug, because that's a major bug. Please upload a curaprofile which shows the problem in a new issue at github.com/ultimaker/cura. We really need your .curaproject.3mf file to reproduce the bug and get rid of it once and for all.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5

When people who are among the pillars of this community start complaining that way, I worry...

 

I haven't personally experienced any bugs beyond the Guide being unreadable on dark theme, which is annoying but trivial. However, since a few versions ago, I have the habit of keeping the previous version of Cura on my computer along the new one, just in case there are bugs that make my life more complicated, like the bug one or two versions ago that had the pathing go bonkers and fly off into infinity, resulting in printing time of days or a week for tiny object.

 

Asking for the help of the community for testing is good, but investment in the beta-testing will vary upon the availability of people. I helped some time ago, but I haven't been able to for a while due to a lack of print time available since I use my printer for work. Perhaps more extensive testing in-house should be done.

 

Also, about in-house testing, I wanted to ask what kind of system does UM has for those test? Do you test only on macs or also on windows machines? Do you test only on the latest version of the OS or also on previous ones (Win 8 or whatever big cat or animal name Apple used previously)? Do you test on low end computers or high end?

 

 

 

 

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
Just now, bagel-orb said:

 We really need your .curaproject.3mf file to reproduce the bug and get rid of it once and for all.

 

I thought the 'curaproject' extension had been removed?

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
1 minute ago, bagel-orb said:

The feature is only enabled for Top/Bottom Pattern concentric and for infill pattern Cross.

If you are not using those and you still have random lines in the gcode then you should definitely file a new bug, because that's a major bug. Please upload a curaprofile which shows the problem in a new issue at github.com/ultimaker/cura. We really need your .curaproject.3mf file to reproduce the bug and get rid of it once and for all.

 

Just did that, see https://github.com/Ultimaker/Cura/issues/4575

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
1 minute ago, Brulti said:

 

I thought the 'curaproject' extension had been removed?

I said it that way just to make clear that I don't want the export of the 3D model only in the 3mf file....

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
2 hours ago, kmanstudios said:

And c) You are right, you guys get to work on the really fun stuff that gets a lot of cool reviews, such as the gyroid infill, so, I do feel for them, but first bug that begged me off upgrading is that the 'dark' UI did not even display the right side interface. I feel that was a warning sign of issues to beware of and, it does seem to be a good thing, from what I have read so far.

I just opened Cura 3.5.0 for the first time and I have no problems with the Dark UI...

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
5 minutes ago, bagel-orb said:

The feature is only enabled for Top/Bottom Pattern concentric and for infill pattern Cross.

If you are not using those and you still have random lines in the gcode then you should definitely file a new bug, because that's a major bug. Please upload a curaprofile which shows the problem in a new issue at github.com/ultimaker/cura. We really need your .curaproject.3mf file to reproduce the bug and get rid of it once and for all.

 

By the way, also see this thread: 

 Maybe it's already fixed in the master branch, sorry that I can't verify this myself, at my work computer I can't just set up a build environment and compile stuff my self, since program installation is all managed by our IT department.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
7 minutes ago, bagel-orb said:

I just opened Cura 3.5.0 for the first time and I have no problems with the Dark UI...

Saw a screenshot somewhere of it. since I saw that, I never upgraded between prints.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
13 minutes ago, Brulti said:

When people who are among the pillars of this community start complaining that way, I worry...

I would not worry. I would just be cautious as with any upgrade.

 

Here is the thing about this: I have had upgrades from paid software that were not really that good. Having said that, I would like team cura to consider that as Ultimaker moves to create a visible business solution it will become imperative to not mess up pipelines. One of the reasons so many businesses are not going to hop on the latest and greatest immediately as it can mess up a lot of things that are more of a pain to fix than to just wait a bit.

 

Nobody is making anybody upgrade. But, right now, I am a bit more cautious. It is one of the things that keeps me from beta testing the software many times. If I am  in the middle of a production cycle, I just cannot let upgrades or even testing flummox things up.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5

Is there a timline, when version 3.5.1 will be released? I couldn't use Cura 3.5 with my MK3, because of the wrong temperature in the gocde. On GitHub they wrote thye will fix it with 3.5.1

  • Like 1

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
19 minutes ago, Laire said:

On GitHub they wrote thye will fix it with 3.5.1

 

On Github they also wrote workarounds for 3.5.0

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
5 hours ago, bagel-orb said:


That's because we all have a lot of experience in writing Cura code. I have worked on Cura full time for 3 years, while the Cura team is growing and so it also has some people who are newer to the code base.

Also the Cura team might take on tasks which are more challenging or more bug-prone.

 

Although I am not using 3.5.0 (due to a bug in importing my profiles); with a background in industrial PLC programming, I can appreciate the hard work and complexity that goes into making a program like this. Especially a program that is offered for free. If you are unhappy enough, you can buy Simplify3D. 

 

Thanks for the hard work. 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
7 minutes ago, James777 said:

If you are unhappy enough, you can buy Simplify3D. 

I own S3D and, since I own S3D, you think it invalidates my, and other's comments to very real issues and should just move along or, look for a more robust solution? I am not doing that by choice. I am offering experience on things from ages ago when there were things that had to be solid or could have real implications for the company or even the health of an individual? Does it ruffle up feathers? I would guess so seeing from replies. But, not one reply from internal offered any sort of mea culpa and then to evolve from this situation. I find that to be the most overlooked thing. And, as an owner of S3D, I stick with Cura because I have faith. But, I did invest for a reason.

 

Frankly, if you are moving into industrial arenas and, tout the combined solution of hardware and software, then it is a problem. Do you really expect Volkswagen to be told, "Go buy this software," with the implication that they cannot solve the issues?

 

And, the "It's for free" argument is a crutch. So is, "It's hard."  If it was not hard, then everybody would do it for themselves. We get that it is hard. I can program. But I see where people can boil down a solid piece of robust code to just a few tens or hundred of lines that I meally about with a thousand lines or more. But, being free is what they, the owners decided to do. It is for free because they decided to be that way. Maybe time for a premium, rock solid, ready for the industrial world version? I could get behind that. And, still offer the basic version for free. But then, you would not get the really fun stuff being developed by volunteers without a price increase somewhere.

 

When it does go awry, it is time to figure out why it is not up to snuff and not get defensive. There are valid arguments here in this thread. But the worst is the take it or leave it approach. That would not be good as that would lead to other people looking for more robust solutions. And, to reiterate, I use Cura even though I own S3D.

 

And, to be honest, if I were to apply my experience, it is the powers above team cura that make things unrealistic and not focus on basic robustness.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
27 minutes ago, James777 said:

. If you are unhappy enough, you can buy Simplify3D. 

I'm not sure whether Simplify3D will make you more happy, though.

The fact that it's paid doesn't mean it's better.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
8 minutes ago, bagel-orb said:

I'm not sure whether Simplify3D will make you more happy, though.

As an owner who uses Cura, it is not because it is free, but the promise of a solid hardware/software solution.

 

9 minutes ago, bagel-orb said:

The fact that it's paid doesn't mean it's better. 

I will agree with that.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
10 minutes ago, bagel-orb said:

I'm not sure whether Simplify3D will make you more happy, though.

The fact that it's paid doesn't mean it's better.

 

I fully agree with this. There are many paying softwares out there that aren't better than their free counterparts.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
44 minutes ago, Brulti said:

 

I fully agree with this. There are many paying softwares out there that aren't better than their free counterparts.

True but I’ve gone back to S3D as for some reason, with similar settings, I can’t get results with ABS X.  But with S3D they are border line perfect. 

 

I have no idea  why this is. I am using bond tech QR mods but shouldn’t make a difference. 

 

But it I am truly gutted. I’ve not used S3D for about 2 years. 

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
On 10/4/2018 at 4:26 AM, OttoRenner said:

The filament diameter for the Ender 3 is wrong by default in the Cura profile. Go to the machine settings for the Ender, choose the tab "Extruder 1" and change the setting for "Compatible filament diameter" from 2.85mm to 1.75mm. 

I just installed 3.5 for Mac. New user, trying to figure it out. I don't have Ender 3 as a machine choice - am I missing something (plugins, configuration files, etc)? I am ultimately trying to learn how to print directly using USB, and use a control interface for jogging and manual extrusion, etc

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5

Whoops, I had downloaded the Lulzbot edition by mistake. Now have the real 3.5. Please disregard previous post

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
5 hours ago, Link said:

I don't get why people are bashing the UM team here, this software is free !!!! and whilst anyone who works in software development knows you can't find every issue, it's how you deal with it when they come up.

 

I think, if you are going to charge a premium for your machines and target a professional customer you really need to have your house in order.  The software is free, yes, but it is companion software to expensive hardware.  Releasing software in this state in my opinion is unprofessional and damages Ultimakers reputation. 

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
11 minutes ago, Bigbrit said:

 

I think, if you are going to charge a premium for your machines and target a professional customer you really need to have your house in order.  The software is free, yes, but it is companion software to expensive hardware.  Releasing software in this state in my opinion is unprofessional and damages Ultimakers reputation. 

@bigbrit - except that this software is free to use for ANY printer, not just Ultimakers. I considerate it generous that they are willing to offer it for free to competitors hardware. You have many other options besides Cura so I don't see your point.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
Just now, svenyonson said:

@bigbrit - except that this software is free to use for ANY printer, not just Ultimakers. I considerate it generous that they are willing to offer it for free to competitors hardware. You have many other options besides Cura so I don't see your point.

 

But I do not own another printer, I own an S5.  It may be free for other printers but that does not concern me at all.  It is the companion software to the hardware I own, the whole point of it is that if you buy an Ultimaker printer you use ultimaker software and ultimaker materials for a seamless experience.  If the software is buggy then that whole process breaks down.

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
1 hour ago, svenyonson said:

Whoops, I had downloaded the Lulzbot edition by mistake. Now have the real 3.5. Please disregard previous post

 

?  I think we have all made some similar mistake ?

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
1 minute ago, Bigbrit said:

 

But I do not own another printer, I own an S5.  It may be free for other printers but that does not concern me at all.  It is the companion software to the hardware I own, the whole point of it is that if you buy an Ultimaker printer you use ultimaker software and ultimaker materials for a seamless experience.  If the software is buggy then that whole process breaks down.

 

True, in that case I do see your point - and I agree. A friend just bought an S5 and it is very expensive. Not unreasonable to expect 1st rate software to go along with it.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · New: Ultimaker Cura 3.5
18 minutes ago, Bigbrit said:

 

I think, if you are going to charge a premium for your machines and target a professional customer you really need to have your house in order.  The software is free, yes, but it is companion software to expensive hardware.  Releasing software in this state in my opinion is unprofessional and damages Ultimakers reputation. 

 

That would be slightly relevant if the only users of Cura were Ultimaker owners, and if what they released meant people could not use their printers !. Two points there, the vast majority of Cura users I bet aren’t only Ultimaker owners, and lets be honest, the only issue is here that (some ) people cannot use one version of Cura. It’s not like 3.4.1 doesn’t work !. There are some great additions in 3.5 but it’s not like 3.4.1 wasn’t useable !, far from it. 

 

Agree the software shouldn’t have bugs in it but UM are aware of this better than anyone and are fixing it. 

 

Ultimaker 2+ owners should be a lot more upset by the firmware which still hasn’t been fixed to correct the fact the material gets rammed into the hot end every time you change material !. I am a lot more concerned about a fix for this. Tbh I don’t get the stress over this issue when UM have acknowledge and are working on it !. 

 

Now UM team please release the 3.5 firmware for the 2+ ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!