Jump to content
Shelton

Cura software and Raise 3D Pro Plus

Recommended Posts

Posted · Cura software and Raise 3D Pro Plus

Hello everybody. I'm using Idea Maker with my Raise Pro Plus 2 but Cura software is more professional and full of new features. So I need help from you. Do you have some settings to use Cura with Raise Pro Plus 2? I tried with G-code input lines but still didn't work. Anybody can help me with that issue? thank you

Share this post


Link to post
Share on other sites
Posted · Cura software and Raise 3D Pro Plus

Hello everybody too!

I'm in the same position of Shelton. I'm falling in love whit CURA slicer (it's particolarly usefull) but unfortunately the generated g-code don't match with Raise Pro 2 (and Pro Plus).

Any support will be well accepted!!

Share this post


Link to post
Share on other sites
Posted · Cura software and Raise 3D Pro Plus

Please can someone help get Cura working on the raise 3D pro2?! We need a single slicer that works across all our printers. Ideamaker is not that. If Cura cant we will have to abandon it also.

 

For the same settings ideamaker takes roughly double the print time than cura (bad travel move choices), creates supports that fall down, and has far fewer advanced options.

 

Share this post


Link to post
Share on other sites
Posted · Cura software and Raise 3D Pro Plus

I used Google Translator to read the above-linked thread. It appears you can use the start/end gcode provided in the initial reply by @Guillaume777

Quote

 

The G-code start / end print of S3D works in Cura.

 

Starting :

M221 T0 S100

G28 X0 Y0

G28 Z0

T0

G1 X5 Y5 Z0.2 F2000

G92 E0

G1 X100 E30 F600

G1 X120 F5000

M117 Printing ...

M1001

 

End :

M107

M1002

M104 S0 T1

M104 S0 T0

M140 S0

M117 Print Complete.

G28 X0 Y0

G91

G1 Z10

G90

M84

 

 

 

 

 

Share this post


Link to post
Share on other sites
Posted · Cura software and Raise 3D Pro Plus

To make g-code in Cura for the Raise3D Pro2 Dual I created a new printer type by copying the Raise3D N2 Dual and updating the print dimensions X/Y/Z = 280/305/300mm. I also had to make a small change to the "Start G-code" in the printer machine settings. The default g-code makes two calls of "M92 E140", which sets the number of steps per unit. I think there might be some unit confusion happening here because it effectively stops the printer from extruding anything.

 

After rebooting the printer to reload the original M92 value and commenting out those two commands in the Start G-code section it prints just fine.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura software and Raise 3D Pro Plus

@Mblaughton , Bonjour, et merci pour ton retour.

Comment faire pour changer le gcode dans l'imprimante ?

Les fonctions "détection de filament" et "coupure de courant " marche correctement .

merci

 

-------

 

Mblaughton, Hello, and thank you for your feedback.

How to change the gcode in the printer?

The "filament detection" and "power failure" functions work correctly.

thank you

Edited by Smithy
Translated to English

Share this post


Link to post
Share on other sites
Posted · Cura software and Raise 3D Pro Plus

@Guillaume777 Could you please post your message in English in this thread - thanks!

Share this post


Link to post
Share on other sites
Posted · Cura software and Raise 3D Pro Plus
 

 

@ Mblaughton, Hello, and thank you for your return.

How to change the code in the state?

The functions "filament detection" and "power failure" work correctly.

thank you

Share this post


Link to post
Share on other sites
Posted (edited) · Cura software and Raise 3D Pro Plus

To make our Raise3D Pro2 Dual printers work with Cura I ended up copying and modifying the Raise3D N2 definitions to create a custom printer type (files attached). To use them, unzip the attached zip file into your "C:\Program Files\Ultimake Cura 4.3\resources\definitions" directory (assuming Windows) and hopefully Cura will offer it as a printer option after you restart.

 

I updated the build plate dimensions in the new definition, but the main fix involved updating the extruders' "steps per unit" setting in the "machine start g-code" section, which went from E140 to E6640. The new value is based on the number I found in the printer's menus.

 

Please note:

  • This definition is for the regular Pro2 Dual, not the "Plus" model. I suspect it would work on both though.
  • I have used this definition to make several prints, but your mileage may vary. (i.e., it's not an official solution)
  • If you want to be extra cautious, you can confirm that your printer uses the same "steps per unit=6640" before attempting a print. It's located under "Home > Settings (gear icon) > Machine > More Settings > Hardware > Steps Per Unit > E Steps Per Unit".

If you end up trying it can you reply back and let us know if it works for you?

raise3D_Pro2_dual.custom.def.zip

Edited by mblaughton
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!